Skip to content

Commit

Permalink
media-video/gaupol: bump to 1.0
Browse files Browse the repository at this point in the history
Closes: gentoo#2697
Package-Manager: portage-2.3.2
  • Loading branch information
sbraz authored and mgorny committed Oct 31, 2016
1 parent 239d0c8 commit b66fb57
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-video/gaupol/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gaupol-0.91.tar.gz 518493 SHA256 cb7d2d3fa4dfd321802eb6c3dd0a2f9582a9195a70b153d0ce65f2dfa9048add SHA512 92459ec0a7d77c8e4a34f44489ae8fc01feeb2d34f6fd152c8bfeaf72b8235c680155698c55e7f9d46ce82bee8274b14313b6a43167f65f784511e583d4858fb WHIRLPOOL 7d46d9bb20d104355f16a966a46e25eb76e8cb72fa5082b9526a6ee3b012312dc1e5a6a74d6fe850cce40d9ce993b4a06471ec93ac907bb1f3de30409217ff43
DIST gaupol-0.92.tar.gz 519991 SHA256 790928bb7863d4f1484bcd907f23f8b938f71b491860d51e497e63729e1e3bf8 SHA512 828bba44b8fbf2c2ab074a1479b1b9cc4e42eee98d87e5f32f049bc2c34ccfbdf9488256b794a134f93d4c01249c42361f72bf9df5819e528d59e9e7285f9dd3 WHIRLPOOL 7acb87b80e7a534fee19b40fbebaf99ae586bce49957122211ead814a9c597dbea76bda52c539414f01bfacb5a5e235d7116ac1337b1d30083d5582ef67d4fe3
DIST gaupol-1.0.tar.gz 520620 SHA256 bc407489855eb0a7a8bda6f6fcc7fcbe6136582cc588ec081750b8546f311e3b SHA512 1f6a9ff1bf6722473aa53c9c8e787ce9d25669bbafe19b4c117965bf281307365cb4cd31241af92b0623ead8a9627d38c5811d5b361c8707ac3467d520c1d89c WHIRLPOOL 50cd2546cc48538c8095ad9fbb9eb71efb6ea8cd038fa9ad217cf5a502c6cfee9530e94a8da9f69e60fbd9c511c112c9fbebc62a24edec10049e80b135c7232d
61 changes: 61 additions & 0 deletions media-video/gaupol/gaupol-1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python{3_3,3_4,3_5} )

inherit distutils-r1 gnome2-utils virtualx xdg-utils

DESCRIPTION="A subtitle editor for text-based subtitles"
HOMEPAGE="http://otsaloma.io/gaupol/"
SRC_URI="https://github.com/otsaloma/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="spell test"

RDEPEND="app-text/iso-codes
dev-python/chardet[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
x11-libs/gtk+:3[introspection]
spell? (
app-text/gtkspell:3
>=dev-python/pyenchant-1.4[${PYTHON_USEDEP}]
)"
DEPEND="${RDEPEND}
dev-util/intltool
sys-devel/gettext
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-runner[${PYTHON_USEDEP}]
)
"

DOCS=( AUTHORS.md NEWS.md TODO.md README.md README.aeidon.md )

pkg_postinst() {
xdg_desktop_database_update
xdg_mimeinfo_database_update
gnome2_icon_cache_update
if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "Previewing support needs MPV, MPlayer or VLC."

if use spell; then
elog "Additionally, spell-checking requires a dictionary, any of"
elog "Aspell/Pspell, Ispell, MySpell, Uspell, Hspell or AppleSpell."
fi
fi
}

python_test() {
virtx py.test
}

pkg_postrm() {
xdg_desktop_database_update
xdg_mimeinfo_database_update
gnome2_icon_cache_update
}

0 comments on commit b66fb57

Please sign in to comment.