Skip to content

Commit

Permalink
app-admin/calamares: Version bump 2.4.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
johu committed Oct 14, 2016
1 parent 23242ee commit b75121c
Show file tree
Hide file tree
Showing 4 changed files with 85 additions and 2 deletions.
1 change: 1 addition & 0 deletions app-admin/calamares/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST calamares-2.3.tar.gz 2029483 SHA256 c499a8a8ea1573c6f0323398fb092f8978958202e11c9d339202c35c73276f9f SHA512 be0b1e328ebd6bddab3a163bf38649fd4f64cfe74213946f00b0d05c76fba870662386328c0ccb7656dc63975a1b28058be7eda56b2cee792fba78443ab6d36e WHIRLPOOL aa1602aa06a4320f5a263c24e17c322bbdfcd83b7f11012e4b2cec895d6a18cdbf627d82f614ace60c62572374a9fb247216619fa0a4de207e3f8267bf51cd9e
DIST calamares-2.4.1.tar.gz 2135702 SHA256 ab1ea9c57bfeccea1282813fa67d3ee97ee03f8673af002c13fdda8dc75ef028 SHA512 8720c04cdd6ccc8f18f4a81e9ae213aa1e049f5bcd0af2521161b1adb9faebb217a6a06a30ca37ee7096b200984f271863752cca29f5225196f0306a8ef2ec2c WHIRLPOOL 12be30182b2d2c1c959743d84a0212a9db8ae93ad93c1e377e359a54617914183008b5a4ad6cedce482968bf7b71faa87097c21b8358b3d09ff9258de9223e1a
DIST calamares-2.4.tar.gz 2134756 SHA256 5519077c79fe1964dd9bf1ae6aedff202bb3c2e3289398affd7e7946672f7f3e SHA512 5119f2203358a794a66aa26e052bdd58e0d5197d1dcd5cd7be83a3e3f7c466096221e3f4b0cd89b5205fcbf3c1fe1cd19aea77facae4980a78ef1f7943cbaac2 WHIRLPOOL 51a5ccd8403baffc7b1365a456ed807b5f43fc6dc1a789566344c8ef7426e340481dab8707caf836392a666684ea4ebb58bd48695cf27d7f2755426f429da8fb
2 changes: 1 addition & 1 deletion app-admin/calamares/calamares-2.3.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -47,7 +47,7 @@ RDEPEND="${DEPEND}
net-misc/rsync
sys-apps/gptfdisk
>=sys-block/parted-3.0
|| ( sys-boot/grub:2 sys-boot/gummiboot )
|| ( sys-boot/grub:2 sys-boot/systemd-boot )
sys-boot/os-prober
sys-fs/squashfs-tools
sys-fs/udisks:2[systemd]
Expand Down
82 changes: 82 additions & 0 deletions app-admin/calamares/calamares-2.4.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,82 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python{3_4,3_5} )
inherit kde5 python-r1

DESCRIPTION="Distribution-independent installer framework"
HOMEPAGE="http://calamares.io"
if [[ ${KDE_BUILD_TYPE} == live ]] ; then
EGIT_REPO_URI="git://github.com/${PN}/${PN}"
KEYWORDS=""
else
SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~amd64"
fi

LICENSE="GPL-3"
IUSE="+networkmanager +upower"

REQUIRED_USE="${PYTHON_REQUIRED_USE}"

DEPEND="${PYTHON_DEPS}
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kparts)
$(add_frameworks_dep kservice)
$(add_qt_dep qtdbus)
$(add_qt_dep qtdeclarative)
$(add_qt_dep qtgui)
$(add_qt_dep qtnetwork)
$(add_qt_dep qtsvg)
$(add_qt_dep qtwebengine 'widgets')
$(add_qt_dep qtwidgets)
>=dev-cpp/yaml-cpp-0.5.1
>=dev-libs/boost-1.55:=[${PYTHON_USEDEP}]
sys-apps/dbus
sys-apps/dmidecode
sys-auth/polkit-qt[qt5]
>=sys-libs/kpmcore-2.2.0:5=
"

RDEPEND="${DEPEND}
app-admin/sudo
dev-libs/libatasmart
net-misc/rsync
sys-apps/gptfdisk
>=sys-block/parted-3.0
|| ( sys-boot/grub:2 sys-boot/systemd-boot )
sys-boot/os-prober
sys-fs/squashfs-tools
sys-fs/udisks:2[systemd]
virtual/udev[systemd]
networkmanager? ( net-misc/networkmanager )
upower? ( sys-power/upower )
"

src_prepare() {
python_setup
export PYTHON_INCLUDE_DIRS="$(python_get_includedir)" \
PYTHON_INCLUDE_PATH="$(python_get_library_path)"\
PYTHON_CFLAGS="$(python_get_CFLAGS)"\
PYTHON_LIBS="$(python_get_LIBS)"

eapply_user
}

src_configure() {
local mycmakeargs=(
-DWEBVIEW_FORCE_WEBKIT=OFF
)

kde5_src_configure
sed -i -e 's:pkexec /usr/bin/calamares:calamares-pkexec:' "${S}"/calamares.desktop
sed -i -e 's:Icon=calamares:Icon=drive-harddisk:' "${S}"/calamares.desktop
}

src_install() {
kde5_src_install
dobin "${FILESDIR}"/calamares-pkexec
}
2 changes: 1 addition & 1 deletion app-admin/calamares/calamares-2.4.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -47,7 +47,7 @@ RDEPEND="${DEPEND}
net-misc/rsync
sys-apps/gptfdisk
>=sys-block/parted-3.0
|| ( sys-boot/grub:2 sys-boot/gummiboot )
|| ( sys-boot/grub:2 sys-boot/systemd-boot )
sys-boot/os-prober
sys-fs/squashfs-tools
sys-fs/udisks:2[systemd]
Expand Down

0 comments on commit b75121c

Please sign in to comment.