forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-crypt/signing-party: Version bump (v2.11)
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <[email protected]>
- Loading branch information
Showing
2 changed files
with
116 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST signing-party_2.10.orig.tar.gz 222778 BLAKE2B b2225ba3038037a8f841e5f2ee8c5f08f3fe294e617c42396269aadf348965a17151bb31b11a76b2d84806e060cb0eb1093963f72e17bb5549ac6fbec0e332fb SHA512 82e51b91c282a72e9d16d920b87560c66aeafc0219e91615ea47d2f1a5df903fb459201f34368e6fa7ea1e2d2ca46a73096f30a068c8c35322af2f3ea256b269 | ||
DIST signing-party_2.11.orig.tar.gz 224706 BLAKE2B 6ef03d9e7e5652b7da77facc3206d25de63958a56ef64c0393b9964e1653c099dc022be5c80a02041418aee9dcb74e4fc0c448198b1deade79e59372cb8308c0 SHA512 9a34bde415bf779859b48eaab12e5c6a1a3f08d0292cd5cd691518e398fe40a73b878926d3ea1ef12ccca40179933478d03ec16ec4d9200fb726aaade541505d |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,115 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit toolchain-funcs autotools | ||
|
||
DESCRIPTION="A collection of several tools related to OpenPGP" | ||
HOMEPAGE="https://salsa.debian.org/signing-party-team/signing-party" | ||
SRC_URI="mirror://debian/pool/main/s/signing-party/${PN}_${PV}.orig.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~x86" | ||
|
||
DEPEND="dev-lang/perl | ||
app-crypt/libmd" | ||
RDEPEND="${DEPEND} | ||
>=app-crypt/gnupg-1.3.92 | ||
dev-perl/GnuPG-Interface | ||
dev-perl/Text-Template | ||
dev-perl/MIME-tools | ||
net-mail/qprint | ||
>=dev-perl/MailTools-1.62 | ||
dev-perl/Net-IDN-Encode | ||
virtual/mailx | ||
virtual/mta | ||
|| ( | ||
dev-perl/libintl-perl | ||
dev-perl/Text-Iconv | ||
app-text/recode | ||
)" | ||
|
||
src_prepare() { | ||
default | ||
|
||
# app-crypt/keylookup | ||
rm -r keylookup || die | ||
sed -i -e 's#keylookup/keylookup##' Makefile || die | ||
|
||
# media-gfx/springgraph | ||
rm -r springgraph || die | ||
|
||
find . -name Makefile | xargs sed -i -e 's/CFLAGS:=/CFLAGS=/' -e 's/CPPFLAGS:=/CPPFLAGS=/' -e 's/LDFLAGS:=/LDFLAGS=/' | ||
|
||
sed -i -e 's/autoreconf/true/g' keyanalyze/Makefile || die | ||
pushd keyanalyze/pgpring || die | ||
eautoreconf | ||
popd || die | ||
} | ||
|
||
src_compile() { | ||
emake \ | ||
CC="$(tc-getCC)" \ | ||
CPPFLAGS="${CPPFLAGS}" \ | ||
CFLAGS="${CFLAGS}" \ | ||
LDFLAGS="${LDFLAGS}" \ | ||
STRIP=true | ||
} | ||
|
||
src_install() { | ||
einstalldocs | ||
|
||
# Check Makefile when a new tool is introduced to this package. | ||
# caff | ||
dobin caff/caff caff/pgp-clean caff/pgp-fixkey | ||
docinto caff | ||
dodoc caff/{README*,THANKS,TODO,caffrc.sample} | ||
# gpgdir | ||
dobin gpgdir/gpgdir | ||
docinto gpgdir | ||
dodoc gpgdir/{VERSION,LICENSE,README,INSTALL,CREDITS,ChangeLog*} | ||
# gpg-key2ps | ||
dobin gpg-key2ps/gpg-key2ps | ||
docinto gpg-key2ps | ||
dodoc gpg-key2ps/README | ||
# gpglist | ||
dobin gpglist/gpglist | ||
# gpg-mailkeys | ||
dobin gpg-mailkeys/gpg-mailkeys | ||
docinto gpg-mailkeys | ||
dodoc gpg-mailkeys/{example.gpg-mailkeysrc,README} | ||
# gpgparticipants | ||
dobin gpgparticipants/gpgparticipants | ||
# gpgwrap | ||
dobin gpgwrap/bin/gpgwrap | ||
docinto gpgwrap | ||
dodoc gpgwrap/{LICENSE,NEWS,README} | ||
doman gpgwrap/doc/gpgwrap.1 | ||
# gpgsigs | ||
dobin gpgsigs/gpgsigs | ||
insinto /usr/share/signing-party | ||
# keyanalyze | ||
# TODO: some of the scripts are intended for webpages, and not really | ||
# packaging, so they are NOT installed yet. | ||
newbin keyanalyze/pgpring/pgpring pgpring-keyanalyze | ||
dobin keyanalyze/{keyanalyze,process_keys} | ||
docinto keyanalyze | ||
dodoc keyanalyze/{README,Changelog} | ||
# See app-crypt/keylookup instead | ||
#dobin keylookup/keylookup | ||
#docinto keylookup | ||
#dodoc keylookup/NEWS | ||
# sig2dot | ||
dobin sig2dot/sig2dot | ||
dodoc sig2dot/README.sig2dot | ||
# gog-key2latex | ||
dobin gpg-key2latex/gpg-key2latex | ||
# See media-gfx/springgraph instead | ||
#dobin springgraph/springgraph | ||
#dodoc springgraph/README.springgraph | ||
# all other manpages, and the root doc | ||
doman */*.1 | ||
dodoc README | ||
} |