Skip to content

Commit

Permalink
games-rpg/manaplus: Bump to version 1.7.4.29
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
Lars Wendler committed May 2, 2017
1 parent 69931a7 commit b813571
Show file tree
Hide file tree
Showing 2 changed files with 99 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-rpg/manaplus/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST manaplus-1.7.4.1.tar.xz 14800880 SHA256 9422f6c1d7a79a69a8c89c70f3608f7d3afc5d77faae04fd1457f5f7c96bace1 SHA512 3338b193a5a91e3cf8bdee28e1344fcb1fbdeea1edf14fa2257560fb2200656dbe2bbef7dd4df7a7796344c4b01f3974df239a3ab9d005ef7797268c20bd6b9e WHIRLPOOL 800d659b17b2415ea632159263612349100d78098e5f7d05c98713ab6747333d9c713014746bf2c9188d39c7cdd495e511970e5ecad74be662b09cc387bf5c35
DIST manaplus-1.7.4.15.tar.xz 14796748 SHA256 d6916bdc2587747bfe7fc2b1b67ae6e88284613a9f0001e2b6ccf2b8b40d3734 SHA512 c97f849c047ec37ae0a6a445b5a520e441fd452c2e7e0e3ae0a2a494a88027c1cf34c4f7dc860b811e58dac5b2e165d231fc4fbf22defe9a241291caa4762b23 WHIRLPOOL bf76c3de7663d4f08906962b7df6421e9f4495b85166dc68b31da8641a4d07f8a25c82482f3b94b40cebb20a47ff806a3b39300335828b6a603f25a27911795d
DIST manaplus-1.7.4.29.tar.xz 14816088 SHA256 08048156c97255b1b1311a912c6b7224a7f7ade2d2bfaee0375968ee843b5f48 SHA512 0ba95ee6f9f3b18e53bc61047b4a5779faf76c9eb88d49e7f2e171cd13fc211c574d02e8b38b3e6a382bfa82e28db37d7908058054bd7a010615fabbf6dd2c7d WHIRLPOOL e7a654ebd350efda80321c32ba3395f0b5099d4e25725e84fdb01a3a0421aa3bf19c012c025cc3a74c8eaaec94fedf978e15e33467ae5699569d4e21a1463255
98 changes: 98 additions & 0 deletions games-rpg/manaplus/manaplus-1.7.4.29.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,98 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
[[ ${PV} == 9999 ]] && inherit autotools git-r3

DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
HOMEPAGE="http://manaplus.evolonline.org"
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/ManaPlus/ManaPlus.git"
else
SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="GPL-2+"
SLOT="0"
IUSE="mumble nls opengl pugixml +sdl2 test"

RDEPEND="
>=dev-games/physfs-1.0.0
media-fonts/dejavu
media-fonts/liberation-fonts
media-fonts/mplus-outline-fonts
media-fonts/wqy-microhei
media-libs/libpng:0=
net-misc/curl
sys-libs/zlib
x11-apps/xmessage
x11-libs/libX11
x11-misc/xdg-utils
mumble? ( media-sound/mumble )
nls? ( virtual/libintl )
opengl? ( virtual/opengl )
pugixml? ( dev-libs/pugixml )
!pugixml? ( dev-libs/libxml2 )
sdl2? (
media-libs/libsdl2[X,opengl?,video]
media-libs/sdl2-gfx
media-libs/sdl2-image[png]
media-libs/sdl2-mixer[vorbis]
media-libs/sdl2-net
media-libs/sdl2-ttf
)
!sdl2? (
media-libs/libsdl[X,opengl?,video]
media-libs/sdl-gfx
media-libs/sdl-image[png]
media-libs/sdl-mixer[vorbis]
media-libs/sdl-net
media-libs/sdl-ttf
)"
DEPEND="${RDEPEND}
virtual/pkgconfig
nls? ( sys-devel/gettext )"

src_prepare() {
default
if [[ ${PV} == 9999 ]] ; then
eautoreconf
fi
}

src_configure() {
CONFIG_SHELL=/bin/bash \
econf \
--localedir=/usr/share/locale \
--without-internalsdlgfx \
$(use_with mumble) \
$(use_enable nls) \
$(use_with opengl) \
--enable-libxml=$(usex pugixml pugixml libxml) \
$(use_with sdl2) \
$(use_enable test unittests)
}

src_install() {
default

local destpath="/usr/share/${PN}"
dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${destpath}"/data/fonts/dejavusans-bold.ttf
dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${destpath}"/data/fonts/dejavusans.ttf
dosym /usr/share/fonts/dejavu/DejaVuSansMono-Bold.ttf "${destpath}"/data/fonts/dejavusansmono-bold.ttf
dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${destpath}"/data/fonts/dejavusansmono.ttf
dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed-Bold.ttf "${destpath}"/data/fonts/dejavuserifcondensed-bold.ttf
dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed.ttf "${destpath}"/data/fonts/dejavuserifcondensed.ttf
dosym /usr/share/fonts/liberation-fonts/LiberationMono-Bold.ttf "${destpath}"/data/fonts/liberationsansmono-bold.ttf
dosym /usr/share/fonts/liberation-fonts/LiberationMono-Regular.ttf "${destpath}"/data/fonts/liberationsansmono.ttf
dosym /usr/share/fonts/liberation-fonts/LiberationSans-Bold.ttf "${destpath}"/data/fonts/liberationsans-bold.ttf
dosym /usr/share/fonts/liberation-fonts/LiberationSans-Regular.ttf "${destpath}"/data/fonts/liberationsans.ttf
dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-bold.ttf "${destpath}"/data/fonts/mplus-1p-bold.ttf
dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-regular.ttf "${destpath}"/data/fonts/mplus-1p-regular.ttf
dosym /usr/share/fonts/wqy-microhei/wqy-microhei.ttc "${destpath}"/data/fonts/wqy-microhei.ttf
}

src_test() {
make check
}

0 comments on commit b813571

Please sign in to comment.