Skip to content

Commit

Permalink
dev-util/android-studio: bump to 3.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.8, Repoman-2.3.3
  • Loading branch information
perfinion committed Oct 29, 2017
1 parent 09bd348 commit b839dcc
Show file tree
Hide file tree
Showing 2 changed files with 109 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/android-studio/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST android-studio-ide-162.3934792-linux.zip 459976690 SHA256 6e33a232466820a15c884af9faefab772b8267ede056aaedb63f291ceb5e95a7 SHA512 ff563d4c1adca5ae153bf23cde39cda4b462097706e92eb09e9850b07902388cdc569e479d7c8be7d27dca24f897797810534e54a113d043436c312637d62184 WHIRLPOOL 3d44bf16988c280d5ee6df1ee9a7c664a46a58107a73d001d493580f6ca365428a164a5ab9a6fb48fce730c0a19bc3b82a0f891c23131755c659842fe506aa3d
DIST android-studio-ide-162.4069837-linux.zip 490782431 SHA256 1383cfd47441e5f820b6257a1bdd683e0e980bc76c7f2027ef84dc2e6ad2f17f SHA512 44f093ce4c97211913bb979fb28d5fe43163462ce6153c31c03576d872e11cbc11651f10397e14247ca41ea269a3cb0998e9e7d37fc63ac6782cc653037d925c WHIRLPOOL ed833816f48abba51d8142fda91175c07f019f40a3ed21ea026367870723016c17262c0eccb71d3d85a5f963ca0a84b0ee2111ae15f95ad92ac565f225d6c10a
DIST android-studio-ide-171.4408382-linux.zip 771324214 SHA256 7991f95ea1b6c55645a3fc48f1534d4135501a07b9d92dd83672f936d9a9d7a2 SHA512 7637cc2bfd808cd641d8420e8f5a53660139f37beaf822b7b6a3bb49369d7f5a4e5ccfc805d914ff82eee3065d694a7c3d92b53ced88090ad15d57dae4e7e737 WHIRLPOOL b8b78d6838d960313d10bba98bf3deaf6e9e1defad0d6288c7108228210d8c3a6d9b92de38620f4c9ed43338d425605437d45f19e57c56eb369e10f046e9322d
108 changes: 108 additions & 0 deletions dev-util/android-studio/android-studio-3.0.0.18.171.4408382.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,108 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit eutils java-pkg-2 versionator

RESTRICT="strip"
QA_PREBUILT="opt/${PN}/bin/libbreakgen*.so
opt/${PN}/bin/fsnotifier*
opt/${PN}/lib/libpty/linux/x86*/libpty.so
opt/${PN}/plugins/android/lib/libwebp_jni*.so
opt/${PN}/plugins/android/resources/perfa/*/libperfa.so
opt/${PN}/plugins/android/resources/perfd/*/perfd
opt/${PN}/plugins/android/resources/simpleperf/*/simpleperf"

if [[ $(get_version_component_count) -eq 6 ]]; then
STUDIO_V=$(get_version_component_range 1-4)
BUILD_V=$(get_version_component_range 5-6)
else
STUDIO_V=$(get_version_component_range 1-3)
BUILD_V=$(get_version_component_range 4-5)
fi

DESCRIPTION="A new Android development environment based on IntelliJ IDEA"
HOMEPAGE="http://developer.android.com/sdk/installing/studio.html"
SRC_URI="https://dl.google.com/dl/android/studio/ide-zips/${STUDIO_V}/${PN}-ide-${BUILD_V}-linux.zip"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="selinux"
KEYWORDS="~amd64 ~x86"

DEPEND="app-arch/zip
dev-java/commons-logging:0
dev-java/log4j:0"

# dev-java/guava:18
RDEPEND=">=virtual/jdk-1.7
selinux? ( sec-policy/selinux-android )
>=app-arch/bzip2-1.0.6-r4
dev-java/commons-logging:0
dev-java/log4j:0
>=dev-libs/expat-2.1.0-r3
>=dev-libs/libffi-3.0.13-r1
>=media-libs/fontconfig-2.10.92
>=media-libs/freetype-2.5.5
>=media-libs/libpng-1.2.51
>=media-libs/mesa-10.2.8
|| ( gnome-extra/zenity kde-apps/kdialog x11-apps/xmessage x11-libs/libnotify )
>=sys-libs/ncurses-5.9-r3:5/5[tinfo]
>=sys-libs/zlib-1.2.8-r1
>=x11-libs/libX11-1.6.2
>=x11-libs/libXau-1.0.7-r1
>=x11-libs/libXdamage-1.1.4-r1
>=x11-libs/libXdmcp-1.1.1-r1
>=x11-libs/libXext-1.3.2
>=x11-libs/libXfixes-5.0.1
>=x11-libs/libXrender-0.9.8
>=x11-libs/libXxf86vm-1.1.3
>=x11-libs/libdrm-2.4.46
>=x11-libs/libxcb-1.9.1
>=x11-libs/libxshmfence-1.1"
S=${WORKDIR}/${PN}

src_prepare() {
eapply_user
# This is really a bundled jdk not a jre
rm -R "${S}/jre" || die "Could not remove bundled jdk"

# Replace bundled jars with system
# has problems with newer jdom:0 not updated to jdom:2
cd "${S}/lib" || die
local JARS="commons-logging log4j"
local j
for j in ${JARS}; do
rm -v ${j/:*/}*.jar || die
java-pkg_jar-from ${j}
done

cd "${S}" || die

# bug 629404
echo "-Djdk.util.zip.ensureTrailingSlash=false" >> bin/studio64.vmoptions || die
echo "-Djdk.util.zip.ensureTrailingSlash=false" >> bin/studio.vmoptions || die
}

src_compile() {
:
}

src_install() {
local dir="/opt/${PN}"

insinto "${dir}"
# Replaced bundled jre with system vm/jdk
# This is really a bundled jdk not a jre
doins -r *

rm -rf "${D}${dir}/jre" || die
dosym "/etc/java-config-2/current-system-vm" "${dir}/jre"

fperms 755 "${dir}/bin/studio.sh" "${dir}"/bin/fsnotifier{,64}
chmod 755 "${D}${dir}"/gradle/gradle-*/bin/gradle || die

newicon "bin/studio.png" "${PN}.png"
make_wrapper ${PN} ${dir}/bin/studio.sh
make_desktop_entry ${PN} "Android Studio" ${PN} "Development;IDE"
}

0 comments on commit b839dcc

Please sign in to comment.