Skip to content

Commit

Permalink
Merge remote-tracking branch 'github/pr/697'.
Browse files Browse the repository at this point in the history
Gentoo-Bug: 558182
PR-Number: gentoo#697
  • Loading branch information
monsieurp committed Jan 20, 2016
2 parents 47c27c7 + 93e0473 commit b8b8856
Show file tree
Hide file tree
Showing 67 changed files with 919 additions and 300 deletions.
37 changes: 37 additions & 0 deletions dev-python/CacheControl/CacheControl-0.11.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )

inherit distutils-r1 eutils

DESCRIPTION="The httplib2 caching algorithms packaged up for use with requests"
HOMEPAGE="https://github.com/ionrock/cachecontrol https://pypi.python.org/pypi/cachecontrol/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="test"

RDEPEND="
dev-python/requests[${PYTHON_USEDEP}]
>=dev-python/lockfile-0.9[${PYTHON_USEDEP}]"
DEPENDS="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"

# Not included
RESTRICT=test

python_test() {
py.test -v -v || die
}

pkg_postinst() {
optfeature "Redis based caches" dev-python/redis-py
}
1 change: 1 addition & 0 deletions dev-python/CacheControl/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST CacheControl-0.11.5.tar.gz 13104 SHA256 b78484d6feb17b501267f4048c364a8fc26fcef35ca3ff62bdba63d41fa4cf42 SHA512 2acce5a8be2e409a1a18254cfe71314074037bce3341f8b8fdec52c43500c90bfdb6063b2121c5cf6c8a2fc7c0903e4fd0c15813ffdfa547810b33571d211deb WHIRLPOOL 5e12640ba5c952ee8a83f5271bbbd105f148cd080bf6ae5c2cbc9c6cc20361005aa5cf1a95feaa1a808c56c26b7abdfbde3b7bffc873f26072d23262c12b49ca
DIST CacheControl-0.11.6.tar.gz 13642 SHA256 37dfcb453e7f186c95b330834a1673e022db900d5e3a883f80257c4369477695 SHA512 5640805db3a0f3e0e96192f2122159f0391be4821934ae6624b2778e91de319d5acf0e8693d00cf9910314ff7e2e1e7d2c82789b46fb012363fbb1c38dcb0d29 WHIRLPOOL 9187c18e12196b379136afa89d64c5dda461f9f0fa1764a5922046d579d9c10921a7bc8f8b409db29cd51d6bc0c358ab9bd8f3cf142de375da2b0a5723ed4117
2 changes: 1 addition & 1 deletion dev-python/httplib2/httplib2-0.9.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
IUSE=""

DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
Expand Down
2 changes: 1 addition & 1 deletion dev-python/ipython/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
DIST ipython-3.2.1.tar.gz 10884249 SHA256 c913adee7ae5b338055274c51a7d2b3cea468b5b316046fa520cd8a434b09177 SHA512 de7723e3b859d21a58a24456c76c8d8ec98c019f290f61269f46270e7647d2b49a98671138fecd75cb6f46384fde7e09618eb5c85c175e0e442c7fae7328d8fe WHIRLPOOL 9f020c167559259931dcb177d0c3a5211939632e5775c2627795ba390cf57bd62c378c15b7ee9b9ed2079180f8df8e062eb9673ed9cfc025a56f1da82c9428d1
DIST ipython-4.0.1.tar.gz 6207566 SHA256 3bd3b78abc4f43b9ea7fa5353a2a9ba01af8ac4aec5d11e78fa5cbcec105432e SHA512 88419feca21c762a8553b4c11661e28b3305742fc89309abfd46b1213da210249b4781b754996835a2cc539569ae7cb816ed26bbaddbf15529eeb6479660265e WHIRLPOOL 58c17378fbcbac94e1585cce0cdd00996f7df20f5781a88e1e7d56b9fe2db81fe3282211dba31e8f54d2e50db869d2cce2670cfebc5c868455f481064e0089c6
DIST ipython-4.0.2.tar.gz 6206506 SHA256 10cb9cd4b7730349241bb9053dcd90c3e1f11f2b5baafa2a914b69acc94a35a8 SHA512 b7a05c190286e30fd994b81bfb251f5e542d22b96dbdacbe611eb62c690ea79e83f932252cc360b2290c939376540b92fad0263188798de350817850796c1966 WHIRLPOOL 6fa157f2bb6fe4227f0a0863c9dde9f657f5eb02ef49dad172e7c686e864b29cd8305f67bfed3dcf79449a664d851cb73a7ec6c631792f091dd28a1476db4bb3
DIST ipython-4.0.3.tar.gz 6207899 SHA256 3a928f59e8ac8dd97858c28390867c87c09510f1f8bbe97e4e9c6b036eb84fc0 SHA512 1e2deb597348757e69aaeadd0632cf984056e5f7278ee5bbbd7b4233581323b07f55685b1891c23dc0977d9f30f7dc734dcf2216bc8876424cdb0f7a9294fecf WHIRLPOOL 1beb60e6daf3cea4609318e87a07307843eeb1002847f8c3c5fbe8e114ab29cb052c810884b410f1e8414437b91c5335048106756e2d88a82a7e440e3ff8fc17
File renamed without changes.
2 changes: 1 addition & 1 deletion dev-python/oauth2client/oauth2client-1.5.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,7 @@ SRC_URI="https://github.com/google/oauth2client/archive/v${PV}.tar.gz -> ${P}.ta

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
IUSE="test"

RDEPEND="
Expand Down
1 change: 1 addition & 0 deletions dev-python/packaging/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST packaging-15.3.tar.gz 34359 SHA256 1e9a6b9ad621bc1dbd3aa8dfff52abc4b44f5c14fbb406731c25cba250a5f61e SHA512 bd59408dc6ea2a4f8cb3a84b4d1e4284148a0f6fb2d3203f90885f608871f1f2315201427d08d2ca7b2d706bc5457c8a521b5edda9187e794522dbb8e46a663c WHIRLPOOL 197e9f26022383bf5962efbd562f1502bd5f0972a782c94f3188961d8d14167c25febee459ad5b3a731bafaf3f7e53e5b051d383382c169b58aff1cb521442f3
DIST packaging-16.0.tar.gz 40167 SHA256 a32895134cd7b86ee8add60a3be5bfd7ef3f30e73e5b54221dbe67d0e0690689 SHA512 7672f0a51f73543e39ad80b021d288c0e235c2ace9add5022a1d494b2711ce55ba7d05d92245cbb96fa354d67fdfbdbdd2e1858ace3d6d2761869bc5ddaaeddd WHIRLPOOL be813ffbcc614e5be3bc9bb1e704e9c65c194b47172bb0c9bf0113ea8456256fa8263faec33b3e001b6d71ed7fd8763796afd6eeb608f3a65ea987db48304d5a
43 changes: 43 additions & 0 deletions dev-python/packaging/packaging-16.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )

inherit distutils-r1

DESCRIPTION="Core utilities for Python packages"
HOMEPAGE="https://github.com/pypa/packaging https://pypi.python.org/pypi/packaging"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

SLOT="0"
LICENSE="|| ( Apache-2.0 BSD-2 )"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="test"

RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? (
dev-python/pretend[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
)
"

python_test() {
py.test --capture=no --strict -v || die
}

pkg_preinst() {
# Remove this in the next version bump
_cleanup() {
local pyver=$("${PYTHON}" -c "from distutils.sysconfig import get_python_version; print(get_python_version())")
local egginfo="${ROOT%/}$(python_get_sitedir)/${P}-py${pyver}.egg-info"
if [[ -d ${egginfo} ]]; then
echo rm -r "${egginfo}"
rm -r "${egginfo}" || die "Failed to remove egg-info directory"
fi
}
python_foreach_impl _cleanup
}
1 change: 1 addition & 0 deletions dev-python/pip/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST pip-7.1.2.tar.gz 1049170 SHA256 ca047986f0528cfa975a14fb9f7f106271d4e0c3fe1ddced6c1db2e7ae57a477 SHA512 78082afe6b559bf87f91ae9b6d304cfbfce00206e09be42fdae9d449a55cd8d968df6873e834191d0b0e6baae29e72eb3eee42386ff7c5dc9c29b6c28b754449 WHIRLPOOL 953fdc9104f3ac34c9104ec93948f58c4b0e193f18da60d3247d801c283c574490f8b91146e4278888c0b920090f537095c1a1693ca352d062dd98473390fdc9
DIST pip-8.0.0.tar.gz 1129857 SHA256 90112b296152f270cb8dddcd19b7b87488d9e002e8cf622e14c4da9c2f6319b1 SHA512 2277dbe74af2dd3a3280b4115ebdbe2de83a5fbfdd3f15e2627441478bd08f21b46771153100ed9934a48a3662846aa84310f722029e6f56fa9a400dbd61e910 WHIRLPOOL 8f70adb37fdabf91db8c5a9d257daa8a0df0e6c6d8f077f19288033a41bca445427173bb32c4b18019096f2191b3b5d2381124c0e3a664da79bb881a0cf60610
68 changes: 68 additions & 0 deletions dev-python/pip/pip-8.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
PYTHON_REQ_USE="threads(+)"

inherit bash-completion-r1 distutils-r1

DESCRIPTION="Installs python packages -- replacement for easy_install"
HOMEPAGE="https://pip.pypa.io/ https://pypi.python.org/pypi/pip/ https://github.com/pypa/pip/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
SLOT="0"

# Check pip/_vendor/vendor.txt for this
VENDOR_DEPEND="
>=dev-python/distlib-0.2.1[${PYTHON_USEDEP}]
>=dev-python/html5lib-0.9999999[${PYTHON_USEDEP}]
>=dev-python/six-1.9[${PYTHON_USEDEP}]
>=dev-python/colorama-0.3.6[${PYTHON_USEDEP}]
>=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
>=dev-python/CacheControl-0.11.5[${PYTHON_USEDEP}]
>=dev-python/lockfile-0.12.2[${PYTHON_USEDEP}]
>=dev-python/progress-1.2[${PYTHON_USEDEP}]
>=dev-python/packaging-16.0[${PYTHON_USEDEP}]
>=dev-python/retrying-1.3.3[${PYTHON_USEDEP}]
>=dev-python/pyparsing-2.0.7[${PYTHON_USEDEP}]
virtual/python-ipaddress[${PYTHON_USEDEP}]
"
RDEPEND="${VENDOR_DEPEND}
>=dev-python/setuptools-19.4[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"

# required test data isn't bundled with the tarball
RESTRICT="test"

PATCHES=(
"${FILESDIR}"/${PN}-6.0.2-disable-version-check.patch
"${FILESDIR}"/${PN}-7.1.2-unbundle.patch
)

python_prepare_all() {
mv pip/_vendor/__init__.py "${T}" || die
rm -r pip/_vendor/* || die
mv "${T}"/__init__.py pip/_vendor/__init__.py || die

distutils-r1_python_prepare_all
}

python_install_all() {
local DOCS=( AUTHORS.txt docs/*.rst )
distutils-r1_python_install_all

COMPLETION="${T}"/completion.tmp

"${PYTHON}" -m pip completion --bash > "${COMPLETION}" || die
newbashcomp "${COMPLETION}" ${PN}

"${PYTHON}" -m pip completion --zsh > "${COMPLETION}" || die
insinto /usr/share/zsh/site-functions
newins "${COMPLETION}" _pip
}
2 changes: 1 addition & 1 deletion dev-python/rsa/rsa-3.2.3-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm ~x86"
KEYWORDS="amd64 ~arm x86"
IUSE="test"

RDEPEND="
Expand Down
1 change: 1 addition & 0 deletions dev-python/setuptools/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -7,3 +7,4 @@ DIST setuptools-18.8.1.tar.gz 629889 SHA256 ac472c7c4752e8cd44d646fcb4f15d13e72a
DIST setuptools-18.8.tar.gz 629367 SHA256 04180e33a40a114ff9b458f31786d885964612af2b2111c3d0efdc9a1ac76c4d SHA512 718f8ef19e639450f62e1751715bac65ce2bd218b81614d07c9283a01be3a085ec5422ff9d96a54e74c05135a1a4bb167ece6d4ecece588716d05982c9f25811 WHIRLPOOL 412545b8b2625675612c9d79b366c7b5287e0f6f48596a49fdbd1b358a4efefcd4cbf8993ff42ad7d7f14868fc86e5136c7af650dfe954ab015060ea57268523
DIST setuptools-19.1.1.tar.gz 640997 SHA256 32ebb08b72aee11fefa6907ddf5db5a81e0eef9cf62c7fa6b58d8e32da249960 SHA512 480aaed577ab9bc4d3cae71d957407ecb71e743dab7fb06f165b76683445f356ce141e1057b5a057101f9546df8c62e2abc2c35ebd751e4bb3febb846a71ac41 WHIRLPOOL 608af5cb22e9b87de3cb0181519058cc7437b7e74b7be4774337d18a562e869cb361edf17f0488c2594039e87dcdc1f201723520568490b0e0be105992abeb37
DIST setuptools-19.2.tar.gz 641777 SHA256 f90ed8eb70b14b0594ba74e9de4ffca040c0ec8ee505cbf3570499467859f71a SHA512 2494606930d6d422e8c105e8e5b40a07b23709f361164c5df40ff24c80328b861179652c7212fa38137534206c187bc4de42d249bc686d43fad18f23d0a26126 WHIRLPOOL ee861dc97a48ec7a07eadc3ceb42077b396a14c1448f0c3d8c6edf2266f4da241bb0e9f31922bc687b6e943802b95b440aea9f2e5d60b8d338c8392102353100
DIST setuptools-19.4.tar.gz 641797 SHA256 214bf29933f47cf25e6faa569f710731728a07a19cae91ea64f826051f68a8cf SHA512 463a2b00193b972e684569dce1527b34d7be9a9d0f866fd8a0c2c1a475558c539148841ca117b0a9c5507d8344dfd5ca515bc6beee59b44c6e8bf05771bc448a WHIRLPOOL 37bdb6592e63c8594051ddfa1df4295dc3417e29b338f66a44270619bf30c6e87b12a7086a8f337f3497bd036cbacc10ab2f179c2768af685b6ee5d93a747897
57 changes: 57 additions & 0 deletions dev-python/setuptools/setuptools-19.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )

inherit distutils-r1

DESCRIPTION="Collection of extensions to Distutils"
HOMEPAGE="https://pypi.python.org/pypi/setuptools"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="PSF-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="test"

RDEPEND="
>=dev-python/packaging-15.3-r1[${PYTHON_USEDEP}]
>=dev-python/six-1.10.0[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
test? (
>=dev-python/pytest-2.8[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
)
"
PDEPEND=">=dev-python/certifi-2015.11.20[${PYTHON_USEDEP}]"

# Force in-source build because build system modifies sources.
DISTUTILS_IN_SOURCE_BUILD=1

DOCS=( README.txt docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )

python_prepare_all() {
rm -r ./pkg_resources/_vendor || die
# disable tests requiring a network connection
rm setuptools/tests/test_packageindex.py || die

# don't run integration tests
rm setuptools/tests/test_integration.py || die

distutils-r1_python_prepare_all
}

python_test() {
# test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
# It tries to sandbox the test in a tempdir
HOME="${PWD}" py.test --verbose ${PN} || die "Tests failed under ${EPYTHON}"
}

python_install() {
export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
distutils-r1_python_install
}
File renamed without changes.
2 changes: 1 addition & 1 deletion dev-qt/qtwebkit/qtwebkit-4.10.4.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -57,8 +57,8 @@ DEPEND="${RDEPEND}
S=${WORKDIR}

PATCHES=(
"${FILESDIR}/${PV}-gcc5.patch"
"${FILESDIR}/${PV}-use-correct-icu-typedef.patch"
"${FILESDIR}/${P}-fix-gcc-5.patch"
)

src_prepare() {
Expand Down
14 changes: 8 additions & 6 deletions dev-qt/qtwebkit/qtwebkit-5.5.1-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -83,24 +83,26 @@ src_prepare() {
qt_use_disable_mod orientation sensors Tools/qmake/mkspecs/features/features.prf
qt_use_disable_mod printsupport printsupport Tools/qmake/mkspecs/features/features.prf
qt_use_disable_mod qml quick Tools/qmake/mkspecs/features/features.prf
qt_use_disable_mod webchannel webchannel Source/WebKit2/WebKit2.pri
qt_use_disable_mod webchannel webchannel \
Source/WebKit2/Target.pri \
Source/WebKit2/WebKit2.pri

if use gstreamer010; then
epatch "${FILESDIR}/${PN}-5.3.2-use-gstreamer010.patch"
elif ! use gstreamer; then
epatch "${FILESDIR}/${PN}-5.2.1-disable-gstreamer.patch"
fi

use opengl || sed -i -e '/contains(QT_CONFIG, opengl): WEBKIT_CONFIG += use_3d_graphics/d' \
# bug 562396
use jit || epatch "${FILESDIR}/${PN}-5.5.1-disable-jit.patch"

use opengl || sed -i -e '/contains(QT_CONFIG, opengl): WEBKIT_CONFIG += use_3d_graphics/d' \
Tools/qmake/mkspecs/features/features.prf || die
use webp || sed -i -e '/config_libwebp: WEBKIT_CONFIG += use_webp/d' \
use webp || sed -i -e '/config_libwebp: WEBKIT_CONFIG += use_webp/d' \
Tools/qmake/mkspecs/features/features.prf || die

# bug 458222
sed -i -e '/SUBDIRS += examples/d' Source/QtWebKit.pro || die

# bug 562396
use jit || epatch "${FILESDIR}/${PN}-5.5.1-disable-jit.patch"

qt5-build_src_prepare
}
Loading

0 comments on commit b8b8856

Please sign in to comment.