Skip to content

Commit

Permalink
dev-lua/luadbi: bump to version 0.7.2
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/709736
Package-Manager: Portage-3.0.8, Repoman-3.0.1
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed Oct 13, 2020
1 parent d7a078e commit b90c606
Show file tree
Hide file tree
Showing 3 changed files with 116 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lua/luadbi/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST luadbi-0.7.2.tar.gz 36462 BLAKE2B 581c7353bfa36b3f6cabed2df78372f8810300bf4525bf8d370e61d469f9daa5a5c40c58916164a8d0a621a61e983e85c67b23ef03f51212be79f09ad8512047 SHA512 891f99cbc8f1b5327ef820641a1608abf41410f2f28584b975cc3cf65154b9bebf6f1b9ca7d1818b9c965738ad700dd17ae042dfd2a7146cf755871ebae535b9
DIST luadbi.0.5.tar.gz 22454 BLAKE2B 538fa935ece2a8e0f852cef33716570a6e85100ec26892d7a76c5b00a7fceb82411e2ebe29d25de42cf6ee6bdbfdf5102875bb4d04d65f86dfdc9d79fecef359 SHA512 4ed641e113e90acc8a4f6b3b2d0f5d5044c0fbbef3b2fdfb84d15e17115e45c553a33b19bfb165e5af11a2adce501d66859963e3363d3ab1c6a39b0b2ae92e62
55 changes: 55 additions & 0 deletions dev-lua/luadbi/files/luadbi-0.7.2-mysql-8.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
From b72503cad0654878841172451b2ea860a59e30c1 Mon Sep 17 00:00:00 2001
From: Conrad Kostecki <[email protected]>
Date: Tue, 13 Oct 2020 07:34:16 +0200
Subject: [PATCH] dbd/mysql/statement.c: fix compilation with mysql-8

Signed-off-by: Conrad Kostecki <[email protected]>
---
dbd/mysql/dbd_mysql.h | 2 +-
dbd/mysql/statement.c | 6 +++---
2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/dbd/mysql/dbd_mysql.h b/dbd/mysql/dbd_mysql.h
index 233bc35..4777289 100644
--- a/dbd/mysql/dbd_mysql.h
+++ b/dbd/mysql/dbd_mysql.h
@@ -3,7 +3,7 @@
#endif


-#include <mysql.h>
+#include <mysql/mysql.h>
#include <dbd/common.h>

#define DBD_MYSQL_CONNECTION "DBD.MySQL.Connection"
diff --git a/dbd/mysql/statement.c b/dbd/mysql/statement.c
index aca865a..6af4c39 100644
--- a/dbd/mysql/statement.c
+++ b/dbd/mysql/statement.c
@@ -424,7 +424,7 @@ static int statement_fetch_impl(lua_State *L, statement_t *statement, int named_

if (fields[i].type == MYSQL_TYPE_TIMESTAMP || fields[i].type == MYSQL_TYPE_DATETIME) {
char str[20];
- struct st_mysql_time *t = bind[i].buffer;
+ MYSQL_TIME *t = bind[i].buffer;

snprintf(str, 20, "%d-%02d-%02d %02d:%02d:%02d", t->year, t->month, t->day, t->hour, t->minute, t->second);

@@ -435,7 +435,7 @@ static int statement_fetch_impl(lua_State *L, statement_t *statement, int named_
}
} else if (fields[i].type == MYSQL_TYPE_TIME) {
char str[9];
- struct st_mysql_time *t = bind[i].buffer;
+ MYSQL_TIME *t = bind[i].buffer;

snprintf(str, 9, "%02d:%02d:%02d", t->hour, t->minute, t->second);

@@ -446,7 +446,7 @@ static int statement_fetch_impl(lua_State *L, statement_t *statement, int named_
}
} else if (fields[i].type == MYSQL_TYPE_DATE) {
char str[20];
- struct st_mysql_time *t = bind[i].buffer;
+ MYSQL_TIME *t = bind[i].buffer;

snprintf(str, 11, "%d-%02d-%02d", t->year, t->month, t->day);

60 changes: 60 additions & 0 deletions dev-lua/luadbi/luadbi-0.7.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit toolchain-funcs

DESCRIPTION="A database interface library for Lua"
HOMEPAGE="https://github.com/mwild1/luadbi"
SRC_URI="https://github.com/mwild1/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="mysql postgres +sqlite"
REQUIRED_USE="|| ( mysql postgres sqlite )"

RDEPEND="
>=dev-lang/lua-5.1:=
mysql? ( dev-db/mysql-connector-c:0= )
postgres? ( dev-db/postgresql:= )
sqlite? ( dev-db/sqlite )
"

DEPEND="${RDEPEND}"

BDEPEND="virtual/pkgconfig"

PATCHES=( "${FILESDIR}/${PN}-0.7.2-mysql-8.patch" )

src_prepare() {
default

# Respect users CFLAGS
sed -e 's/-g //' -e 's/-O2 //g' -i Makefile || die
}

src_compile() {
tc-export AR CC

local myemakeargs=(
"LUA_INC=-I$($(tc-getPKG_CONFIG) --variable INSTALL_INC lua)/lua5.1"
)

use mysql && emake ${myemakeargs} MYSQL_INC="-I$(mariadb_config --libs)" mysql
use postgres && emake ${myemakeargs} PSQL_INC="-I$(pg_config --libdir)" psql
use sqlite emake ${myemakeargs} SQLITE3_INC="-I/usr/include" sqlite
}

src_install() {
local myemakeargs=(
DESTDIR="${ED}"
LUA_CDIR="$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)"
LUA_LDIR="$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
)

use mysql && emake ${myemakeargs[@]} install_mysql
use postgres && emake ${myemakeargs[@]} install_psql
use sqlite && emake ${myemakeargs[@]} install_sqlite3
}

0 comments on commit b90c606

Please sign in to comment.