Skip to content

Commit

Permalink
sys-apps/smcipmitool: bump to version 2.22
Browse files Browse the repository at this point in the history
Also bumped to EAPI=7 and dropped x86 support, as upstream dropped it.

Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Conrad Kostecki <[email protected]>
Closes: gentoo#13004
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
ConiKost authored and Whissi committed Oct 6, 2019
1 parent 260e0ac commit b90d23a
Show file tree
Hide file tree
Showing 2 changed files with 84 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-apps/smcipmitool/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST SMCIPMITool_2.21.0_build.181029_bundleJRE_Linux.tar.gz 122153416 BLAKE2B 2d4224a76588fa4da41a8080bde5833ce3a7da01a11e45fc48069084077fe2e1e48f5e92ec266b10a390b3a40cfbc66f2b674c9ef59f8b3b11d42cb20eb992bb SHA512 e655e14751906d392f0f528c6d5afe83298f398025c5808d2efed142a3cdf9b56d06964feeed63fef58f2fe793d7de06c3eeb909e4467ce774317bb7971792d1
DIST SMCIPMITool_2.21.0_build.181029_bundleJRE_Linux_x64.tar.gz 119034481 BLAKE2B 032bbae5a3e608f6f51ae955df875d18a7b260fc0d49d6371af910cc1186c47b3db2b012dccd2837b598d5e405fde01390cfb44a5526297691c9bb99029c2dbd SHA512 9d721b8409510f75dbe36e8b5e3fdfb89f42f85365406f2c53890c1f5a6620f6abe00325017443b9af26bc60aeae7392065eb451d1a318de9898783562b43933
DIST SMCIPMITool_2.22.0_build.190701_bundleJRE_Linux_x64.tar.gz 77421471 BLAKE2B fffb158364c7d8a71bd3e1c81ac6e0822cbaa00470aa2df14e34663b92d4c2641d01ab18c63b251e696624e3988ec5bcee97d72e3788b2f77e43db682e568077 SHA512 ea68816e3ab294862b5b6927305283f4204364ed9b319e3be577bc49bf47f767b89e05475e11269b426f73385148c10cf0109715708497737db393846cf10ccf
83 changes: 83 additions & 0 deletions sys-apps/smcipmitool/smcipmitool-2.22.0.190701.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,83 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit java-pkg-2 prefix

MY_DATE="$(ver_cut 4)"
MY_PN="SMCIPMITool"
MY_PN_SRC_URI="SMCIPMItool"
MY_PV="$(ver_cut 1-3)"

DESCRIPTION="An out-of-band utility for interfacing with SuperBlade and IPMI devices via CLI"
HOMEPAGE="https://www.supermicro.com/"
SRC_URI="ftp://ftp.supermicro.com/utility/${MY_PN_SRC_URI}/Linux/${MY_PN}_${MY_PV}_build.${MY_DATE}_bundleJRE_Linux_x64.tar.gz"

LICENSE="supermicro"
SLOT="0"
KEYWORDS="-* ~amd64"

RDEPEND="
net-misc/stunnel
sys-libs/ncurses-compat:5
virtual/jre:1.8
"

RESTRICT="bindist fetch mirror"

DIR="/usr/share/${PN}"
QA_PREBUILT="usr/lib*"

pkg_nofetch() {
elog "Please download ${A} from"
elog "https://www.supermicro.com/SwDownload/UserInfo.aspx?sw=0&cat=IPMI"
elog "and place it in your DISTDIR directory."
}

src_unpack() {
unpack ${A}
mv -v ${MY_PN}_${MY_PV}_build.${MY_DATE}_bundleJRE_Linux_x64 ${P} || die
}

src_prepare() {
default

# Don't use their scary launchers
rm -v lax.jar || die
}

src_compile() {
:
}

src_install() {
java-pkg_dojar *.jar
java-pkg_doso libjcurses.so *64.so

local pre=$(prefixify_ro "${FILESDIR}"/launcher-pre.bash)
java-pkg_dolauncher smcipmitool-ikvm --jar iKVM.jar -pre "${pre}"
java-pkg_dolauncher smcipmitool-jviewersmc --jar JViewerSMC.jar -pre "${pre}"
java-pkg_dolauncher smcipmitool-jviewerx9 --jar JViewerX9.jar -pre "${pre}"
java-pkg_dolauncher smcipmitool --jar SMCIPMITool.jar -pre "${pre}"

exeinto "${DIR}"/jre/bin
newexe $(prefixify_ro "${FILESDIR}"/fake-java.bash) java

insinto "${DIR}"/lib/BMCSecurity
doins BMCSecurity/*.{crt,key,pem,txt}

insinto "${DIR}"/lib/BMCSecurity/linux
doins BMCSecurity/linux/stunnel.conf

dosym ../../../../../bin/stunnel "${DIR}"/lib/BMCSecurity/linux/stunnel32
dosym ../../../../../bin/stunnel "${DIR}"/lib/BMCSecurity/linux/stunnel64

local DOCS=(
"jcurses.README"
"ReleaseNotes.txt"
"SMCIPMITool_User_Guide.pdf"
)

einstalldocs
}

0 comments on commit b90d23a

Please sign in to comment.