Skip to content

Commit

Permalink
sys-auth/pambase: Version bump (v0210201)
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.13, Repoman-3.0.2
Signed-off-by: Mikle Kolyada <[email protected]>
  • Loading branch information
Zlogene committed Feb 1, 2021
1 parent c6738c6 commit b922c43
Show file tree
Hide file tree
Showing 2 changed files with 110 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-auth/pambase/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST pambase-20201103.tar.gz 3295 BLAKE2B 7e104b5342842a21e10dce6e5c5a2d330ec06146b4791b888518463d915eebefbd694a809ff676b32c9c43945087935dc5c3496ae93ac17b7e4fd4e2e2974d1a SHA512 b94e47780f45c5e897b5fd073ce2184a901d241d51516ac5007658b1ae423d0f34c37a09a9e1d055962aa7158675ea7740dfe6466fad5e4a1b50b66a0812f51d
DIST pambase-20210201.tar.gz 3346 BLAKE2B fd9183ec91062b88ab0f013a955fcadfe48c105a2e31838a6a89b2e5a58313ba3376971567288d609ad6f080743e587e5787ee307589b890a397969bab42e108 SHA512 0a45415284c64c706b30fc0e75c4c541d897e8876f0bd04e28cf73cc2a907e2ed48bed6472e355572a5a9cfb5508666312f225fcdedc370380fadac2077fef3d
109 changes: 109 additions & 0 deletions sys-auth/pambase/pambase-20210201.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,109 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7..9} )

inherit pam python-any-r1 readme.gentoo-r1

DESCRIPTION="PAM base configuration files"
HOMEPAGE="https://github.com/gentoo/pambase"

if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/gentoo/pambase.git"
else
SRC_URI="https://github.com/gentoo/pambase/archive/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
S="${WORKDIR}/${PN}-${P}"
fi

LICENSE="MIT"
SLOT="0"
IUSE="caps debug elogind gnome-keyring homed minimal mktemp +nullok pam_krb5 pam_ssh +passwdqc pwhistory pwquality securetty selinux +sha512 systemd"

RESTRICT="binchecks"

REQUIRED_USE="
?? ( elogind systemd )
?? ( passwdqc pwquality )
pwhistory? ( || ( passwdqc pwquality ) )
homed? ( !pam_krb5 )
pam_krb5? ( !homed )
"

MIN_PAM_REQ=1.4.0

RDEPEND="
>=sys-libs/pam-${MIN_PAM_REQ}
elogind? ( sys-auth/elogind[pam] )
gnome-keyring? ( gnome-base/gnome-keyring[pam] )
mktemp? ( sys-auth/pam_mktemp )
pam_krb5? (
>=sys-libs/pam-${MIN_PAM_REQ}
sys-auth/pam_krb5
)
caps? ( sys-libs/libcap[pam] )
pam_ssh? ( sys-auth/pam_ssh )
passwdqc? ( >=sys-auth/passwdqc-1.4.0-r1 )
pwquality? ( dev-libs/libpwquality[pam] )
selinux? ( sys-libs/pam[selinux] )
sha512? ( >=sys-libs/pam-${MIN_PAM_REQ} )
homed? ( sys-apps/systemd[homed] )
systemd? ( sys-apps/systemd[pam] )
"

BDEPEND="$(python_gen_any_dep '
dev-python/jinja[${PYTHON_USEDEP}]
')"

python_check_deps() {
has_version -b "dev-python/jinja[${PYTHON_USEDEP}]"
}

src_configure() {
${EPYTHON} ./${PN}.py \
$(usex caps '--caps' '') \
$(usex debug '--debug' '') \
$(usex elogind '--elogind' '') \
$(usex gnome-keyring '--gnome-keyring' '') \
$(usex homed '--homed' '') \
$(usex minimal '--minimal' '') \
$(usex mktemp '--mktemp' '') \
$(usex nullok '--nullok' '') \
$(usex pam_krb5 '--krb5' '') \
$(usex pam_ssh '--pam-ssh' '') \
$(usex passwdqc '--passwdqc' '') \
$(usex pwhistory '--pwhistory' '') \
$(usex pwquality '--pwquality' '') \
$(usex securetty '--securetty' '') \
$(usex selinux '--selinux' '') \
$(usex sha512 '--sha512' '') \
$(usex systemd '--systemd' '') \
|| die
}

src_test() { :; }

src_install() {
local DOC_CONTENTS

if use passwdqc; then
DOC_CONTENTS="To amend the existing password policy please see the man 5 passwdqc.conf
page and then edit the /etc/security/passwdqc.conf file"
fi

if use pwquality; then
DOC_CONTENTS="To amend the existing password policy please see the man 5 pwquality.conf
page and then edit the /etc/security/pwquality.conf file"
fi

{ use passwdqc || use pwquality; } && readme.gentoo_create_doc

dopamd -r stack/.
}

pkg_postinst() {
{ use passwdqc || use pwquality; } && readme.gentoo_print_elog
}

0 comments on commit b922c43

Please sign in to comment.