Skip to content

Commit

Permalink
app-portage/gander: enable python3.9 (tested)
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.18, Repoman-3.0.3
Signed-off-by: Marco Scardovi <[email protected]>
Closes: gentoo#20713
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
Marco Scardovi authored and mgorny committed May 7, 2021
1 parent 5c10df2 commit b96df14
Showing 1 changed file with 30 additions and 0 deletions.
30 changes: 30 additions & 0 deletions app-portage/gander/gander-0.0.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{8..9} )
inherit distutils-r1

DESCRIPTION="Statistic submission client for Goose (anser.gentoo.org)"
HOMEPAGE="https://github.com/mgorny/gander/"
SRC_URI="https://github.com/mgorny/gander/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="
dev-python/requests[${PYTHON_USEDEP}]
sys-apps/portage[${PYTHON_USEDEP}]
"

BDEPEND="test? ( dev-python/responses[${PYTHON_USEDEP}] )"

distutils_enable_tests pytest

python_test() {
# Portage exports random configuration options *overriding* its own
# behavior into the build environment.
env -u PORTAGE_REPOSITORIES pytest -vv || die "Tests fail with ${EPYTHON}"
}

0 comments on commit b96df14

Please sign in to comment.