Skip to content

Commit

Permalink
dev-ruby/childprocess: add 0.6.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
graaff committed Jan 23, 2017
1 parent 748908b commit ba08cdf
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/childprocess/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST childprocess-0.5.3.gem 28160 SHA256 9cebed1bd68f7ba0deb54683a5c05a8c3e79037f682b5d0a6ecd1d4472bbb289 SHA512 f48ab94dc3da7ca82551f480cb18214ec65f9550ef053b25216239ed92c289a7353c632fff53148b1d6ce0c7bf70188bcecbdeede3df9b8130f815599a45ac05 WHIRLPOOL 68f7e9585c39a2628c4cb162d02c7d332d116be96ce8f325308e15d530e00139d43b9dcfcdfd490c6a252057947eed4c91843d8f37b96201d95b6ff3078055da
DIST childprocess-0.5.9.gem 29184 SHA256 221f98abeacce606ab3940785217c2d4a58ddbb7d267678b185acc54f92842c7 SHA512 5a671e59d19531347438dc149d5309218c7e439cfd0bfcfe201ae8e1099a2608a0170f9a3f3752fb709afc6b68fa3a10dc60d0632af545a9ba71483c7be2c21d WHIRLPOOL 8558622ef2f0ad3d9c2d84968378034d3293b7f485d30b6361326539e329b33bb52e5b472c8880485c23f85e457ad07894036ca2adfdf148ac4b05925407ac28
DIST childprocess-0.6.1.gem 30208 SHA256 51c158ebb45ecf2149777b5ce9db6a73cdc51326dfe782869470acee91a0b1bc SHA512 7361f9704174c9acfb24cbcad60ba51fb90f67f4464e9b89e8cfefd1928b7af1358cde98f9eb2a234db5596df34e3ab3a45e85da3999dc88b773fb88590ba9ba WHIRLPOOL 61b763064ab1f1c97afd628bd28760bff10cc0f3bbc1b10f97a86b5a4ed7e686845f1a13ba06b4cb41a488a77e3bcec38dbe25b959d1c84ce31581233b08ec8b
35 changes: 35 additions & 0 deletions dev-ruby/childprocess/childprocess-0.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
USE_RUBY="ruby21 ruby22 ruby23"

RUBY_FAKEGEM_RECIPE_TEST="rspec3"

RUBY_FAKEGEM_TASK_DOC="yard"
RUBY_FAKEGEM_EXTRADOC="README.md"

RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"

inherit ruby-fakegem

DESCRIPTION="Solution for controlling external programs running in the background"
HOMEPAGE="https://github.com/jarib/childprocess"

LICENSE="MIT"
SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64 ~x86"
IUSE=""

ruby_add_bdepend "doc? ( dev-ruby/yard dev-ruby/rspec:3 )"

ruby_add_rdepend ">=dev-ruby/ffi-1.0.11"

all_ruby_prepare() {
# Remove bundler support
rm Gemfile || die
sed -i -e "/[Bb]undler/d" Rakefile || die
sed -i -e "/[Cc]overalls/d" spec/spec_helper.rb || die
sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
}

0 comments on commit ba08cdf

Please sign in to comment.