Skip to content

Commit

Permalink
dev-lua/lua-term: initial commit
Browse files Browse the repository at this point in the history
  • Loading branch information
williamh committed Nov 11, 2015
1 parent df089e8 commit ba3d52d
Show file tree
Hide file tree
Showing 3 changed files with 51 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lua/lua-term/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST lua-term-0.3.tar.gz 3752 SHA256 255c833cd4f2c526f4b1e0aa0e06a6c2a58614eac112d0e10aace51a30218bb3 SHA512 e91585994c0337d4dbdc36f51cec9f66fe7319212e82c56752ed724bbbe273e4dc67977bd13e7963545bb075f23f69a448dfc4cc4d6c3c49e96af99cd3eb59e7 WHIRLPOOL ba273177de47b2512745c6440af9d22a71055de5e040b3779678929fe994587576ed0e5958e8918cf80a0502fcf2a08383c4123c510756ef539b3fd7308b051b
42 changes: 42 additions & 0 deletions dev-lua/lua-term/lua-term-0.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit toolchain-funcs

# Yes, upstream used different version numbers.
# The rockspec version number is 0.3, but the version associated with
# the tarball is 0.03.
MY_PV=0.03

DESCRIPTION="Terminal functions for Lua"
HOMEPAGE="https://github.com/hoelzro/lua-term"
SRC_URI="https://github.com/hoelzro/lua-term/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""

COMMON_DEPEND=">=dev-lang/lua-5.1:="
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig"
RDEPEND="${COMMON_DEPEND}"

S="${WORKDIR}/${PN}-${MY_PV}"

src_compile() {
echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -fPIC -shared \
-o core.so core.c"
$(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -fPIC -shared \
-o core.so core.c || die
}

src_install() {
exeinto "$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)"/term
doexe core.so
insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
doins -r term
}
8 changes: 8 additions & 0 deletions dev-lua/lua-term/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
<email>[email protected]</email>
<name>William Hubbs</name>
</maintainer>
</pkgmetadata>

0 comments on commit ba3d52d

Please sign in to comment.