Skip to content

Commit

Permalink
app-metrics/prometheus: Version bump to 2.6.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: Manuel Rüger <[email protected]>
  • Loading branch information
mrueg committed Jan 15, 2019
1 parent defd3c3 commit ba7222a
Show file tree
Hide file tree
Showing 2 changed files with 71 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-metrics/prometheus/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST prometheus-2.4.3.tar.gz 6095284 BLAKE2B 9b9d54cf8ed61453d63e4b93cd81cd1c08a732b2238830aa1b83b63076205569b8f947a94d0528b910c0958bc77f98605ab3eaf98a1e93d361ea6b431d5df48c SHA512 c86ce48416d32ca4310315dd7195a6ee471244b7a9323ddc49270c2b885bda38c2922047dc8fd7d9b19c9f62f8bc788d30387d38f956cbf04130d7041f9a479b
DIST prometheus-2.5.0.tar.gz 6123272 BLAKE2B a84b31e24f4448330af63b64ed56b8c535e790930738c0f00d7ec05ff5b49cd52bcae047cfe3a0470909397562f29662003e5b5ad0a747dc209109e360daa18d SHA512 181ef94b75717d116ae8b1307f7351eb889d153b27316e08e8cffe16cf885dbf43bd0bd4214f05e56bc33bbf53f7864721ab666f5ea4356b37a5987347c6a191
DIST prometheus-2.6.0.tar.gz 6607363 BLAKE2B b9449403c840367b5332e27cf5d76b3becf1abcaaff6b2f2fd48441609b91d969ce078a2a3c4a38cc68b421b8e796561be87858adb77ac780f45650147469596 SHA512 75ae11a49de4277c7b4e49b83d7f34c9eb17b6bde988ab84e735109430361856ae0d33179a678b2cfc88342966a8e393a75062142c6f713f8a974aa8f332691e
DIST prometheus-2.6.1.tar.gz 6612143 BLAKE2B 33dc64406dd45f494720a1ff5f6d09ed4b45b3880b15626ab7455909258addc5d1549d3edbf8af9a374516930b297c5bdb6ef51a78cac3cb338357896c0d71ae SHA512 80bf6afa00b60aa4245a53e275a2b9579a7936609aba4ffacbbe478f34e530208e0498d8c5ea53dd3a940726e05bd6fac19fed3d6d9dd209af565d5368b2340f
70 changes: 70 additions & 0 deletions app-metrics/prometheus/prometheus-2.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,70 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit user golang-build golang-vcs-snapshot

EGO_PN="github.com/prometheus/prometheus"
MY_PV=${PV/_rc/-rc.}
EGIT_COMMIT="v${MY_PV}"
PROMETHEUS_COMMIT="b639fe1"
ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"

DESCRIPTION="Prometheus monitoring system and time series database"
HOMEPAGE="https://github.com/prometheus/prometheus"
SRC_URI="${ARCHIVE_URI}"
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""

DEPEND="
>=dev-lang/go-1.10
dev-util/promu"

PROMETHEUS_HOME="/var/lib/prometheus"

RESTRICT="test"

pkg_setup() {
enewgroup prometheus
enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
}

src_prepare() {
default
sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN}/.promu.yml || die
}

src_compile() {
pushd src/${EGO_PN} || die
GO111MODULE=on GOPATH="${S}" GOCACHE="${T}/go-cache" promu build -v || die
popd || die
}

src_install() {
pushd src/${EGO_PN} || die
dobin promtool prometheus
dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
insinto /etc/prometheus
doins documentation/examples/prometheus.yml
insinto /usr/share/prometheus
doins -r console_libraries consoles
dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
popd || die

newinitd "${FILESDIR}"/prometheus-3.initd prometheus
newconfd "${FILESDIR}"/prometheus.confd prometheus
keepdir /var/log/prometheus /var/lib/prometheus
fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
}

pkg_postinst() {
if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
ewarn "This release requires a clean storage directory and is not compatible with"
ewarn "files created by previous beta releases"
fi
}

0 comments on commit ba7222a

Please sign in to comment.