Skip to content

Commit

Permalink
media-sound/qsampler: bump to 0.4.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.1
  • Loading branch information
aballier committed Sep 26, 2016
1 parent 3febabc commit baba26b
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-sound/qsampler/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST qsampler-0.4.0.tar.gz 243065 SHA256 4f45e80dca00593ad7d9703125e300f98a6f4dce5216985b07f26f3f76ba80e4 SHA512 42c235396cf68bd811fa251fd6f112a835ce1769130823163fa1a0e517431922b941aa56bc88f22890e6d6326b38765a2f3ced8e67a78d3420600f85e827d467 WHIRLPOOL 330769bd6615ec9a909914e1f3559f5999bbfa9e3d9de85432c12656459e5956a2ea547737b7ef72d8545d2b91da710289ce83e2cff6a9fdd5aee28a5e208818
DIST qsampler-0.4.1.tar.gz 243377 SHA256 2e2315b8b4c1c33512618a2a3c0d6dfdb5ee10914cc9eac5deb2f5c0d9bcb08d SHA512 ffa6e2feb11f9a96580fb1803b6ddb5c56ae475c1f04b5bfa94b1403c29ed0e14f8f60e9166ca166d5b478184c37337b0de0e098a54f74a90f951260d070ce14 WHIRLPOOL b4cfed615681d621b100b0f22525fbdedda8b5907888b16660959e324cbb7c91941c123bf7dc04625f7fdf50ca064a88513bc47dad1052a7b9778c2464e631ba
43 changes: 43 additions & 0 deletions media-sound/qsampler/qsampler-0.4.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit eutils qmake-utils

DESCRIPTION="A graphical frontend to the LinuxSampler engine"
HOMEPAGE="http://www.linuxsampler.org/"
SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug +libgig"

DEPEND="media-libs/alsa-lib
>=media-libs/liblscp-0.5.6:=
x11-libs/libX11
libgig? ( >=media-libs/libgig-3.3.0:= )
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtx11extras:5
dev-qt/qtwidgets:5"
RDEPEND="${DEPEND}
>=media-sound/linuxsampler-0.5"
DEPEND="${DEPEND}
dev-qt/linguist-tools:5"

src_configure() {
ac_qmake="$(qt5_get_bindir)/qmake" \
econf $(use_enable debug) \
$(use_enable libgig) \
--disable-qt4
cd "${S}/src"
eqmake5 src.pro -o Makefile
}

src_install() {
emake DESTDIR="${D}" install
dodoc AUTHORS ChangeLog README TODO TRANSLATORS
doman ${PN}.1
}

0 comments on commit baba26b

Please sign in to comment.