Skip to content

Commit

Permalink
dev-php/pecl-raphf: add PHP 7.3 support
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Jun 7, 2019
1 parent 843b458 commit bad55f6
Showing 1 changed file with 6 additions and 6 deletions.
12 changes: 6 additions & 6 deletions dev-php/pecl-raphf/pecl-raphf-2.0.0-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,20 +1,20 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
EAPI="7"

PHP_EXT_NAME="raphf"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
PHP_EXT_ECONF_ARGS=""
PHP_INI_NAME="30-${PHP_EXT_NAME}"

USE_PHP="php5-6 php7-0 php7-1 php7-2"
USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"

inherit php-ext-pecl-r3

# Only really build for 7.x
USE_PHP="php7-0 php7-1 php7-2"
USE_PHP="php7-1 php7-2 php7-3"

KEYWORDS="~amd64 ~x86"

Expand All @@ -26,15 +26,15 @@ IUSE=""
RDEPEND="php_targets_php5-6? ( ${CATEGORY}/${PN}:0[php_targets_php5-6] )"

src_prepare() {
if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2; then
if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3; then
php-ext-source-r3_src_prepare
else
default_src_prepare
fi
}

src_install() {
if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2; then
if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3; then
php-ext-pecl-r3_src_install
fi
}

0 comments on commit bad55f6

Please sign in to comment.