forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <[email protected]>
- Loading branch information
Showing
3 changed files
with
162 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST totem-3.32.1.tar.xz 2154892 BLAKE2B ff9ec2facbada0f72ae82bbb35d03e82b574be02d7c1f1d4c4dd3262e2b302d3430ba953cd9f4b4e1d1e5151f9b5987986c7ea387a7f5d6667eb931d41805659 SHA512 31a3e3ac7628b992da3cf99570d013eb8b972e28465db30a9ec68291f8e19ab498d89df6275228367a7e3e43121bcebda2654f2b0461a9d1d561cf46e0029f67 | ||
DIST totem-3.34.1.tar.xz 2157160 BLAKE2B 9ae9c8f6485c7377af07803c328e8ea3cc6fa80d8e30a7045bd2b50f7bc3d5a12582e5b60d901d22683f89e994c619c26ddb8b0890e343c873d4457fa177786d SHA512 9a3556f5cf522fca29926db185c2e5d25bdb80a25e14d0ba3062a7f15fc3ec40ae9f25752763bc444d4fd82ec2098efd732da662a1b1c5923ec19fde432606db |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,42 @@ | ||
From 2108ed8d025499fbf11dfe750ebc7617bdbb795a Mon Sep 17 00:00:00 2001 | ||
From: Gilles Dartiguelongue <[email protected]> | ||
Date: Thu, 7 Jun 2018 23:47:48 +0200 | ||
Subject: [PATCH] Make gst-inspect calls optional at build-time | ||
|
||
Crashes on Gentoo due to plugins trying to access dri nodes which are sandboxed | ||
--- | ||
meson_options.txt | 1 + | ||
src/backend/meson.build | 2 ++ | ||
2 files changed, 3 insertions(+) | ||
|
||
diff --git a/meson_options.txt b/meson_options.txt | ||
index d6f8b4290..c8db92335 100644 | ||
--- a/meson_options.txt | ||
+++ b/meson_options.txt | ||
@@ -2,3 +2,4 @@ option('enable-easy-codec-installation', type: 'combo', choices: ['yes', 'no', ' | ||
option('enable-python', type: 'combo', choices: ['yes', 'no', 'auto'], value: 'auto', description: 'Enable python support') | ||
option('with-plugins', type: 'combo', choices: ['all', 'none', 'auto'], value: 'auto', description: 'Which Totem plugins to compile (default: auto; "all", "none" and "auto" are valid)') | ||
option('enable-gtk-doc', type: 'boolean', value: false, description: 'use gtk-doc to build documentation') | ||
+option('gst-inspect', type: 'boolean', value: true, description: 'build-time test of available gstreamer plugins') | ||
diff --git a/src/backend/meson.build b/src/backend/meson.build | ||
index 7a63bab1b..5c4ebb996 100644 | ||
--- a/src/backend/meson.build | ||
+++ b/src/backend/meson.build | ||
@@ -1,5 +1,6 @@ | ||
backend_inc = include_directories('.') | ||
|
||
+if get_option('gst-inspect') | ||
gst_inspect = find_program( | ||
'gst-inspect-1.0', | ||
join_paths(gst_dep.get_pkgconfig_variable('toolsdir'), 'gst-inspect-1.0'), | ||
@@ -31,6 +32,7 @@ foreach plugin: gst_good_plugins | ||
assert(r.returncode() == 0, | ||
'Cannot find required GStreamer-1.0 plugin "' + plugin + '". It should be part of gst-plugins-good. Please install it.') | ||
endforeach | ||
+endif | ||
|
||
sources = files( | ||
'bacon-time-label.c', | ||
-- | ||
2.20.1 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,119 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
PYTHON_COMPAT=( python3_{6,7,8} ) | ||
PYTHON_REQ_USE="threads(+)" | ||
|
||
inherit gnome.org gnome2-utils meson virtualx xdg python-single-r1 | ||
|
||
DESCRIPTION="Media player for GNOME" | ||
HOMEPAGE="https://wiki.gnome.org/Apps/Videos" | ||
|
||
LICENSE="GPL-2+ LGPL-2+" | ||
SLOT="0" | ||
IUSE="gtk-doc +python test" | ||
# see bug #359379 | ||
REQUIRED_USE=" | ||
python? ( ${PYTHON_REQUIRED_USE} ) | ||
" | ||
RESTRICT="!test? ( test )" | ||
|
||
KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86" | ||
|
||
DEPEND=" | ||
>=dev-libs/glib-2.43.4:2 | ||
>=x11-libs/gtk+-3.19.4:3[introspection] | ||
>=media-libs/gstreamer-1.6.0:1.0 | ||
>=media-libs/gst-plugins-base-1.6.0:1.0[pango] | ||
>=media-libs/gst-plugins-good-1.6.0:1.0 | ||
>=media-libs/grilo-0.3.0:0.3[playlist] | ||
>=dev-libs/libpeas-1.1.0[gtk] | ||
>=dev-libs/totem-pl-parser-3.10.1:0=[introspection] | ||
>=media-libs/clutter-1.17.3:1.0[gtk] | ||
>=media-libs/clutter-gst-2.99.2:3.0 | ||
>=media-libs/clutter-gtk-1.8.1:1.0 | ||
gnome-base/gnome-desktop:3= | ||
gnome-base/gsettings-desktop-schemas | ||
>=x11-libs/cairo-1.14 | ||
x11-libs/gdk-pixbuf:2 | ||
>=dev-libs/gobject-introspection-1.54:= | ||
python? ( | ||
${PYTHON_DEPS} | ||
$(python_gen_cond_dep ' | ||
>=dev-python/pygobject-2.90.3:3[${PYTHON_MULTI_USEDEP}] | ||
') | ||
) | ||
" | ||
RDEPEND="${DEPEND} | ||
media-plugins/grilo-plugins:0.3 | ||
media-plugins/gst-plugins-meta:1.0 | ||
media-plugins/gst-plugins-taglib:1.0 | ||
x11-themes/adwaita-icon-theme | ||
python? ( | ||
x11-libs/pango[introspection] | ||
>=dev-libs/libpeas-1.1.0[python,${PYTHON_SINGLE_USEDEP}] | ||
$(python_gen_cond_dep ' | ||
dev-python/dbus-python[${PYTHON_MULTI_USEDEP}] | ||
') | ||
) | ||
" | ||
BDEPEND=" | ||
dev-lang/perl | ||
gtk-doc? ( >=dev-util/gtk-doc-1.14 | ||
app-text/docbook-xml-dtd:4.5 ) | ||
dev-util/glib-utils | ||
dev-util/itstool | ||
>=sys-devel/gettext-0.19.8 | ||
virtual/pkgconfig | ||
x11-base/xorg-proto | ||
" | ||
# perl for pod2man | ||
# Prevent dev-python/pylint dep, bug #482538 | ||
|
||
PATCHES=( | ||
"${FILESDIR}"/${PV}-gst-inspect-sandbox.patch # Allow disabling calls to gst-inspect (sandbox issue) | ||
) | ||
|
||
pkg_setup() { | ||
use python && python-single-r1_pkg_setup | ||
} | ||
|
||
src_prepare() { | ||
# Drop pointless samplepython plugin from build | ||
sed -e '/samplepython/d' -i src/plugins/meson.build || die | ||
xdg_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local emesonargs=( | ||
-Denable-easy-codec-installation=yes | ||
-Denable-python=$(usex python yes no) | ||
-Dwith-plugins=all # in 3.34.1 only builtin and python plugins are left, and python is extra controlled by enable-python | ||
$(meson_use gtk-doc enable-gtk-doc) | ||
-Dgst-inspect=false | ||
) | ||
meson_src_configure | ||
} | ||
|
||
src_install() { | ||
meson_src_install | ||
if use python ; then | ||
python_optimize "${ED}"/usr/$(get_libdir)/totem/plugins/ | ||
fi | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_pkg_postinst | ||
gnome2_schemas_update | ||
} | ||
|
||
pkg_postrm() { | ||
xdg_pkg_postrm | ||
gnome2_schemas_update | ||
} | ||
|
||
src_test() { | ||
virtx meson_src_test | ||
} |