Skip to content

Commit

Permalink
games-puzzle/kiki: Port to python-single-r1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
SoapGentoo committed Feb 18, 2017
1 parent 07be6b5 commit bc9e094
Show file tree
Hide file tree
Showing 4 changed files with 85 additions and 8 deletions.
8 changes: 4 additions & 4 deletions games-puzzle/kiki/files/kiki-1.0.2-build.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- kodilib/linux/Makefile
+++ kodilib/linux/Makefile
--- a/kodilib/linux/Makefile
+++ b/kodilib/linux/Makefile
@@ -21,7 +21,7 @@

INCLUDES = $(KODI_INCLUDES) $(X11_INCLUDES) $(SDL_INCLUDES)
Expand All @@ -9,8 +9,8 @@

src = \
$(KODISRCDIR)/handler/KEventHandler.cpp \
--- linux/Makefile
+++ linux/Makefile
--- a/linux/Makefile
+++ b/linux/Makefile
@@ -14,11 +14,7 @@

GLLIBS = -lglut -lGLU -lGL
Expand Down
4 changes: 2 additions & 2 deletions games-puzzle/kiki/files/kiki-1.0.2-freeglut.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- src/main/main.cpp.orig 2003-04-11 14:42:29.000000000 +0100
+++ src/main/main.cpp 2006-07-06 19:37:55.000000000 +0100
--- a/src/main/main.cpp.orig 2003-04-11 14:42:29.000000000 +0100
+++ b/src/main/main.cpp 2006-07-06 19:37:55.000000000 +0100
@@ -9,6 +9,7 @@
#include <math.h>

Expand Down
4 changes: 2 additions & 2 deletions games-puzzle/kiki/files/kiki-1.0.2-gcc41.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- src/main/KikiPythonWidget.h.old 2006-05-07 23:14:09.000000000 +0200
+++ src/main/KikiPythonWidget.h 2006-05-07 23:17:20.000000000 +0200
--- a/src/main/KikiPythonWidget.h.old 2006-05-07 23:14:09.000000000 +0200
+++ b/src/main/KikiPythonWidget.h 2006-05-07 23:17:20.000000000 +0200
@@ -9,6 +9,7 @@
#include "KikiPos.h"
#include <KTextField.h>
Expand Down
77 changes: 77 additions & 0 deletions games-puzzle/kiki/kiki-1.0.2-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,77 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python2_7 )

inherit python-single-r1 toolchain-funcs

DESCRIPTION="Fun 3D puzzle game using SDL/OpenGL"
HOMEPAGE="http://kiki.sourceforge.net/"
SRC_URI="mirror://sourceforge/kiki/${P}-src.tgz"

LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="
media-libs/libsdl[opengl]
media-libs/sdl-image
media-libs/sdl-mixer
virtual/opengl
virtual/glu
media-libs/freeglut
${PYTHON_DEPS}"
DEPEND="${RDEPEND}
dev-lang/swig"

S=${WORKDIR}/${PN}

PATCHES=(
"${FILESDIR}"/${P}-gcc41.patch
"${FILESDIR}"/${P}-freeglut.patch
"${FILESDIR}"/${P}-gcc43.patch
"${FILESDIR}"/${P}-build.patch
)

src_prepare() {
default

rm -f py/runkiki || die

# Change the hard-coded data dir for sounds, etc...
sed -i \
-e "s:kiki_home += /;:kiki_home = /usr/share/${PN}/;:g" \
-e "s:KConsole\:\:printf(\"WARNING \:\: environment variable KIKI_HOME not set ...\");::g" \
-e "s:KConsole\:\:printf(\" ... assuming resources in current directory\");::g" \
src/main/KikiController.cpp || die

# Bug 139570
cd SWIG || die
swig -c++ -python -globals kiki -o KikiPy_wrap.cpp KikiPy.i || die
cp -f kiki.py ../py || die
eapply "${FILESDIR}"/${P}-gcc46.patch
}

src_compile() {
tc-export AR CXX

emake -C kodilib/linux
emake -C linux PYTHON_VERSION="${EPYTHON#python}"
}

src_install() {
dobin linux/kiki

insinto /usr/share/${PN}
doins -r sound

python_moduleinto ${PN}
python_domodule py/.

dodoc Readme.txt Thanks.txt
}

0 comments on commit bc9e094

Please sign in to comment.