Skip to content

Commit

Permalink
dev-haskell/arithmoi: initial import, numeric library
Browse files Browse the repository at this point in the history
Efficient basic number-theoretic functions.
Primes, powers, integer logarithms for haskell.

Package-Manager: portage-2.2.27
  • Loading branch information
Sergei Trofimovich committed Feb 6, 2016
1 parent bf5522d commit bcaeae8
Show file tree
Hide file tree
Showing 3 changed files with 54 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-haskell/arithmoi/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST arithmoi-0.4.1.3.tar.gz 66196 SHA256 2e623924079d3f8733fd31bf40a30ee0051dd0c3e3ae4b13a7afb5f2300413c9 SHA512 abc5939207e502dffd91b3a4e2b9c688eef388a6b9354576fcb4badf4625da1cad0e9698cb42b293b37cc29427ad2679170452374fbf6cd5e614d53db34cd9f6 WHIRLPOOL dc0c167e63430d8f57fef7107f8444fa2fb1e76a5664043524df6c606f778cbecb457c43d9b1484015b96d4f91c221e60718f637593362ad657e7c5a5ae24a48
34 changes: 34 additions & 0 deletions dev-haskell/arithmoi/arithmoi-0.4.1.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

# ebuild generated by hackport 0.4.5.9999
#hackport: flags: -llvm

CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal

DESCRIPTION="Efficient basic number-theoretic functions. Primes, powers, integer logarithms"
HOMEPAGE="https://github.com/cartazio/arithmoi"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND=">=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
>=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.2:=[profile?]
>=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.10
test? ( dev-haskell/hspec )
"

src_configure() {
haskell-cabal_src_configure \
--flag=-llvm
}
19 changes: 19 additions & 0 deletions dev-haskell/arithmoi/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Haskell</name>
</maintainer>
<longdescription>
A library of basic functionality needed for
number-theoretic calculations. The aim of this library
is to provide efficient implementations of the functions.
Primes and related things (totients, factorisation),
powers (integer roots and tests, modular exponentiation),
integer logarithms.
Note: Requires GHC &gt;= 6.12 with the integer-gmp package
for efficiency. Portability is on the to-do list (with
low priority, however).
</longdescription>
</pkgmetadata>

0 comments on commit bcaeae8

Please sign in to comment.