Skip to content

Commit

Permalink
games-board/qcheckers: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0
  • Loading branch information
austin987 committed Aug 2, 2016
1 parent 7d5ec09 commit bd1b38c
Showing 1 changed file with 33 additions and 0 deletions.
33 changes: 33 additions & 0 deletions games-board/qcheckers/qcheckers-20091230-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils qmake-utils

MY_PN=${PN/qc/QC}

DESCRIPTION="Qt4 based checkers game"
HOMEPAGE="https://code.google.com/p/qcheckers/"
SRC_URI="https://qcheckers.googlecode.com/files/${MY_PN}-${PV}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND="dev-qt/qtgui:4"
RDEPEND=${DEPEND}

S=${WORKDIR}/${MY_PN}

src_configure() {
eqmake4 ${MY_PN}.pro
}

src_install() {
dobin ${MY_PN}
newicon icons/help-about.png ${PN}.png
make_desktop_entry ${MY_PN} ${MY_PN}
dodoc README
}

0 comments on commit bd1b38c

Please sign in to comment.