forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-emulation/diskimage-builder: 3.16.0 bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Matthew Thode <[email protected]>
- Loading branch information
1 parent
0e768db
commit bdabf26
Showing
2 changed files
with
40 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
39 changes: 39 additions & 0 deletions
39
app-emulation/diskimage-builder/diskimage-builder-3.16.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,39 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PYTHON_COMPAT=( python3_{7,8,9} ) | ||
DISTUTILS_USE_SETUPTOOLS=rdepend | ||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Golden Disk Image builder." | ||
HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/" | ||
if [[ ${PV} == 9999* ]]; then | ||
inherit git-r3 | ||
EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git" | ||
else | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux" | ||
fi | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
IUSE="" | ||
|
||
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}] | ||
!~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]" | ||
DEPEND="${CDEPEND}" | ||
RDEPEND="${CDEPEND} | ||
>=dev-python/Babel-2.3.4[${PYTHON_USEDEP}] | ||
!~dev-python/Babel-2.4.0[${PYTHON_USEDEP}] | ||
>=dev-python/networkx-1.10[${PYTHON_USEDEP}] | ||
>=dev-python/pyyaml-3.12[${PYTHON_USEDEP}] | ||
>=dev-python/six-1.10.0[${PYTHON_USEDEP}] | ||
>=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}] | ||
app-emulation/qemu | ||
sys-block/parted | ||
sys-fs/multipath-tools | ||
sys-fs/dosfstools | ||
sys-apps/gptfdisk | ||
!dev-python/dib-utils[${PYTHON_USEDEP}]" |