Skip to content

Commit

Permalink
app-cdr/b5i2iso: segfault patch, HOMEPAGE, Gentoo Prefix
Browse files Browse the repository at this point in the history
Closes: gentoo#4664
  • Loading branch information
lukateras authored and mgorny committed May 18, 2017
1 parent f10528b commit bddfa12
Show file tree
Hide file tree
Showing 3 changed files with 46 additions and 1 deletion.
24 changes: 24 additions & 0 deletions app-cdr/b5i2iso/b5i2iso-0.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
inherit toolchain-funcs

DESCRIPTION="Convert CD images from b5i (BlindWrite) to iso"
HOMEPAGE="https://web.archive.org/web/20100116120705/b5i2iso.berlios.de"
SRC_URI="mirror://gentoo/${PN}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-macos ~x64-macos"
PATCHES=( "${FILESDIR}/${P}-segfault.patch" )

S=${WORKDIR}/${PN}

src_compile() {
$(tc-getCC) ${LDFLAGS} ${CFLAGS} src/${PN}.c -o ${PN}
}

src_install() {
dobin ${PN}
}
18 changes: 18 additions & 0 deletions app-cdr/b5i2iso/files/b5i2iso-0.2-segfault.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@
--- b5i2iso/src/b5i2iso.c
+++ b5i2iso/src/b5i2iso.c
@@ -1,3 +1,4 @@
+#include <errno.h>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
@@ -45,6 +46,10 @@
}

fsource = fopen(argv[1],"rb");
+if (fsource == NULL) {
+ printf("can't open %s: %s\n", argv[1], strerror(errno));
+ exit(EXIT_FAILURE);
+}
fdest = fopen(destfilename,"wb");

fseek(fsource, 2352, SEEK_CUR);
5 changes: 4 additions & 1 deletion app-cdr/b5i2iso/metadata.xml
Original file line number Diff line number Diff line change
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
<maintainer type="person">
<email>[email protected]</email>
<name>Yegor Timoshenko</name>
</maintainer>
</pkgmetadata>

0 comments on commit bddfa12

Please sign in to comment.