Skip to content

Commit

Permalink
dev-embedded/esptool: fix incorrect DISTUTILS_USE_SETUPTOOLS value
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/746614
Package-Manager: Portage-3.0.8, Repoman-3.0.1
Signed-off-by: Martin Dummer <[email protected]>
Closes: gentoo#17807
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
madmartin authored and juippis committed Oct 11, 2020
1 parent ff9303f commit bdfbde2
Showing 1 changed file with 40 additions and 0 deletions.
40 changes: 40 additions & 0 deletions dev-embedded/esptool/esptool-2.8-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6,7,8,9} )
DISTUTILS_SINGLE_IMPL=1

inherit distutils-r1

DESCRIPTION="Utility to communicate with the ROM bootloader in Espressif ESP8266 and ESP32"
HOMEPAGE="https://github.com/espressif/esptool"
SRC_URI="https://github.com/espressif/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
$(python_gen_cond_dep '
dev-python/ecdsa[${PYTHON_MULTI_USEDEP}]
dev-python/pyaes[${PYTHON_MULTI_USEDEP}]
>=dev-python/pyserial-3.0[${PYTHON_MULTI_USEDEP}]
')
"
BDEPEND="
test? ( $(python_gen_cond_dep 'dev-python/pyelftools[${PYTHON_MULTI_USEDEP}]') )
"

src_prepare() {
rm -rf pyaes/ ecdsa/ || die "unable to remove bundled modules"
default
}

python_test() {
${EPYTHON} test/test_imagegen.py || die "imagegen test failed with ${EPYTHON}"
${EPYTHON} test/test_espsecure.py || die "espsecure test failed with ${EPYTHON}"
}

0 comments on commit bdfbde2

Please sign in to comment.