Skip to content

Commit

Permalink
app-misc/carbon-c-relay-3.7.3: version bump, fix #822711
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/822711
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Fabian Groffen <[email protected]>
  • Loading branch information
grobian committed Nov 9, 2021
1 parent 04b95b7 commit bf0bfb4
Show file tree
Hide file tree
Showing 2 changed files with 59 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/carbon-c-relay/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST carbon-c-relay-3.7.2.tar.gz 561080 BLAKE2B 55674699b2afcffa911954a52e3c51b92380c81083db0330e7e6eab495e72938b7761a8c7bc17ac65ea56db1c11f4c360bab3b7442ca13f3466170d6bb3f6fd6 SHA512 dab2eaf2da07afd429012b93f0c826e2fe6e43371afa07d34793dd212820790af2487f5710524deac52c3ed18b874ce8ff54d90b3872e269dc570b7ad30c1826
DIST carbon-c-relay-3.7.3.tar.gz 575680 BLAKE2B d2d07c7f1ec356a16bb375bd740ffa018a0d256ef1ce97ae0555001411a05e28173c2009f3980b0d711977068392b5a0baca68f9dda3a677c7c3d245cad70a0e SHA512 ba3e4b7173abe5e3b018413a8d46d91c3f433e785dcf3d7643836b91f9a6ff993b22c3db51192476c75d45486d1e2541ad73056671b4bdbfd1447dcfc3f26ff3
58 changes: 58 additions & 0 deletions app-misc/carbon-c-relay/carbon-c-relay-3.7.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DESCRIPTION="Enhanced C version of Carbon relay, aggregator and rewriter"
HOMEPAGE="https://github.com/grobian/carbon-c-relay"
SRC_URI="https://github.com/grobian/carbon-c-relay/releases/download/v${PV}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc64 ~x64-macos ~x64-solaris ~x86-solaris"
IUSE="lz4 snappy zlib ssl pcre pcre2 +oniguruma"

# ensure only one of pcre, pcre2 and oniguruma is set, or none (libc)
# unforunately pcre is in global USE, so we have to exclude that here
REQUIRED_USE="
pcre2? ( !oniguruma )
oniguruma? ( !pcre2 )
"
RDEPEND="lz4? ( app-arch/lz4 )
snappy? ( app-arch/snappy )
zlib? ( app-arch/gzip )
ssl? ( dev-libs/openssl:0= )
!oniguruma? ( !pcre2? ( pcre? ( dev-libs/libpcre ) ) )
pcre2? ( dev-libs/libpcre2 )
oniguruma? ( dev-libs/oniguruma )
acct-group/carbon
acct-user/carbon"
DEPEND="${RDEPEND}"

src_configure() {
local pcrecfg
if use !pcre2 && use !oniguruma ; then
pcrecfg=$(use_with pcre)
else
pcrecfg="--without-pcre"
fi

econf $(use_with lz4) $(use_with snappy) \
$(use_with ssl) $(use_with zlib gzip) \
"${pcrecfg}" $(use_with pcre2) $(use_with oniguruma)
}

src_install() {
default

# rename too generic name
mv "${ED}"/usr/bin/{relay,${PN}} || die

# remove libfaketime, necessary for testing only
rm -f "${ED}"/usr/$(get_libdir)/libfaketime.*

dodoc ChangeLog.md

newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
newconfd "${FILESDIR}"/${PN}.confd-r1 ${PN}
}

0 comments on commit bf0bfb4

Please sign in to comment.