Skip to content

Commit

Permalink
sys-libs/uclibc: git-2->git-r3, explicit EAPI=0
Browse files Browse the repository at this point in the history
Also unified the live vs versioned ebuild logic.

Package-Manager: Portage-2.3.31, Repoman-2.3.9
Signed-off-by: Anthony G. Basile <[email protected]>
  • Loading branch information
hanetzer authored and blueness committed Apr 27, 2018
1 parent 27b53eb commit bf60ab9
Show file tree
Hide file tree
Showing 3 changed files with 43 additions and 36 deletions.
27 changes: 15 additions & 12 deletions sys-libs/uclibc/uclibc-0.9.33.2-r15.ebuild
Original file line number Diff line number Diff line change
@@ -1,10 +1,20 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=0

inherit eutils flag-o-matic multilib toolchain-funcs savedconfig
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.busybox.net/uClibc"
inherit git-2

MY_P=uClibc-${PV}
if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://git.busybox.net/uClibc"
EGIT_BRANCH="0.9.33"
inherit git-r3
else
PATCH_VER="17"
SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
KEYWORDS="-* amd64 arm m68k ~mips ppc sh sparc x86"
fi

export CBUILD=${CBUILD:-${CHOST}}
Expand All @@ -15,15 +25,8 @@ if [[ ${CTARGET} == ${CHOST} ]] ; then
fi
fi

MY_P=uClibc-${PV}
DESCRIPTION="C library for developing embedded Linux systems"
HOMEPAGE="https://www.uclibc.org/"
if [[ ${PV} != "9999" ]] ; then
PATCH_VER="17"
SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
KEYWORDS="-* amd64 arm m68k ~mips ppc sh sparc x86"
fi

LICENSE="LGPL-2"
SLOT="0"
Expand Down Expand Up @@ -232,8 +235,8 @@ src_config() {
}

src_unpack() {
if [[ ${PV} == "9999" ]] ; then
git-2_src_unpack
if [[ ${PV} == *9999* ]] ; then
git-r3_src_unpack
else
unpack ${A}
fi
Expand Down
26 changes: 14 additions & 12 deletions sys-libs/uclibc/uclibc-0.9.33.9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,11 +1,20 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=0

inherit eutils flag-o-matic multilib toolchain-funcs savedconfig
if [[ ${PV} == *9999 ]] ; then

MY_P=uClibc-${PV}
if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://git.busybox.net/uClibc"
EGIT_BRANCH="0.9.33"
EGIT_REPO_URI="git://git.busybox.net/uClibc"
inherit git-2
inherit git-r3
else
PATCH_VER=""
SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
KEYWORDS="-* ~amd64 ~arm ~m68k ~mips ~ppc ~sh ~sparc ~x86"
fi

export CBUILD=${CBUILD:-${CHOST}}
Expand All @@ -16,15 +25,8 @@ if [[ ${CTARGET} == ${CHOST} ]] ; then
fi
fi

MY_P=uClibc-${PV}
DESCRIPTION="C library for developing embedded Linux systems"
HOMEPAGE="https://www.uclibc.org/"
if [[ ${PV} != *9999 ]] ; then
PATCH_VER=""
SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
KEYWORDS="-* ~amd64 ~arm ~m68k ~mips ~ppc ~sh ~sparc ~x86"
fi

LICENSE="LGPL-2"
SLOT="0"
Expand Down Expand Up @@ -231,8 +233,8 @@ src_config() {
}

src_unpack() {
if [[ ${PV} == *9999 ]] ; then
git-2_src_unpack
if [[ ${PV} == *9999* ]] ; then
git-r3_src_unpack
else
unpack ${A}
fi
Expand Down
26 changes: 14 additions & 12 deletions sys-libs/uclibc/uclibc-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,10 +1,19 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=0

inherit eutils flag-o-matic multilib toolchain-funcs savedconfig
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.busybox.net/uClibc"
inherit git-2

MY_P=uClibc-${PV}
if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://git.busybox.net/uClibc"
inherit git-r3
else
PATCH_VER=""
SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
KEYWORDS="-* ~amd64 ~arm ~m68k ~mips ~ppc ~sh ~sparc ~x86"
fi

export CBUILD=${CBUILD:-${CHOST}}
Expand All @@ -15,15 +24,8 @@ if [[ ${CTARGET} == ${CHOST} ]] ; then
fi
fi

MY_P=uClibc-${PV}
DESCRIPTION="C library for developing embedded Linux systems"
HOMEPAGE="https://www.uclibc.org/"
if [[ ${PV} != "9999" ]] ; then
PATCH_VER=""
SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
KEYWORDS="-* ~amd64 ~arm ~m68k ~mips ~ppc ~sh ~sparc ~x86"
fi

LICENSE="LGPL-2"
SLOT="0"
Expand Down Expand Up @@ -230,8 +232,8 @@ src_config() {
}

src_unpack() {
if [[ ${PV} == "9999" ]] ; then
git-2_src_unpack
if [[ ${PV} == *9999* ]] ; then
git-r3_src_unpack
else
unpack ${A}
fi
Expand Down

0 comments on commit bf60ab9

Please sign in to comment.