Skip to content

Commit

Permalink
games-emulation/mgba: Bump to version 0.6.3
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.29, Repoman-2.3.9
  • Loading branch information
Lars Wendler committed Apr 17, 2018
1 parent ea90747 commit bf802cd
Show file tree
Hide file tree
Showing 2 changed files with 116 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-emulation/mgba/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST mgba-0.6.1.tar.gz 7437240 BLAKE2B d00ed8a517b6e82f477537702d757bd9d86d007ee7bea022b67751b0423a2f386706e410c5e41b984ae8e7e66efabbf41356b846fdcba438cb5a64c89bc2379c SHA512 fb4d2bd490afa052c32d263e4d7b65ff83ccdcad01f5df6572d73c81de3c4e0c268b102ac36cff4a85ab20fc190d2f1a4959a3058e559a528be5e49c4808ce57
DIST mgba-0.6.2.tar.gz 7441969 BLAKE2B f807a3a26667f50cbf3b87ac6e7887ec7fb99516895e1168855fafee417025a1d1e5605ca3f87a171fde563fd69878d5d164e068247643401c2696164d7460c1 SHA512 8afe4fb331f4163f4cd96cc73a51136bdb9008178b74c0ecb827c1f06dee79eba3cf753e1c35657972d8593ab97d294c15287ebf2c5ffa6a135527d5611d3574
DIST mgba-0.6.3.tar.gz 7442154 BLAKE2B 2b46cf36174ef0a186b1bc71784820e6ddd7754a7cae695a95dcdae96efff58af70dd14faa2f1f6194a23450943d82aed2394f7bf2821ed91bf558eef6ae9c4d SHA512 d646af7869dbcf8df671a75ecfd8c270950c013b826b23b94bacae43a77243786f198725e1b9bf17827d1ffcf6a8eef70091d53ea878bfb2450472485f42f233
115 changes: 115 additions & 0 deletions games-emulation/mgba/mgba-0.6.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,115 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils gnome2-utils xdg-utils

DESCRIPTION="Game Boy Advance emulator written in C"
HOMEPAGE="https://mgba.io"
SRC_URI="https://github.com/${PN}-emu/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug ffmpeg imagemagick opengl qt5 +sdl"
REQUIRED_USE="|| ( qt5 sdl )
qt5? ( opengl )"

RDEPEND="
dev-db/sqlite:3
media-libs/libpng:0=
sys-libs/zlib[minizip]
ffmpeg? ( virtual/ffmpeg )
imagemagick? ( media-gfx/imagemagick:= )
opengl? ( virtual/opengl )
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtmultimedia:5
dev-qt/qtwidgets:5
opengl? ( dev-qt/qtopengl:5 )
)
sdl? ( media-libs/libsdl2[X,sound,joystick,video,opengl?] )
"
DEPEND="${RDEPEND}"

src_prepare() {
cmake-utils_src_prepare

# Get rid of any bundled stuff we don't want
for pkg in libpng lzma sqlite3 zlib ; do
rm -r src/third-party/${pkg} || die
done
}

src_configure() {
local mycmakeargs=(
-DBUILD_GL="$(usex opengl)"
-DBUILD_GLES=OFF
-DBUILD_PYTHON=OFF
-DBUILD_QT="$(usex qt5)"
-DBUILD_SDL="$(usex sdl)"
-DBUILD_SHARED=ON
# test suite fails to build (0.6.0)
-DBUILD_SUITE=OFF
-DBUILD_TEST=OFF
-DM_CORE_GB=ON
-DM_CORE_GBA=ON
-DUSE_DEBUGGERS="$(usex debug)"
-DUSE_EDITLINE="$(usex debug)"
-DUSE_EPOXY=OFF
-DUSE_FFMPEG="$(usex ffmpeg)"
-DUSE_GDB_STUB="$(usex debug)"
-DUSE_LIBZIP=OFF
-DUSE_LZMA=OFF
-DUSE_MAGICK="$(usex imagemagick)"
-DUSE_MINIZIP=ON
-DUSE_PNG=ON
# build fails with sqlite being disabled (0.6.3)
-DUSE_SQLITE3=ON
-DUSE_ZLIB=ON
)
cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile
}

src_install() {
if use qt5 ; then
dobin ../${P}_build/qt/${PN}-qt
doman doc/${PN}-qt.6
domenu res/${PN}-qt.desktop
for size in 16 24 32 48 64 96 128 256; do
newicon -s ${size} res/${PN}-${size}.png ${PN}.png
done
fi
if use sdl ; then
doman doc/${PN}.6
newbin ../${P}_build/sdl/${PN} ${PN}-sdl
fi

dolib.so ../${P}_build/lib${PN}.so*
}

pkg_preinst() {
if use qt5 ; then
gnome2_icon_savelist
fi
}

pkg_postinst() {
if use qt5 ; then
xdg_desktop_database_update
gnome2_icon_cache_update
fi
}

pkg_postrm() {
if use qt5 ; then
xdg_desktop_database_update
gnome2_icon_cache_update
fi
}

0 comments on commit bf802cd

Please sign in to comment.