Skip to content

Commit

Permalink
app-text/atril: Version bump to 1.18.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
mudler committed Jun 4, 2017
1 parent 4affeba commit c04ad30
Show file tree
Hide file tree
Showing 2 changed files with 90 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-text/atril/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST atril-1.12.2.tar.xz 1663920 SHA256 47cd22969d4ff6ef860a310a57f77f1fcc0c5674113a72ee507d2b1b5c780226 SHA512 2ceeda42adeb284a25caff3a69d15a231129988fb410e4d502a281ccf5819307b9963722a2e330307a1c3b15d3c82405b708d983ed1c266e091a35264766e6ec WHIRLPOOL 8eb8a0cd40c0c3d21141493a09b3dc8f2c4d902fff1ed80fe5468b1ac342c81312518c015cbd288372f228bc4bb91bb1555af8f8b5842e72e4eb895fc787988c
DIST atril-1.14.2.tar.xz 1703272 SHA256 9a8eadd85bda4539560f01a2127be4d6c358c07c6a744c09d1fdb5bff7ce14f4 SHA512 9f77abe43848a3a35df1484edef4a6bbc6339f82b0d8e9f3c149c44fd632f2720acf24bcc1354b944c5c364fc4ce1d70b733c1ec5bc40b1a17041e59acf7bd9b WHIRLPOOL 3e4bf2f6af6369b7cf410f161c159f6f0221d311b354c24d8b86fbcb14c3553d01ea6d79667d9817541aa401202bc8590d074f635745730854a148ca74b41dfc
DIST atril-1.16.1.tar.xz 1691456 SHA256 c74a5f8c8603fa5952efb4343f055677e4474f1907080be9658d4456d3dc092f SHA512 69128171f13f50079b0b40bfada868967c289b5970e3cda3454f10e7cf723000ab29290c7c9ada67648c370472fd51eeb0a8dbbfa0af05babfc85cb28e3570fe WHIRLPOOL a7b386897c598e473642aa8c3ba2a40211c4389ef3560e574adf04072882887e37a50a7d83ff5fab4c74982908994c926211272d33220fb47a360e05c851a670
DIST atril-1.18.0.tar.xz 1688144 SHA256 c2284f17f7b683efa22615f00cf2768ea07667981d8304566e49c3d863de80fd SHA512 71e40faebfac08c60c90e7c919d2274976a5f03e6f9c6882fe81d4736152c14b1baf45da770f357030708d103203a4ffc47387c736c4df8737dfc5caf1fd466a WHIRLPOOL 4cef97e4a832a2123ddfc1ddaf2af8d44af9a746676ce356c0d7dcc4fe463a762ab33982fa2045ca9bf461dd79c52b513d6fe263fd153121ff3a6afad1708ecc
89 changes: 89 additions & 0 deletions app-text/atril/atril-1.18.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,89 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

MATE_LA_PUNT="yes"

inherit mate

if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~x86"
fi

DESCRIPTION="Atril document viewer for MATE"
LICENSE="GPL-2"
SLOT="0"

IUSE="caja dbus debug djvu dvi epub +introspection gnome-keyring +postscript t1lib tiff xps"

REQUIRED_USE="t1lib? ( dvi )"

COMMON_DEPEND=">=app-text/poppler-0.22:0=[cairo]
dev-libs/atk:0
>=dev-libs/glib-2.36:2
>=dev-libs/libxml2-2.5:2
sys-libs/zlib:0
x11-libs/gdk-pixbuf:2
>=x11-libs/gtk+-3.14:3[introspection?]
x11-libs/libICE:0
>=x11-libs/libSM-1:0
x11-libs/libX11:0
>=x11-libs/cairo-1.9.10:0
x11-libs/pango:0
caja? ( >=mate-base/caja-1.17.1[introspection?] )
djvu? ( >=app-text/djvu-3.5.17:0 )
dvi? (
virtual/tex-base:0
t1lib? ( >=media-libs/t1lib-5:5 )
)
epub? (
dev-libs/mathjax
>=net-libs/webkit-gtk-2.4.3:4
)
gnome-keyring? ( >=app-crypt/libsecret-0.5:0 )
introspection? ( >=dev-libs/gobject-introspection-0.6:= )
postscript? ( >=app-text/libspectre-0.2:0 )
tiff? ( >=media-libs/tiff-3.6:0 )
xps? ( >=app-text/libgxps-0.2.1:0 )
!!app-text/mate-document-viewer"

RDEPEND="${COMMON_DEPEND}"

DEPEND="${COMMON_DEPEND}
app-text/docbook-xml-dtd:4.1.2
app-text/rarian:0
app-text/yelp-tools:0
>=app-text/scrollkeeper-dtd-1:1.0
dev-util/gtk-doc
dev-util/gtk-doc-am
>=dev-util/intltool-0.50.1:*
virtual/pkgconfig:*
sys-devel/gettext:*"

# Tests use dogtail which is not available on Gentoo.
RESTRICT="test"

src_configure() {
# Passing --disable-help would drop offline help, that would be inconsistent
# with helps of the most of GNOME apps that doesn't require network for that.
mate_src_configure \
--disable-tests \
--enable-comics \
--enable-pdf \
--enable-pixbuf \
--enable-previewer \
--enable-thumbnailer \
$(use_with gnome-keyring keyring) \
$(use_enable caja) \
$(use_enable dbus) \
$(use_enable debug) \
$(use_enable djvu) \
$(use_enable dvi) \
$(use_enable epub) \
$(use_enable introspection) \
$(use_enable postscript ps) \
$(use_enable t1lib) \
$(use_enable tiff) \
$(use_enable xps)
}

0 comments on commit c04ad30

Please sign in to comment.