Skip to content

Commit

Permalink
dev-php/symfony-process: bump to v3.4.38
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Mar 19, 2020
1 parent bb57567 commit c064142
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/symfony-process/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST symfony-process-3.4.29.tar.gz 34684 BLAKE2B 87f79a17ac321b395a634f0b83a0d218c39a06f0b5b553904c1c00431ffaf94f7bd26aa015cd426f5ba7726f09328b4b1d4475f4f8c229eedc1d52fc3f0142c1 SHA512 9e19406cad79f51d4ec811460a762c3a5004679e53777ca37049f5d8eb73bc3b569e266bd11ecddfc42481d7f05a4850bd6901c3ec2dd1d398d5077cdbe2e0bd
DIST symfony-process-3.4.38.tar.gz 34424 BLAKE2B d990ba77e1d1e9b00e1b22381c9b3c454d94a8705ff7bd9830b59a32108f590efbb7e434e0f11421ccb143aa72d659d7211062c07c0cb36d18aae1f01e073b3a SHA512 14ff5f874904166978cb4021c87fde42611f05505498a8257089f97ae6f65051427c0f8e720a28b57e64de436818967676e35ddfc273e86b809ea0bf590662af
43 changes: 43 additions & 0 deletions dev-php/symfony-process/symfony-process-3.4.38.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

DESCRIPTION="Symfony Process Component"
HOMEPAGE="https://github.com/symfony/process"
SRC_URI="https://github.com/symfony/process/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="test"

RDEPEND="
dev-lang/php:*
dev-php/fedora-autoloader"
DEPEND="
test? (
${RDEPEND}
dev-php/phpunit )"

S="${WORKDIR}/process-${PV}"

src_prepare() {
default
if use test; then
cp "${FILESDIR}"/autoload.php "${S}"/autoload-test.php || die
fi
}

src_install() {
insinto "/usr/share/php/Symfony/Component/Process"
doins -r Exception/ Pipes/ ExecutableFinder.php InputStream.php \
LICENSE PhpExecutableFinder.php PhpProcess.php ProcessBuilder.php \
Process.php ProcessUtils.php "${FILESDIR}"/autoload.php
dodoc README.md
}

src_test() {
phpunit --bootstrap "${S}"/autoload-test.php || die "test suite failed"
}

0 comments on commit c064142

Please sign in to comment.