Skip to content

Commit

Permalink
app-shells/ksh: bump to 1.0.0_beta2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Stephan Hartmann <[email protected]>
  • Loading branch information
stha09 committed Dec 17, 2021
1 parent 53067f4 commit c0f04fa
Show file tree
Hide file tree
Showing 2 changed files with 72 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-shells/ksh/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST ksh-2020.0.0.tar.gz 2022880 BLAKE2B cb952c4febe88a3ccf8fd48f511a30a73bfc812ebf0b7a5fe799470b29ee13ca61004fd34e367d836940a88214da2aa05b7cb96f173a1b8d57c8e644c8c3a2a6 SHA512 7d6da3af341a62718d691ddc52e10bdf3b7290d74f1cd01610093c587af47b6d6d04b74b210eb31f93a3559855a5bc5155f9b188d2f8bb4444042c26bfaf1792
DIST ksh-v1.0.0-beta.1.tar.gz 2376823 BLAKE2B 0c985bd17bd0a6301205cffa703536c99322b99953e86b8e8266616f70c7d8cab01801f55c5ba2964628cef8c05878f4e721be39987c418b35859952d3a07719 SHA512 968d7c1aef38f0a29f3a32d0aba7bd5138b70d96486443d5b13c4830907aa7344fb7599ca153a55116758413640ba84ec9e6be19a6f0941814f2515a3961b312
DIST ksh-v1.0.0-beta.2.tar.gz 2238224 BLAKE2B b4eb8e116d0dd8fda498fb8d2805613a73291be628ce87ebc1c47c9bc8c49b236b285accaf35b4c9e411df23b99c6a949b672edeea1f1f317fc85a2b4db48779 SHA512 c2cd5a4b442bcff1dd2c1c054ee79c4cb131dce28d811dcd3476164d6cb7e88e6b317a094b16f227564a1266708ef0cfeca2af0929c00a19497cf1b67c647cf2
71 changes: 71 additions & 0 deletions app-shells/ksh/ksh-1.0.0_beta2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit flag-o-matic toolchain-funcs

DESCRIPTION="The Original ATT Korn Shell"
HOMEPAGE="http://www.kornshell.com/"

MY_PV=$(ver_rs 3 - 4 .)
SRC_URI="https://github.com/ksh93/${PN}/archive/v${MY_PV}/ksh-v${MY_PV}.tar.gz"

LICENSE="EPL-1.0"
SLOT="0"

KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~x86"

S="${WORKDIR}/${PN}-${MY_PV}"

src_prepare() {
default

# disable register for debugging
sed -i 1i"#define register" src/lib/libast/include/ast.h || die
}

src_compile() {
local extraflags=(
"-Wno-unknown-pragmas"
"-Wno-missing-braces"
"-Wno-unused-result"
"-Wno-return-type"
"-Wno-int-to-pointer-cast"
"-Wno-parentheses"
"-Wno-unused"
"-Wno-unused-but-set-variable"
"-Wno-cpp"
"-Wno-maybe-uninitialized"
"-Wno-lto-type-mismatch"
"-P"
)
append-cflags $(test-flags-CC ${extraflags[@]})
filter-flags '-fdiagnostics-color=always' # https://github.com/ksh93/ksh/issues/379
export CCFLAGS="${CFLAGS} -fno-strict-aliasing"

tc-export AR CC LD NM

sh bin/package make SHELL="${BROOT}"/bin/sh || die
}

src_test() {
# test tries to catch IO error
addwrite /proc/self/mem

# arith.sh uses A for tests
unset A

sh bin/shtests --compile || die
}

src_install() {
local myhost="$(sh bin/package host)"
cd "arch/${myhost}" || die

into /
dobin bin/ksh
dosym ksh /bin/rksh

newman man/man1/sh.1 ksh.1
}

0 comments on commit c0f04fa

Please sign in to comment.