Skip to content

Commit

Permalink
dev-libs/bemenu: version bump to 0.5.0
Browse files Browse the repository at this point in the history
fixed gcc-10 -fno-common

Closes: https://bugs.gentoo.org/712034
Package-Manager: Portage-2.3.101, Repoman-2.3.22
Signed-off-by: Aisha Tammy <[email protected]>
Signed-off-by: Matthew Thode <[email protected]>
  • Loading branch information
epsilon-0 authored and prometheanfire committed Jul 4, 2020
1 parent 40b3df6 commit c132740
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/bemenu/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST bemenu-0.3.0.tar.gz 120059 BLAKE2B 5db3e7bcc4c67e9f7030fc803a5531994746787ebecfba91c7f09128ea9077b3b06e8f542c1a2980811b8364db3a54fefbdb0af1afaca2f58f098473a4fbd5d6 SHA512 7e68d11954517f41c9669055c28b375c4f13ddfee8aae6a8e67c3282fe9118229d9ab072dc5e264e4204803b1a5ab715c6a5c9565ad4b7436cc172b9e455c05b
DIST bemenu-0.4.1.tar.gz 110388 BLAKE2B 229f75887b8efc336c7790745b1a3402481a1cb86f92311c0c46ec123777ad051351fede5f7d59bce532a3a906bcab8d956f1e93d5aeac44dd7a49e7210e8e9f SHA512 d86b80b2eccbfca73287975f6f5ff9d86c7541900caec858c9aeff9cb7da2ee563e34e378561822671ba16e0f2af3440e0329f5c77f06ff5adcf332451452bf2
DIST bemenu-0.5.0.tar.gz 110749 BLAKE2B dbc6d295262e51c381a9208c6936c0f40e05f3667af6a562716501577861d04c7b28ba836acbce2a6644950a191e56f865efe2f126eccdad67ea68d42f2d30b5 SHA512 5f4397bcb77d3e22340988bfb131feced1782f724ff637e40bf03c36a4377f38127c827f55faccc0dcce2ca482b9353fca7c6bfe700e6cac8e095e0df3b87a31
50 changes: 50 additions & 0 deletions dev-libs/bemenu/bemenu-0.5.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DESCRIPTION="dmenu clone for wayland"
HOMEPAGE="https://github.com/Cloudef/bemenu"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Cloudef/bemenu.git"
else
SRC_URI="https://github.com/Cloudef/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi

LICENSE="GPL-3"
SLOT="0"
IUSE="doc ncurses wayland X"

# Require at least one backend be built
REQUIRED_USE="|| ( ncurses wayland X )"

DEPEND="
ncurses? ( sys-libs/ncurses:0 )
wayland? (
dev-libs/wayland
dev-libs/wayland-protocols
x11-libs/cairo
x11-libs/pango
)
X? (
x11-libs/libxcb
x11-libs/libXext
x11-libs/libX11
x11-libs/cairo[X]
x11-libs/pango[X]
x11-libs/libXinerama
)
"
RDEPEND="${DEPEND}"
BDEPEND="doc? ( app-doc/doxygen )"

src_compile() {
emake clients $(usex ncurses curses "") $(usex X x11 "") $(usex wayland wayland "") PREFIX=/usr libdir=/$(get_libdir)
use doc && emake doxygen PREFIX=/usr libdir=/$(get_libdir)
}

src_install() {
emake install PREFIX="${D}"/usr libdir=/$(get_libdir)
}

0 comments on commit c132740

Please sign in to comment.