Skip to content

Commit

Permalink
app-arch/xz-utils: version bump to 5.2.2
Browse files Browse the repository at this point in the history
  • Loading branch information
vapier committed Sep 29, 2015
1 parent 7eb380e commit c15d2a7
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-arch/xz-utils/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST xz-5.0.7.tar.gz 1317771 SHA256 f4d2165553b9d0d82fd08bc2eacddeb48ebeb862a568
DIST xz-5.0.8.tar.gz 1329117 SHA256 cac71b31ed322a487f1da1f10dfcf47f8855f97ff2c23b92680c7ae7be58babb SHA512 402079001c280e0e957d666da724158b134fd0b17320c4c387413dd2cc88400ea0a7f88819e06de3b35d864f51cb3e3a50495265382cabd6c1080920b4c70847 WHIRLPOOL d8a5748ef85000e81d535a98448fbf4198c59da7183fa8e25d5311b0e122f8b9342d706fceb1a6151a1b40a2a4bc264d4e799c65a89dd5ed80d1fbebf29e5049
DIST xz-5.2.0.tar.gz 1445562 SHA256 231ef369982240bb20ed7cffa52bb12a4a297ce6871f480ab85e8a7ba98bf3d6 SHA512 dc272d4f8d437bfe22ed75355fcd647018a2514e4b011552c913074c0ae7d306ae2a20f3227895ea8123918088d826b2c5595dc15ba6ba2d8062e780d8707a28 WHIRLPOOL a629c42215c5c8ee366d757a4a08ecf9773aea3422f8c51cf8dffcb74edaab4fa3f760a7a3c11e85564b3a2d6154e06f9a76afc460c1120406539233254caa9e
DIST xz-5.2.1.tar.gz 1454491 SHA256 b918b6648076e74f8d7ae19db5ee663df800049e187259faf5eb997a7b974681 SHA512 61d059c51c7cdbab803d006ee47b0be116fd6ba4ba05b9234c43c8b1d8b0021b44735c1335a911a4bccb8543548563cef16dafd7d76dd8ef6c4f763fc023afc2 WHIRLPOOL d4d90f7230c0880c1c392a2767c398510a69e24c18f5c5947472e108902aebb6e94aad0245f16720c60729a7a50199fb4250ae3f6801a0cc25086e7858c55d19
DIST xz-5.2.2.tar.gz 1464228 SHA256 73df4d5d34f0468bd57d09f2d8af363e95ed6cc3a4a86129d2f2c366259902a2 SHA512 8d6249f93c5c43e1c8eeb21f93b22330fd54575e20bbb4af3d06721192d9f0ca3351878964c9640238ac410b7dd9f16329793c7be7355c7ca0db92c6db6ab813 WHIRLPOOL 7707f10908a57b5780cdb9dda6bac2674f4c5e3350660ea61539b4df5ecc7dbeeb03f05a9b32873d28a14343f9c6491d68095769d3b283018e8139a95bf5f369
74 changes: 74 additions & 0 deletions app-arch/xz-utils/xz-utils-5.2.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

# Remember: we cannot leverage autotools in this ebuild in order
# to avoid circular deps with autotools

EAPI="4"

inherit eutils multilib toolchain-funcs libtool multilib-minimal

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="http://git.tukaani.org/xz.git"
inherit git-2 autotools
SRC_URI=""
EXTRA_DEPEND="sys-devel/gettext dev-vcs/cvs >=sys-devel/libtool-2" #272880 286068
else
MY_P="${PN/-utils}-${PV/_}"
SRC_URI="http://tukaani.org/xz/${MY_P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
S=${WORKDIR}/${MY_P}
EXTRA_DEPEND=
fi

DESCRIPTION="utils for managing LZMA compressed files"
HOMEPAGE="http://tukaani.org/xz/"

# See top-level COPYING file as it outlines the various pieces and their licenses.
LICENSE="public-domain LGPL-2.1+ GPL-2+"
SLOT="0"
IUSE="elibc_FreeBSD nls static-libs +threads"

RDEPEND="!<app-arch/lzma-4.63
!app-arch/lzma-utils
!<app-arch/p7zip-4.57"
DEPEND="${RDEPEND}
${EXTRA_DEPEND}"

src_prepare() {
if [[ ${PV} == "9999" ]] ; then
eautopoint
eautoreconf
else
elibtoolize # to allow building shared libs on Solaris/x64
fi
}

multilib_src_configure() {
use elibc_FreeBSD && export ac_cv_header_sha256_h=no #545714
ECONF_SOURCE="${S}" econf \
$(use_enable nls) \
$(use_enable threads) \
$(use_enable static-libs static) \
$(multilib_is_native_abi || echo --disable-{xz,xzdec,lzmadec,lzmainfo,lzma-links,scripts})
}

multilib_src_install() {
default
multilib_is_native_abi && gen_usr_ldscript -a lzma
}

multilib_src_install_all() {
prune_libtool_files --all
rm "${ED}"/usr/share/doc/xz/COPYING* || die
mv "${ED}"/usr/share/doc/{xz,${PF}} || die
}

pkg_preinst() {
preserve_old_lib /usr/$(get_libdir)/liblzma$(get_libname 0)
}

pkg_postinst() {
preserve_old_lib_notify /usr/$(get_libdir)/liblzma$(get_libname 0)
}

0 comments on commit c15d2a7

Please sign in to comment.