Skip to content

Commit

Permalink
media-plugins/calf: Sync with 0.90.1 changes
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Mar 10, 2019
1 parent a526be6 commit c2cc32c
Showing 1 changed file with 39 additions and 27 deletions.
66 changes: 39 additions & 27 deletions media-plugins/calf/calf-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,8 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit autotools gnome2-utils
EAPI=7

inherit autotools xdg

DESCRIPTION="A set of open source instruments and effects for digital audio workstations"
HOMEPAGE="http://calf-studio-gear.org/"
Expand All @@ -17,48 +18,59 @@ fi

LICENSE="LGPL-2.1"
SLOT="0"
IUSE="cpu_flags_x86_sse gtk jack lash lv2 static-libs experimental"
IUSE="cpu_flags_x86_sse experimental gtk jack lash lv2 static-libs"

REQUIRED_USE="jack? ( gtk )"

RDEPEND="dev-libs/atk
BDEPEND="
virtual/pkgconfig
"
DEPEND="
dev-libs/atk
dev-libs/expat
dev-libs/glib:2
media-sound/fluidsynth
jack? ( virtual/jack )
media-sound/fluidsynth:=
gtk? (
x11-libs/cairo
x11-libs/gtk+:2
x11-libs/gdk-pixbuf
x11-libs/gtk+:2
x11-libs/pango
)
jack? ( virtual/jack )
lash? ( media-sound/lash )
lv2? ( media-libs/lv2 )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
lv2? ( media-libs/lv2 )
"
RDEPEND="${DEPEND}"

PATCHES=(
"${FILESDIR}/${PN}-0.90.1-no-automagic.patch"
"${FILESDIR}/${PN}-0.90.1-htmldir.patch"
"${FILESDIR}/${PN}-0.90.1-desktop.patch"
)

src_prepare() {
default
eautoreconf
}

src_configure() {
# automagic...
#$(use_with gtk gui)
#$(use_with jack)
econf \
--prefix="${EPREFIX}"/usr \
--without-obsolete-check \
$(use_with lash) \
$(use_with lv2 lv2) \
$(usex lv2 "--with-lv2-dir=${EPREFIX}/usr/$(get_libdir)/lv2" "") \
$(use_enable static-libs static) \
$(use_enable cpu_flags_x86_sse sse) \
local myeconfargs=(
--prefix="${EPREFIX}"/usr
--without-obsolete-check
$(use_enable experimental)
$(use_enable gtk gui)
$(use_enable jack)
$(use_with lash)
$(use_with lv2 lv2)
$(usex lv2 "--with-lv2-dir=${EPREFIX}/usr/$(get_libdir)/lv2" "")
$(use_enable static-libs static)
$(use_enable cpu_flags_x86_sse sse)
)
econf "${myeconfargs[@]}"
}

pkg_postinst() {
gnome2_icon_cache_update
}

pkg_postrm() {
gnome2_icon_cache_update
src_install() {
default
mv "${ED}"/usr/share/bash-completion/completions/calf \
"${ED}"/usr/share/bash-completion/completions/calfjackhost
}

0 comments on commit c2cc32c

Please sign in to comment.