Skip to content

Commit

Permalink
mail-filter/rspamd: version bump to 1.4.0
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
djc committed Nov 21, 2016
1 parent 4a61758 commit c2edde8
Show file tree
Hide file tree
Showing 2 changed files with 72 additions and 0 deletions.
1 change: 1 addition & 0 deletions mail-filter/rspamd/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST rspamd-1.2.8.tar.xz 1423888 SHA256 485438d8c38ada1a6e95c9ea1298d2c899d4ec618f1dd5f539663522c506eb2b SHA512 21ca76636ce1482233cb3631343e827678d07e0db21e8c0b3961a8124aba4260f2c4f1a4dc110c5689b02707951f28c2ee0e72d1e8cd5c49d9b73fbf688a6056 WHIRLPOOL cdbefbfa3f76b58229c945efc875321950d4981364eb942b83c8a3f12f3e482c83f969b26ebbbddfe6a49d6e72c7c5dee505ba54ac570fb22bbd40a21c17aa53
DIST rspamd-1.3.5.tar.xz 1483044 SHA256 d4413ccfc238c3023e2b8a9441b101a6437f521f333fc9db2dd924d473fee696 SHA512 6d7223c6be6e49296a5228d3d05a5f8dfd4a4002df9d247740bce75f2f652a01d86c30456b8475d08d529d2787aa30191713961ffc82c380c00612cae371b61c WHIRLPOOL 4017484d4653a23b5a987ab0bdd40a709cd5d116dea5c02a767c5cad94bd5399d6319aa8f75e726cec5d0bd7ae9e0722786cacc33963e2f9b8fbdd0fb0986729
DIST rspamd-1.4.0.tar.xz 1769860 SHA256 30c9acf93bdcc6c009524c8b2770931475929c6c9e948faa90d7412306055a1c SHA512 39bfccee070b829f3ea5019ebde0020a850abf7fe92f7e5bb5b9212088d4c98544e6f55228984d3422c09c31f356b209237da6a6eb9c18e3feb7940429de663a WHIRLPOOL 449a15148067e4af38ca7d4218dca69064679d1a064c53d0edf99e63418d6a898fd80cdfce8707f706f19da659d44efadedab3a7ea8c3dcd54c65794f695e3d0
71 changes: 71 additions & 0 deletions mail-filter/rspamd/rspamd-1.4.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit cmake-utils pax-utils user systemd

DESCRIPTION="Rapid spam filtering system"
SRC_URI="https://rspamd.com/downloads/${P}.tar.xz"
HOMEPAGE="https://github.com/vstakhov/rspamd"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="fann +jit libressl"

RDEPEND="!libressl? ( dev-libs/openssl:0[-bindist] )
libressl? ( dev-libs/libressl:0 )
fann? ( sci-mathematics/fann )
jit? (
dev-libs/libpcre[jit]
dev-lang/luajit:2
)
!jit? (
dev-libs/libpcre[-jit]
>=dev-lang/lua-5.1:0
)
dev-libs/libevent
dev-db/sqlite:3
dev-libs/glib:2
dev-libs/gmime
dev-util/ragel
sys-apps/file
virtual/libiconv"
DEPEND="dev-util/ragel
${RDEPEND}"

pkg_setup() {
enewgroup rspamd
enewuser rspamd -1 -1 /var/lib/rspamd rspamd
}

src_configure() {
local mycmakeargs=(
-DCONFDIR=/etc/rspamd
-DRUNDIR=/var/run/rspamd
-DDBDIR=/var/lib/rspamd
-DLOGDIR=/var/log/rspamd
-DENABLE_LUAJIT=$(usex jit ON OFF)
-DENABLE_FANN=$(usex fann ON OFF)
)
cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install
pax-mark m "${ED}"/usr/bin/rspamadm-*
pax-mark m "${ED}"/usr/bin/rspamd-*
newinitd "${FILESDIR}/rspamd.init-r2" rspamd

dodir /var/lib/rspamd
dodir /var/log/rspamd

fowners rspamd:rspamd /var/lib/rspamd /var/log/rspamd

insinto /etc/logrotate.d
newins "${FILESDIR}/rspamd.logrotate" rspamd

systemd_newunit rspamd.service rspamd.service
}

0 comments on commit c2edde8

Please sign in to comment.