Skip to content

Commit

Permalink
games-arcade/cavezofphear: port to EAPI 7, games.eclass--, respect PK…
Browse files Browse the repository at this point in the history
…G_CONFIG

Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Apr 6, 2021
1 parent c3f20e5 commit c3a75de
Show file tree
Hide file tree
Showing 2 changed files with 27 additions and 21 deletions.
Original file line number Diff line number Diff line change
@@ -1,36 +1,44 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
inherit eutils games
EAPI=7

inherit toolchain-funcs

DESCRIPTION="A boulder dash / digger-like game for console using ncurses"
HOMEPAGE="http://www.x86.no/cavezofphear/"
SRC_URI="mirror://gentoo/phear-${PV}.tar.bz2"
S="${WORKDIR}"/${P/cavezof/}

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE=""

RDEPEND=">=sys-libs/ncurses-5:0"
DEPEND="${RDEPEND}
virtual/pkgconfig"
RDEPEND=">=sys-libs/ncurses-5:0="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"

S=${WORKDIR}/${P/cavezof/}
PATCHES=(
"${FILESDIR}"/${P}-gentoo.patch
"${FILESDIR}"/${P}-no-common.patch
)

src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.patch
epatch "${FILESDIR}"/${P}-no-common.patch
default

sed -i \
-e "s:get_data_dir(.):\"${GAMES_DATADIR}/${PN}/\":" \
-e "s:get_data_dir(.):\"/usr/share/${PN}/\":" \
src/{chk.c,main.c,gplot.c} \
|| die
}

src_configure() {
tc-export CC PKG_CONFIG
}

src_install() {
dogamesbin src/phear
insinto "${GAMES_DATADIR}"/${PN}
dobin src/phear
insinto /usr/share/${PN}
doins -r data/*
dodoc ChangeLog README* TODO
prepgamesdirs
}
12 changes: 5 additions & 7 deletions games-arcade/cavezofphear/files/cavezofphear-0.5.1-gentoo.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,5 @@
diff -ru phear-0.5.1.orig/Makefile phear-0.5.1/Makefile
--- phear-0.5.1.orig/Makefile 2007-02-27 06:21:55.000000000 -0500
+++ phear-0.5.1/Makefile 2013-01-18 02:09:56.403224104 -0500
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,7 @@
DESTDIR_DATA = /usr/local/share

Expand All @@ -10,9 +9,8 @@ diff -ru phear-0.5.1.orig/Makefile phear-0.5.1/Makefile
clean:
rm -f phear editor
install:
diff -ru phear-0.5.1.orig/src/Makefile phear-0.5.1/src/Makefile
--- phear-0.5.1.orig/src/Makefile 2011-12-12 07:26:03.000000000 -0500
+++ phear-0.5.1/src/Makefile 2013-01-18 02:10:48.218423433 -0500
--- a/src/Makefile
+++ b/src/Makefile
@@ -2,10 +2,8 @@

DESTDIR = ..
Expand All @@ -21,7 +19,7 @@ diff -ru phear-0.5.1.orig/src/Makefile phear-0.5.1/src/Makefile
INSTALL = install
-CFLAGS ?= -s -Wall -O2
-LDFLAGS += -lncurses
+LDLIBS = `pkg-config ncurses --libs`
+LDLIBS = `${PKG_CONFIG} ncurses --libs`

all: phear install clean

Expand Down

0 comments on commit c3a75de

Please sign in to comment.