Skip to content

Commit

Permalink
dev-db/mongodb: migrate to python-any-r1, fix #692080
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.71, Repoman-2.3.17
Signed-off-by: Alexys Jacob <[email protected]>
  • Loading branch information
ultrabug committed Aug 21, 2019
1 parent 8a4e82f commit c3e899a
Show file tree
Hide file tree
Showing 4 changed files with 33 additions and 25 deletions.
14 changes: 8 additions & 6 deletions dev-db/mongodb/mongodb-3.6.13.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -10,7 +10,7 @@ CHECKREQS_DISK_BUILD="2400M"
CHECKREQS_DISK_USR="512M"
CHECKREQS_MEMORY="1024M"

inherit check-reqs flag-o-matic multiprocessing pax-utils python-single-r1 scons-utils systemd toolchain-funcs user
inherit check-reqs flag-o-matic multiprocessing pax-utils python-any-r1 scons-utils systemd toolchain-funcs user

MY_P=${PN}-src-r${PV/_rc/-rc}

Expand Down Expand Up @@ -38,14 +38,16 @@ RDEPEND=">=app-arch/snappy-1.1.3
)"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
dev-python/cheetah[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
virtual/python-typing[${PYTHON_USEDEP}]
$(python_gen_any_dep '
dev-python/cheetah[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
virtual/python-typing[${PYTHON_USEDEP}]
')
sys-libs/ncurses:0=
sys-libs/readline:0=
debug? ( dev-util/valgrind )
test? (
dev-python/pymongo[${PYTHON_USEDEP}]
$(python_gen_any_dep 'dev-python/pymongo[${PYTHON_USEDEP}]')
)"
PDEPEND="tools? ( >=app-admin/mongo-tools-${PV} )"

Expand Down Expand Up @@ -73,7 +75,7 @@ pkg_setup() {
enewgroup mongodb
enewuser mongodb -1 -1 /var/lib/${PN} mongodb

python-single-r1_pkg_setup
python-any-r1_pkg_setup
}

src_prepare() {
Expand Down
16 changes: 9 additions & 7 deletions dev-db/mongodb/mongodb-3.6.8.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Authors
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand All @@ -10,7 +10,7 @@ CHECKREQS_DISK_BUILD="2400M"
CHECKREQS_DISK_USR="512M"
CHECKREQS_MEMORY="1024M"

inherit check-reqs eapi7-ver flag-o-matic multiprocessing pax-utils python-single-r1 scons-utils systemd toolchain-funcs user
inherit check-reqs eapi7-ver flag-o-matic multiprocessing pax-utils python-any-r1 scons-utils systemd toolchain-funcs user

MY_P=${PN}-src-r${PV/_rc/-rc}

Expand Down Expand Up @@ -38,14 +38,16 @@ RDEPEND=">=app-arch/snappy-1.1.3
)"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
dev-python/cheetah[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
virtual/python-typing[${PYTHON_USEDEP}]
$(python_gen_any_dep '
dev-python/cheetah[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
virtual/python-typing[${PYTHON_USEDEP}]
')
sys-libs/ncurses:0=
sys-libs/readline:0=
debug? ( dev-util/valgrind )
test? (
dev-python/pymongo[${PYTHON_USEDEP}]
$(python_gen_any_dep 'dev-python/pymongo[${PYTHON_USEDEP}]')
)"
PDEPEND="tools? ( >=app-admin/mongo-tools-${PV} )"

Expand Down Expand Up @@ -73,7 +75,7 @@ pkg_setup() {
enewgroup mongodb
enewuser mongodb -1 -1 /var/lib/${PN} mongodb

python-single-r1_pkg_setup
python-any-r1_pkg_setup
}

src_prepare() {
Expand Down
14 changes: 8 additions & 6 deletions dev-db/mongodb/mongodb-4.0.10.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -10,7 +10,7 @@ CHECKREQS_DISK_BUILD="2400M"
CHECKREQS_DISK_USR="512M"
CHECKREQS_MEMORY="1024M"

inherit check-reqs flag-o-matic multiprocessing pax-utils python-single-r1 scons-utils systemd toolchain-funcs user
inherit check-reqs flag-o-matic multiprocessing pax-utils python-any-r1 scons-utils systemd toolchain-funcs user

MY_P=${PN}-src-r${PV/_rc/-rc}

Expand Down Expand Up @@ -38,14 +38,16 @@ RDEPEND=">=app-arch/snappy-1.1.3
)"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
dev-python/cheetah[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
virtual/python-typing[${PYTHON_USEDEP}]
$(python_gen_any_dep '
dev-python/cheetah[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
virtual/python-typing[${PYTHON_USEDEP}]
')
sys-libs/ncurses:0=
sys-libs/readline:0=
debug? ( dev-util/valgrind )
test? (
dev-python/pymongo[${PYTHON_USEDEP}]
$(python_gen_any_dep 'dev-python/pymongo[${PYTHON_USEDEP}]')
)"
PDEPEND="tools? ( >=app-admin/mongo-tools-${PV} )"

Expand Down Expand Up @@ -73,7 +75,7 @@ pkg_setup() {
enewgroup mongodb
enewuser mongodb -1 -1 /var/lib/${PN} mongodb

python-single-r1_pkg_setup
python-any-r1_pkg_setup
}

src_prepare() {
Expand Down
14 changes: 8 additions & 6 deletions dev-db/mongodb/mongodb-4.0.12.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -10,7 +10,7 @@ CHECKREQS_DISK_BUILD="2400M"
CHECKREQS_DISK_USR="512M"
CHECKREQS_MEMORY="1024M"

inherit check-reqs flag-o-matic multiprocessing pax-utils python-single-r1 scons-utils systemd toolchain-funcs user
inherit check-reqs flag-o-matic multiprocessing pax-utils python-any-r1 scons-utils systemd toolchain-funcs user

MY_P=${PN}-src-r${PV/_rc/-rc}

Expand Down Expand Up @@ -38,14 +38,16 @@ RDEPEND=">=app-arch/snappy-1.1.3
)"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
dev-python/cheetah[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
virtual/python-typing[${PYTHON_USEDEP}]
$(python_gen_any_dep '
dev-python/cheetah[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
virtual/python-typing[${PYTHON_USEDEP}]
')
sys-libs/ncurses:0=
sys-libs/readline:0=
debug? ( dev-util/valgrind )
test? (
dev-python/pymongo[${PYTHON_USEDEP}]
$(python_gen_any_dep 'dev-python/pymongo[${PYTHON_USEDEP}]')
)"
PDEPEND="tools? ( >=app-admin/mongo-tools-${PV} )"

Expand Down Expand Up @@ -73,7 +75,7 @@ pkg_setup() {
enewgroup mongodb
enewuser mongodb -1 -1 /var/lib/${PN} mongodb

python-single-r1_pkg_setup
python-any-r1_pkg_setup
}

src_prepare() {
Expand Down

0 comments on commit c3e899a

Please sign in to comment.