forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-libs/poco: version bump (bug #550976)
Package-Manager: portage-2.3.2
- Loading branch information
Showing
4 changed files
with
145 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST poco-1.4.6-all-doc.zip 2072762 SHA256 a1cfb143a671bcef7a2bafcbba095edf8ed21e51a30ae7eb19955e73bb23067d SHA512 458e1a3c6a6017b5ae5efcbd0d7b2bbf50aedd6ddc7ae7befddac07ed133b7243208aadd6ecdb17b3fa273e04eb0da4d73b1d3e5591aee98b754e430b2248e52 WHIRLPOOL af52385b3557853ea4fcd1a31092a5e1fa009e082bc4fcec8e51e42207147400eca7c26c9a65c84de24d322677fcfaa364207dc83f88299ddca2fd06cf9a26af | ||
DIST poco-1.4.6p4-all.tar.bz2 3158594 SHA256 e48ce805702048e099eee4965f3db573728e32bd9a15ff643f5ea856926f2dd6 SHA512 ae4e1190a0ba719f807d0abaf1c47ff445a8f5867157f209260672546f3755ff021c7073bc8d5e656be383d5667dc15ad7eae8208728053fb61439c4c80a7fca WHIRLPOOL fd4efd270103dc7ce248481d5e9048a88caf1ece985384fdd2385d381a3d0bc5cad124b6230dbc6ba9679c3ae4ce69dbe77ae5d684798eb2c4a916d373f87e4a | ||
DIST poco-1.7.6.tar.gz 8044937 SHA256 b9590f10493deb6379452cc926bdf13bdf1fb941ad63c983ffecc140e97ba5c9 SHA512 a02b7ff66acf080942517b3b8644d6e5c7136c5edc6e58fd13083a74b97b5619253fc9db7863284a565226f95410ad4da1fa9738d14885f560aeb03c1f7c18aa WHIRLPOOL d51074280980a7794204a44fd1510bca5dc2ff3fcc83deec3ea324caff485b65489e6ec51d08570b241cabeb0818f17abaea722c2297d9278fa2b8613c73db0d |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,13 @@ | ||
diff --git a/cmake/FindODBC.cmake b/cmake/FindODBC.cmake | ||
index 9e229ed..5d79c7e 100644 | ||
--- a/cmake/FindODBC.cmake | ||
+++ b/cmake/FindODBC.cmake | ||
@@ -16,7 +16,7 @@ | ||
find_path(ODBC_INCLUDE_DIRECTORIES | ||
NAMES sql.h | ||
HINTS | ||
- /usr/include | ||
+ /usr/include/iodbc | ||
/usr/include/odbc | ||
/usr/local/include | ||
/usr/local/include/odbc |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,116 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
inherit cmake-utils | ||
|
||
DESCRIPTION="C++ class libraries for building network- and internet-based applications" | ||
HOMEPAGE="http://pocoproject.org/" | ||
SRC_URI="https://github.com/pocoproject/${PN}/archive/${P}-release.tar.gz -> ${P}.tar.gz" | ||
LICENSE="Boost-1.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~x86" | ||
IUSE="7z apache cppparser +crypto +data examples +file2pagecompiler +json +pagecompiler iodbc libressl +mongodb mysql +net odbc pdf pocodoc sqlite +ssl test +util +xml +zip" | ||
REQUIRED_USE="7z? ( xml ) | ||
apache? ( net util ) | ||
file2pagecompiler? ( pagecompiler ) | ||
iodbc? ( odbc ) | ||
mongodb? ( data ) | ||
mysql? ( data ) | ||
odbc? ( data ) | ||
pagecompiler? ( json net util xml ) | ||
pocodoc? ( cppparser util xml ) | ||
sqlite? ( data ) | ||
test? ( data? ( sqlite ) json util xml )" | ||
|
||
RDEPEND=">=dev-libs/libpcre-8.13 | ||
xml? ( dev-libs/expat ) | ||
apache? ( dev-libs/apr | ||
dev-libs/apr-util | ||
www-servers/apache ) | ||
mysql? ( virtual/mysql ) | ||
odbc? ( iodbc? ( dev-db/libiodbc ) | ||
!iodbc? ( dev-db/unixODBC ) ) | ||
ssl? ( | ||
!libressl? ( <dev-libs/openssl-1.1.0:0 ) | ||
libressl? ( dev-libs/libressl ) | ||
) | ||
sqlite? ( dev-db/sqlite:3 ) | ||
zip? ( sys-libs/zlib )" | ||
DEPEND="${DEPEND} | ||
virtual/pkgconfig" | ||
|
||
S="${WORKDIR}/${PN}-${P}-release" | ||
|
||
PATCHES=( "${FILESDIR}/${PN}-1.7.2-iodbc-incdir.patch" ) | ||
|
||
src_prepare() { | ||
if use test ; then | ||
# ignore missing tests on experimental library | ||
# and tests requiring running DB-servers, internet connections, etc. | ||
sed -i \ | ||
-e '/testsuite/d' \ | ||
{Data/{MySQL,ODBC},MongoDB,Net,NetSSL_OpenSSL,PDF}/CMakeLists.txt || die | ||
# Poco expands ~ using passwd, which does not match $HOME in the build environment | ||
sed -i \ | ||
-e '/CppUnit_addTest.*testExpand/d' \ | ||
Foundation/testsuite/src/PathTest.cpp || die | ||
# ignore failing Crypto test since upstream does not seem to care, | ||
# see https://github.com/pocoproject/poco/issues/1209 | ||
sed -i \ | ||
-e '/RSATest, testRSACipherLarge/d' \ | ||
Crypto/testsuite/src/RSATest.cpp || die | ||
fi | ||
|
||
cmake-utils_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DPOCO_UNBUNDLED=ON | ||
-DENABLE_APACHECONNECTOR="$(usex apache)" | ||
-DENABLE_CPPPARSER="$(usex cppparser)" | ||
-DENABLE_CRYPTO="$(usex ssl)" | ||
-DENABLE_DATA="$(usex data)" | ||
-DENABLE_DATA_MYSQL="$(usex mysql)" | ||
-DENABLE_DATA_ODBC="$(usex odbc)" | ||
-DENABLE_DATA_SQLITE="$(usex sqlite)" | ||
-DENABLE_JSON="$(usex util)" | ||
-DENABLE_MONGODB="$(usex mongodb)" | ||
-DENABLE_NET="$(usex net)" | ||
-DENABLE_NETSSL="$(usex ssl)" | ||
-DENABLE_NETSSL_WIN=OFF | ||
-DENABLE_PAGECOMPILER="$(usex pagecompiler)" | ||
-DENABLE_PAGECOMPILER_FILE2PAGE="$(usex file2pagecompiler)" | ||
-DENABLE_PDF="$(usex pdf)" | ||
-DENABLE_POCODOC="$(usex pocodoc)" | ||
-DENABLE_SEVENZIP="$(usex 7z)" | ||
-DENABLE_TESTS="$(usex test)" | ||
-DENABLE_UTIL="$(usex util)" | ||
-DENABLE_XML="$(usex xml)" | ||
-DENABLE_ZIP="$(usex zip)" | ||
) | ||
|
||
if ! use iodbc ; then | ||
sed -i -e 's|iodbc||' cmake/FindODBC.cmake || die | ||
fi | ||
|
||
cmake-utils_src_configure | ||
} | ||
|
||
src_install() { | ||
cmake-utils_src_install | ||
|
||
if use examples ; then | ||
for sd in */samples ; do | ||
insinto /usr/share/doc/${PF}/examples/${sd%/samples} | ||
doins -r ${sd} | ||
done | ||
find "${D}/usr/share/doc/${PF}/examples" \ | ||
-iname "*.sln" -or -iname "*.vcproj" -or \ | ||
-iname "*.vmsbuild" -or -iname "*.properties" \ | ||
| xargs rm | ||
fi | ||
} |