Skip to content

Commit

Permalink
media-fonts/terminus-font: Bump to version 4.47
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.53, Repoman-2.3.12
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Jan 2, 2019
1 parent c7b5eb2 commit c567b6c
Show file tree
Hide file tree
Showing 2 changed files with 92 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-fonts/terminus-font/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST terminus-font-4.46.tar.gz 590210 BLAKE2B 427b4878afd47cc6c1a0ba6b6116568630a618e313c24744b3465b3e301e142ccbb9bd5e336bed7d98f3d1e01a0a61c6fbdd17912f4d9332ed5430ef47bca4fe SHA512 ae221920ecff54b9575a25d30a429feee6e19ef1e9669896c34f86f80d5495c3654f5423ff1df76e86bc999d1f37c306048b44d8ca55144f0f299926d3d33b58
DIST terminus-font-4.47.tar.gz 620344 BLAKE2B 10eaac6ff4880652ee7373374735629cada73e1cb63344b75b579532fad154b10322a7cb3691c2270c2b4d1aee0914c64338d3650625883752c7e33e5205212a SHA512 09455d107a09c422f4fedfcc70ae1483063c844fb01b0adfa3d2a0e28c9502e9ca922542b5ad735cbebb491d148c453d0213d61ebebf64c79f16cb582964fa47
91 changes: 91 additions & 0 deletions media-fonts/terminus-font/terminus-font-4.47.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,91 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python3_{4,5,6,7} )
inherit font python-any-r1

DESCRIPTION="A clean fixed font for the console and X11"
HOMEPAGE="http://terminus-font.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}/${P}.tar.gz"

LICENSE="OFL-1.1 GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="a-like-o +center-tilde distinct-l +pcf +pcf-unicode-only +psf quote
ru-dv +ru-g ru-i ru-k"

DEPEND="app-arch/gzip
${PYTHON_DEPEND}
virtual/awk
pcf? ( x11-apps/bdftopcf )"
RDEPEND=""

FONTDIR=/usr/share/fonts/terminus
FONT_CONF=( 75-yes-terminus.conf )
DOCS=( README README-BG AUTHORS CHANGES )

REQUIRED_USE="X? ( pcf )"

pkg_setup() {
python_setup
}

src_prepare() {
default

# Upstream patches. Some of them are suggested to be applied by default
# dv - de NOT like latin g, but like caps greek delta
# ve NOT like greek beta, but like caps latin B
# ge - ge NOT like "mirrored" latin s, but like caps greek gamma
# ka - small ka NOT like minimised caps latin K, but like small latin k
use a-like-o && eapply "${S}"/alt/ao2.diff
use center-tilde && eapply "${S}"/alt/td1.diff
use distinct-l && eapply "${S}"/alt/ll2.diff
use ru-i && eapply "${S}"/alt/ij1.diff
use ru-k && eapply "${S}"/alt/ka2.diff
use ru-dv && eapply "${S}"/alt/dv1.diff
use ru-g && eapply "${S}"/alt/ge2.diff
use quote && eapply "${S}"/alt/gq2.diff
}

src_configure() {
local configure_args=(
--prefix="${EPREFIX}"/usr
--psfdir="${EPREFIX}"/usr/share/consolefonts
--x11dir="${EPREFIX}"/${FONTDIR}
)
# selfwritten configure script
./configure "${configure_args[@]}" || die
}

src_compile() {
local args=(
$(usex psf 'psf psf-vgaw' '')
$(usex pcf 'pcf pcf-8bit' '')
)
[[ ${#args[@]} -gt 0 ]] && emake "${args[@]}"
}

src_install() {
local args=(
$(usex psf 'install-psf install-psf-vgaw install-psf-ref' '')
$(usex pcf 'install-pcf' '')
)
# Set the CHECKDIR to a dummy location so we always get the same set of
# files installed regardless of what is in / or ROOT or wherever.
[[ ${#args[@]} -gt 0 ]] && emake DESTDIR="${D}" CHECKDIR="${D}" "${args[@]}"

# Remove trans files that the kbd package takes care of installing.
rm -f "${ED}"/usr/share/consoletrans/*.trans

if use pcf-unicode-only; then
# Only the ter-x* fonts are unicode (ISO-10646-1) based
rm -f "${ED}"/usr/share/fonts/terminus/ter-[0-9a-wy-z]* || die
fi

font_src_install

einstalldocs
}

0 comments on commit c567b6c

Please sign in to comment.