Skip to content

Commit

Permalink
dev-qt: Add Qt 5.15.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.6, Repoman-3.0.1
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Sep 10, 2020
1 parent ad53e15 commit c60b2b1
Show file tree
Hide file tree
Showing 109 changed files with 2,576 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-qt/assistant/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST qttools-everywhere-src-5.14.2.tar.xz 8815020 BLAKE2B 2535541b53cec5cc2dce1ac06ad70b145fce38642d8142f43a800a630aa2f69ad255e8f0a38c44022d14cc5b4373603026cc7c149c2435621f91a66ea0bf223d SHA512 e5b56d38acaa59511f24c817999f901510397d6e8baccc06a8fb8375f09b71dcffda4c57def4eb88d6c2782926d612b382957175a087a0c2224245051c54fe7e
DIST qttools-everywhere-src-5.15.0.tar.xz 8850752 BLAKE2B fed030b2e0bdb3bf397b28e33c1afc84c0b22bf3ede5bdf9a0822f44f8cbf6f7564d0d2c04215f79aec722deeac373d2d46cdd3d7e3d9135f9211486feaf12b0 SHA512 ebcebbc828e6a34766f2f5eeb4775d29af7b60b6124549df5256902ed2bd683721084b45a869ba76d29b1b170fe3834291af0833ab17ee8d05407c509f03d3eb
DIST qttools-everywhere-src-5.15.1.tar.xz 8901096 BLAKE2B f8927993dfc6888a1143b6a8ce09f075636600f77891edb64dd5c39bee75e2c752d3da4443c7956297c65c5b7f1103b1c6bb53b607cd054473a96adc1350e2b9 SHA512 8c7851431de8686a01fc5f85de5dcfa61b6878bd65b53ed78a8a23e57de70f2dcc1a72b4eed9a7219cfd443215a32a59a25fb929d343afcfd498517d6bcfb951
55 changes: 55 additions & 0 deletions dev-qt/assistant/assistant-5.15.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
QT5_MODULE="qttools"
inherit desktop qt5-build xdg-utils

DESCRIPTION="Tool for viewing on-line documentation in Qt help file format"

if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
fi

IUSE="webkit"

DEPEND="
~dev-qt/qtcore-${PV}:5=
~dev-qt/qtgui-${PV}
~dev-qt/qthelp-${PV}
~dev-qt/qtnetwork-${PV}
~dev-qt/qtprintsupport-${PV}
~dev-qt/qtsql-${PV}[sqlite]
~dev-qt/qtwidgets-${PV}
webkit? ( >=dev-qt/qtwebkit-5.9.1:5 )
"
RDEPEND="${DEPEND}"

QT5_TARGET_SUBDIRS=(
src/assistant/assistant
)

src_prepare() {
qt_use_disable_mod webkit webkitwidgets \
src/assistant/assistant/assistant.pro

qt5-build_src_prepare
}

src_install() {
qt5-build_src_install

doicon -s 32 src/assistant/assistant/images/assistant.png
newicon -s 128 src/assistant/assistant/images/assistant-128.png assistant.png
make_desktop_entry "${QT5_BINDIR}"/assistant 'Qt 5 Assistant' assistant 'Qt;Development;Documentation'
}

pkg_postinst() {
qt5-build_pkg_postinst
xdg_icon_cache_update
}

pkg_postrm() {
qt5-build_pkg_postrm
xdg_icon_cache_update
}
1 change: 1 addition & 0 deletions dev-qt/designer/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST qttools-everywhere-src-5.14.2.tar.xz 8815020 BLAKE2B 2535541b53cec5cc2dce1ac06ad70b145fce38642d8142f43a800a630aa2f69ad255e8f0a38c44022d14cc5b4373603026cc7c149c2435621f91a66ea0bf223d SHA512 e5b56d38acaa59511f24c817999f901510397d6e8baccc06a8fb8375f09b71dcffda4c57def4eb88d6c2782926d612b382957175a087a0c2224245051c54fe7e
DIST qttools-everywhere-src-5.15.0.tar.xz 8850752 BLAKE2B fed030b2e0bdb3bf397b28e33c1afc84c0b22bf3ede5bdf9a0822f44f8cbf6f7564d0d2c04215f79aec722deeac373d2d46cdd3d7e3d9135f9211486feaf12b0 SHA512 ebcebbc828e6a34766f2f5eeb4775d29af7b60b6124549df5256902ed2bd683721084b45a869ba76d29b1b170fe3834291af0833ab17ee8d05407c509f03d3eb
DIST qttools-everywhere-src-5.15.1.tar.xz 8901096 BLAKE2B f8927993dfc6888a1143b6a8ce09f075636600f77891edb64dd5c39bee75e2c752d3da4443c7956297c65c5b7f1103b1c6bb53b607cd054473a96adc1350e2b9 SHA512 8c7851431de8686a01fc5f85de5dcfa61b6878bd65b53ed78a8a23e57de70f2dcc1a72b4eed9a7219cfd443215a32a59a25fb929d343afcfd498517d6bcfb951
53 changes: 53 additions & 0 deletions dev-qt/designer/designer-5.15.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
QT5_MODULE="qttools"
inherit desktop qt5-build xdg-utils

DESCRIPTION="WYSIWYG tool for designing and building graphical user interfaces with QtWidgets"

if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
fi

IUSE="declarative webkit"

DEPEND="
~dev-qt/qtcore-${PV}:5=
~dev-qt/qtgui-${PV}:5=
~dev-qt/qtnetwork-${PV}
~dev-qt/qtprintsupport-${PV}
~dev-qt/qtwidgets-${PV}
~dev-qt/qtxml-${PV}
declarative? ( ~dev-qt/qtdeclarative-${PV}[widgets] )
webkit? ( >=dev-qt/qtwebkit-5.9.1:5 )
"
RDEPEND="${DEPEND}"

src_prepare() {
qt_use_disable_mod declarative quickwidgets \
src/designer/src/plugins/plugins.pro

qt_use_disable_mod webkit webkitwidgets \
src/designer/src/plugins/plugins.pro

qt5-build_src_prepare
}

src_install() {
qt5-build_src_install

doicon -s 128 src/designer/src/designer/images/designer.png
make_desktop_entry "${QT5_BINDIR}"/designer 'Qt 5 Designer' designer 'Qt;Development;GUIDesigner'
}

pkg_postinst() {
qt5-build_pkg_postinst
xdg_icon_cache_update
}

pkg_postrm() {
qt5-build_pkg_postrm
xdg_icon_cache_update
}
1 change: 1 addition & 0 deletions dev-qt/linguist-tools/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST qttools-everywhere-src-5.14.2.tar.xz 8815020 BLAKE2B 2535541b53cec5cc2dce1ac06ad70b145fce38642d8142f43a800a630aa2f69ad255e8f0a38c44022d14cc5b4373603026cc7c149c2435621f91a66ea0bf223d SHA512 e5b56d38acaa59511f24c817999f901510397d6e8baccc06a8fb8375f09b71dcffda4c57def4eb88d6c2782926d612b382957175a087a0c2224245051c54fe7e
DIST qttools-everywhere-src-5.15.0.tar.xz 8850752 BLAKE2B fed030b2e0bdb3bf397b28e33c1afc84c0b22bf3ede5bdf9a0822f44f8cbf6f7564d0d2c04215f79aec722deeac373d2d46cdd3d7e3d9135f9211486feaf12b0 SHA512 ebcebbc828e6a34766f2f5eeb4775d29af7b60b6124549df5256902ed2bd683721084b45a869ba76d29b1b170fe3834291af0833ab17ee8d05407c509f03d3eb
DIST qttools-everywhere-src-5.15.1.tar.xz 8901096 BLAKE2B f8927993dfc6888a1143b6a8ce09f075636600f77891edb64dd5c39bee75e2c752d3da4443c7956297c65c5b7f1103b1c6bb53b607cd054473a96adc1350e2b9 SHA512 8c7851431de8686a01fc5f85de5dcfa61b6878bd65b53ed78a8a23e57de70f2dcc1a72b4eed9a7219cfd443215a32a59a25fb929d343afcfd498517d6bcfb951
45 changes: 45 additions & 0 deletions dev-qt/linguist-tools/linguist-tools-5.15.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
QT5_MODULE="qttools"
inherit qt5-build

DESCRIPTION="Tools for working with Qt translation data files"

if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
fi

IUSE="qml"

DEPEND="
~dev-qt/qtcore-${PV}:5=
~dev-qt/qtxml-${PV}
qml? ( ~dev-qt/qtdeclarative-${PV} )
"
RDEPEND="${DEPEND}"

QT5_TARGET_SUBDIRS=(
src/linguist
)

src_prepare() {
sed -i -e '/SUBDIRS += linguist/d' \
src/linguist/linguist.pro || die

qt_use_disable_mod qml qmldevtools-private \
src/linguist/lupdate/lupdate.pro

qt5-build_src_prepare
}

src_configure() {
# Most of qttools require files that are only generated when qmake is
# run in the root directory.
# Related bugs: 633776, 676948, and 716514.
mkdir -p "${QT5_BUILD_DIR}" || die
qt5_qmake "${QT_BUILD_DIR}"
cp "${S}"/qttools-config.pri "${QT5_BUILD_DIR}" || die
qt5-build_src_configure
}
1 change: 1 addition & 0 deletions dev-qt/linguist/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST qttools-everywhere-src-5.14.2.tar.xz 8815020 BLAKE2B 2535541b53cec5cc2dce1ac06ad70b145fce38642d8142f43a800a630aa2f69ad255e8f0a38c44022d14cc5b4373603026cc7c149c2435621f91a66ea0bf223d SHA512 e5b56d38acaa59511f24c817999f901510397d6e8baccc06a8fb8375f09b71dcffda4c57def4eb88d6c2782926d612b382957175a087a0c2224245051c54fe7e
DIST qttools-everywhere-src-5.15.0.tar.xz 8850752 BLAKE2B fed030b2e0bdb3bf397b28e33c1afc84c0b22bf3ede5bdf9a0822f44f8cbf6f7564d0d2c04215f79aec722deeac373d2d46cdd3d7e3d9135f9211486feaf12b0 SHA512 ebcebbc828e6a34766f2f5eeb4775d29af7b60b6124549df5256902ed2bd683721084b45a869ba76d29b1b170fe3834291af0833ab17ee8d05407c509f03d3eb
DIST qttools-everywhere-src-5.15.1.tar.xz 8901096 BLAKE2B f8927993dfc6888a1143b6a8ce09f075636600f77891edb64dd5c39bee75e2c752d3da4443c7956297c65c5b7f1103b1c6bb53b607cd054473a96adc1350e2b9 SHA512 8c7851431de8686a01fc5f85de5dcfa61b6878bd65b53ed78a8a23e57de70f2dcc1a72b4eed9a7219cfd443215a32a59a25fb929d343afcfd498517d6bcfb951
48 changes: 48 additions & 0 deletions dev-qt/linguist/linguist-5.15.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
QT5_MODULE="qttools"
inherit desktop qt5-build xdg-utils

DESCRIPTION="Graphical tool for translating Qt applications"

if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86"
fi

IUSE=""

DEPEND="
~dev-qt/designer-${PV}
~dev-qt/qtcore-${PV}:5=
~dev-qt/qtgui-${PV}:5=
~dev-qt/qtprintsupport-${PV}
~dev-qt/qtwidgets-${PV}
~dev-qt/qtxml-${PV}
"
RDEPEND="${DEPEND}"

QT5_TARGET_SUBDIRS=(
src/linguist/linguist
)

src_install() {
qt5-build_src_install

local size
for size in 16 32 48 64 128; do
newicon -s ${size} src/linguist/linguist/images/icons/linguist-${size}-32.png linguist.png
done
make_desktop_entry "${QT5_BINDIR}"/linguist 'Qt 5 Linguist' linguist 'Qt;Development;Translation'
}

pkg_postinst() {
qt5-build_pkg_postinst
xdg_icon_cache_update
}

pkg_postrm() {
qt5-build_pkg_postrm
xdg_icon_cache_update
}
1 change: 1 addition & 0 deletions dev-qt/pixeltool/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST qttools-everywhere-src-5.14.2.tar.xz 8815020 BLAKE2B 2535541b53cec5cc2dce1ac06ad70b145fce38642d8142f43a800a630aa2f69ad255e8f0a38c44022d14cc5b4373603026cc7c149c2435621f91a66ea0bf223d SHA512 e5b56d38acaa59511f24c817999f901510397d6e8baccc06a8fb8375f09b71dcffda4c57def4eb88d6c2782926d612b382957175a087a0c2224245051c54fe7e
DIST qttools-everywhere-src-5.15.0.tar.xz 8850752 BLAKE2B fed030b2e0bdb3bf397b28e33c1afc84c0b22bf3ede5bdf9a0822f44f8cbf6f7564d0d2c04215f79aec722deeac373d2d46cdd3d7e3d9135f9211486feaf12b0 SHA512 ebcebbc828e6a34766f2f5eeb4775d29af7b60b6124549df5256902ed2bd683721084b45a869ba76d29b1b170fe3834291af0833ab17ee8d05407c509f03d3eb
DIST qttools-everywhere-src-5.15.1.tar.xz 8901096 BLAKE2B f8927993dfc6888a1143b6a8ce09f075636600f77891edb64dd5c39bee75e2c752d3da4443c7956297c65c5b7f1103b1c6bb53b607cd054473a96adc1350e2b9 SHA512 8c7851431de8686a01fc5f85de5dcfa61b6878bd65b53ed78a8a23e57de70f2dcc1a72b4eed9a7219cfd443215a32a59a25fb929d343afcfd498517d6bcfb951
21 changes: 21 additions & 0 deletions dev-qt/pixeltool/pixeltool-5.15.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
QT5_MODULE="qttools"
inherit qt5-build

DESCRIPTION="Qt screen magnifier"

if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
fi

IUSE=""

DEPEND="
~dev-qt/qtcore-${PV}:5=
~dev-qt/qtgui-${PV}:5=
~dev-qt/qtwidgets-${PV}
"
RDEPEND="${DEPEND}"
1 change: 1 addition & 0 deletions dev-qt/qdbus/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST qttools-everywhere-src-5.14.2.tar.xz 8815020 BLAKE2B 2535541b53cec5cc2dce1ac06ad70b145fce38642d8142f43a800a630aa2f69ad255e8f0a38c44022d14cc5b4373603026cc7c149c2435621f91a66ea0bf223d SHA512 e5b56d38acaa59511f24c817999f901510397d6e8baccc06a8fb8375f09b71dcffda4c57def4eb88d6c2782926d612b382957175a087a0c2224245051c54fe7e
DIST qttools-everywhere-src-5.15.0.tar.xz 8850752 BLAKE2B fed030b2e0bdb3bf397b28e33c1afc84c0b22bf3ede5bdf9a0822f44f8cbf6f7564d0d2c04215f79aec722deeac373d2d46cdd3d7e3d9135f9211486feaf12b0 SHA512 ebcebbc828e6a34766f2f5eeb4775d29af7b60b6124549df5256902ed2bd683721084b45a869ba76d29b1b170fe3834291af0833ab17ee8d05407c509f03d3eb
DIST qttools-everywhere-src-5.15.1.tar.xz 8901096 BLAKE2B f8927993dfc6888a1143b6a8ce09f075636600f77891edb64dd5c39bee75e2c752d3da4443c7956297c65c5b7f1103b1c6bb53b607cd054473a96adc1350e2b9 SHA512 8c7851431de8686a01fc5f85de5dcfa61b6878bd65b53ed78a8a23e57de70f2dcc1a72b4eed9a7219cfd443215a32a59a25fb929d343afcfd498517d6bcfb951
25 changes: 25 additions & 0 deletions dev-qt/qdbus/qdbus-5.15.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
QT5_MODULE="qttools"
inherit qt5-build

DESCRIPTION="Interface to Qt applications communicating over D-Bus"

if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
fi

IUSE=""

DEPEND="
~dev-qt/qtcore-${PV}
~dev-qt/qtdbus-${PV}
~dev-qt/qtxml-${PV}
"
RDEPEND="${DEPEND}"

QT5_TARGET_SUBDIRS=(
src/qdbus/qdbus
)
1 change: 1 addition & 0 deletions dev-qt/qdbusviewer/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST qttools-everywhere-src-5.14.2.tar.xz 8815020 BLAKE2B 2535541b53cec5cc2dce1ac06ad70b145fce38642d8142f43a800a630aa2f69ad255e8f0a38c44022d14cc5b4373603026cc7c149c2435621f91a66ea0bf223d SHA512 e5b56d38acaa59511f24c817999f901510397d6e8baccc06a8fb8375f09b71dcffda4c57def4eb88d6c2782926d612b382957175a087a0c2224245051c54fe7e
DIST qttools-everywhere-src-5.15.0.tar.xz 8850752 BLAKE2B fed030b2e0bdb3bf397b28e33c1afc84c0b22bf3ede5bdf9a0822f44f8cbf6f7564d0d2c04215f79aec722deeac373d2d46cdd3d7e3d9135f9211486feaf12b0 SHA512 ebcebbc828e6a34766f2f5eeb4775d29af7b60b6124549df5256902ed2bd683721084b45a869ba76d29b1b170fe3834291af0833ab17ee8d05407c509f03d3eb
DIST qttools-everywhere-src-5.15.1.tar.xz 8901096 BLAKE2B f8927993dfc6888a1143b6a8ce09f075636600f77891edb64dd5c39bee75e2c752d3da4443c7956297c65c5b7f1103b1c6bb53b607cd054473a96adc1350e2b9 SHA512 8c7851431de8686a01fc5f85de5dcfa61b6878bd65b53ed78a8a23e57de70f2dcc1a72b4eed9a7219cfd443215a32a59a25fb929d343afcfd498517d6bcfb951
45 changes: 45 additions & 0 deletions dev-qt/qdbusviewer/qdbusviewer-5.15.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
QT5_MODULE="qttools"
inherit desktop qt5-build xdg-utils

DESCRIPTION="Graphical tool that lets you introspect D-Bus objects and messages"

if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
fi

IUSE=""

DEPEND="
~dev-qt/qtcore-${PV}
~dev-qt/qtdbus-${PV}
~dev-qt/qtgui-${PV}
~dev-qt/qtwidgets-${PV}
~dev-qt/qtxml-${PV}
"
RDEPEND="${DEPEND}"

QT5_TARGET_SUBDIRS=(
src/qdbus/qdbusviewer
)

src_install() {
qt5-build_src_install

doicon -s 32 src/qdbus/qdbusviewer/images/qdbusviewer.png
newicon -s 128 src/qdbus/qdbusviewer/images/qdbusviewer-128.png qdbusviewer.png
make_desktop_entry "${QT5_BINDIR}"/qdbusviewer 'Qt 5 QDBusViewer' qdbusviewer 'Qt;Development'
}

pkg_postinst() {
qt5-build_pkg_postinst
xdg_icon_cache_update
}

pkg_postrm() {
qt5-build_pkg_postrm
xdg_icon_cache_update
}
1 change: 1 addition & 0 deletions dev-qt/qdoc/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST qttools-everywhere-src-5.14.2.tar.xz 8815020 BLAKE2B 2535541b53cec5cc2dce1ac06ad70b145fce38642d8142f43a800a630aa2f69ad255e8f0a38c44022d14cc5b4373603026cc7c149c2435621f91a66ea0bf223d SHA512 e5b56d38acaa59511f24c817999f901510397d6e8baccc06a8fb8375f09b71dcffda4c57def4eb88d6c2782926d612b382957175a087a0c2224245051c54fe7e
DIST qttools-everywhere-src-5.15.0.tar.xz 8850752 BLAKE2B fed030b2e0bdb3bf397b28e33c1afc84c0b22bf3ede5bdf9a0822f44f8cbf6f7564d0d2c04215f79aec722deeac373d2d46cdd3d7e3d9135f9211486feaf12b0 SHA512 ebcebbc828e6a34766f2f5eeb4775d29af7b60b6124549df5256902ed2bd683721084b45a869ba76d29b1b170fe3834291af0833ab17ee8d05407c509f03d3eb
DIST qttools-everywhere-src-5.15.1.tar.xz 8901096 BLAKE2B f8927993dfc6888a1143b6a8ce09f075636600f77891edb64dd5c39bee75e2c752d3da4443c7956297c65c5b7f1103b1c6bb53b607cd054473a96adc1350e2b9 SHA512 8c7851431de8686a01fc5f85de5dcfa61b6878bd65b53ed78a8a23e57de70f2dcc1a72b4eed9a7219cfd443215a32a59a25fb929d343afcfd498517d6bcfb951
28 changes: 28 additions & 0 deletions dev-qt/qdoc/qdoc-5.15.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
QT5_MODULE="qttools"
inherit qt5-build

DESCRIPTION="Qt documentation generator"

if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
fi

IUSE="qml"

DEPEND="
~dev-qt/qtcore-${PV}:5=
sys-devel/clang:=
qml? ( ~dev-qt/qtdeclarative-${PV} )
"
RDEPEND="${DEPEND}"

src_prepare() {
qt_use_disable_mod qml qmldevtools-private \
src/qdoc/qdoc.pro

qt5-build_src_prepare
}
1 change: 1 addition & 0 deletions dev-qt/qt3d/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST qt3d-everywhere-src-5.14.2.tar.xz 81576496 BLAKE2B 39077430fa58a14d0636ef56607b687636651d8fb798093d00b150ae023c462780245f06d61eac214560b336a1f445c2fbeca397c1dc7e7ee0331cc008692a3c SHA512 43053d001d59094bfac19c5bf3ad17df277c64d0c214b72d4cf02231396d9109a231da8d9d72ebe79822bc09ee24fa2387b4b120dbad43d69a49e3d66ee21da8
DIST qt3d-everywhere-src-5.15.0.tar.xz 81921676 BLAKE2B da636ae20daac0e3006f22d3c1e6d9f07938b1c0062d1e554914c1f25c195905f775ba2441125592237b8cc4005f4a05d7f78413b65e67ff0fa609da8ae8952a SHA512 0cc327438ec174bfc6b7b560b5957653d38cdcb1c94717e296c3f52f41750f1b95ad620e3c3777fdc9c63f885f8325b8c1d1befcc338a25fc65d3f62b2019185
DIST qt3d-everywhere-src-5.15.1.tar.xz 81919836 BLAKE2B e0c617e777dc2562caaee02483bb4c9ec2fd17214ea02505942b074b82e698a82e4c81ef552705872c6c10be3cbab65a1fc3c5aff2c87637639f223583a04ae6 SHA512 5d35f39bd3cb65a4b7490fd3d57a4f62b3ccaad25c7963613d67641927bdc9d895fb436d049de5485a9e8e067c716951e376349cbfc3996af6765adda73d51d5
34 changes: 34 additions & 0 deletions dev-qt/qt3d/qt3d-5.15.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit qt5-build

DESCRIPTION="3D rendering module for the Qt5 framework"

if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm64 ~x86"
fi

# TODO: tools
IUSE="gamepad gles2-only qml"

DEPEND="
~dev-qt/qtconcurrent-${PV}
~dev-qt/qtcore-${PV}
~dev-qt/qtgui-${PV}
~dev-qt/qtnetwork-${PV}
>=media-libs/assimp-4.0.0
gamepad? ( ~dev-qt/qtgamepad-${PV} )
qml? ( ~dev-qt/qtdeclarative-${PV}[gles2-only=] )
"
RDEPEND="${DEPEND}"

src_prepare() {
rm -r src/3rdparty/assimp/{code,contrib,include} || die

qt_use_disable_mod gamepad gamepad src/input/frontend/frontend.pri
qt_use_disable_mod qml quick src/src.pro

qt5-build_src_prepare
}
Loading

0 comments on commit c60b2b1

Please sign in to comment.