Skip to content

Commit

Permalink
games-rpg/avadon: EAPI 6->7, tidy a bit
Browse files Browse the repository at this point in the history
Do not own this game, so only doing (hopefully) safe changes.

Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
ionenwks committed Jul 18, 2021
1 parent 02cab29 commit c68e16f
Showing 1 changed file with 13 additions and 17 deletions.
30 changes: 13 additions & 17 deletions games-rpg/avadon/avadon-1.0.4_p1331768904.ebuild
Original file line number Diff line number Diff line change
@@ -1,26 +1,26 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

inherit desktop gnome2-utils unpacker
inherit desktop unpacker

DESCRIPTION="Epic fantasy role-playing adventure in an enormous and unique world"
HOMEPAGE="https://www.spiderwebsoftware.com/avadon"
SRC_URI="avadon-linux-${PV#*_p}-bin.txt" # .txt is odd but that's what Humble Bundle sends.
S="${WORKDIR}/data"

LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
RESTRICT="fetch bindist"
RESTRICT="bindist fetch"

QA_PREBUILT="opt/${PN}/Avadon"

RDEPEND="media-libs/libsdl[opengl,video]
RDEPEND="
media-libs/libsdl[opengl,video]
media-libs/openal"

DEPEND="app-arch/unzip"

S="${WORKDIR}/data"
BDEPEND="app-arch/unzip"

pkg_nofetch() {
einfo "Please buy and download ${SRC_URI} from:"
Expand All @@ -35,19 +35,15 @@ src_unpack() {
src_install() {
local dir=/opt/${PN}

insinto "${dir}"
insinto ${dir}
doins -r "avadon files" icon.bmp

exeinto "${dir}"
exeinto ${dir}
newexe Avadon-$(usex amd64 amd64 x86) Avadon
dosym "../..${dir}"/Avadon /usr/bin/${PN}
dosym ../..${dir}/Avadon /usr/bin/${PN}

newicon -s 512 Avadon.png ${PN}.png
newicon Avadon.png ${PN}.png
make_desktop_entry ${PN} "Avadon: The Black Fortress"

dodoc README-linux.txt
}

pkg_preinst() { gnome2_icon_savelist; }
pkg_postinst() { gnome2_icon_cache_update; }
pkg_postrm() { gnome2_icon_cache_update; }

0 comments on commit c68e16f

Please sign in to comment.