Skip to content

Commit

Permalink
dev-cpp/gtkmm: bump to 3.24.0
Browse files Browse the repository at this point in the history
Signed-off-by: Mart Raudsepp <[email protected]>
Package-Manager: Portage-2.3.52, Repoman-2.3.11
  • Loading branch information
leio committed Dec 7, 2018
1 parent be4b63a commit c7c8dfb
Show file tree
Hide file tree
Showing 2 changed files with 73 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/gtkmm/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gtkmm-2.24.5.tar.xz 12022024 BLAKE2B 6b2bca9fe6ad81cd956e1f3cc3140bc503b78386cf3931c8eeac08c8b2a08c73450bdbb703d1febaee67cdf834093ff5e89790f866357190822613a68a596ad3 SHA512 c50e52830977c37181439f4b82a30ac8bead0cf9022d2bec8225f8dc33e08414f863bf67056e1938fae8f888c09a5a6d757acc011fa9331a78caa6bb626dd51e
DIST gtkmm-3.22.2.tar.xz 12341028 BLAKE2B cac55d0358be4be50ff2d603b245a34af4bab0a046332ac6a7159ea7dece8bce8cd53c532ce499cf3172e8f69455de0378946640ad363e33ddd2a5c38e6843ca SHA512 6e96b543e459481145ee0f56f31a7ad2466bd8ccdd2abf3205998aecede73d235149ca6e5ba6e8d20a4fd5345e310870d81ac2a716d4f78d1460ed685badbdc2
DIST gtkmm-3.24.0.tar.xz 12515792 BLAKE2B d1150019b28ecffbf1e2f561e8b691d584dfc893dbc1ef46f1dd33e2c9050ea77e00a1cb7ce1f3832568fd9865c977dbc71a461923c285331372371a5f235369 SHA512 94658fbf7eebbac2a864d6c7d3cd0e6ffd4ac213fd1d9986d721d4906c7a43a45d8757df475879ee37ef54ec5e3fac7d9a8e4a194b97b2be72a10743bf2e13ac
72 changes: 72 additions & 0 deletions dev-cpp/gtkmm/gtkmm-3.24.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit gnome2 multilib-minimal virtualx

DESCRIPTION="C++ interface for GTK+"
HOMEPAGE="https://www.gtkmm.org"

LICENSE="LGPL-2.1+"
SLOT="3.0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"

IUSE="aqua doc test wayland X"
REQUIRED_USE="|| ( aqua wayland X )"

RDEPEND="
>=dev-cpp/glibmm-2.54.0:2[${MULTILIB_USEDEP}]
>=x11-libs/gtk+-3.24.0:3[aqua?,wayland?,X?,${MULTILIB_USEDEP}]
>=x11-libs/gdk-pixbuf-2.35.5:2[${MULTILIB_USEDEP}]
>=dev-cpp/atkmm-2.24.2[${MULTILIB_USEDEP}]
>=dev-cpp/cairomm-1.12.0[${MULTILIB_USEDEP}]
>=dev-cpp/pangomm-2.38.2:1.4[${MULTILIB_USEDEP}]
>=dev-libs/libsigc++-2.3.2:2[${MULTILIB_USEDEP}]
"
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? (
media-gfx/graphviz
dev-libs/libxslt
app-doc/doxygen )
"
# eautoreconf needs mm-common

src_prepare() {
if ! use test; then
# don't waste time building tests
sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
|| die "sed 1 failed"
fi

# don't waste time building examples
sed 's/^\(SUBDIRS =.*\)demos\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
|| die "sed 2 failed"

gnome2_src_prepare
}

multilib_src_configure() {
ECONF_SOURCE="${S}" gnome2_src_configure \
--enable-api-atkmm \
$(multilib_native_use_enable doc documentation) \
$(use_enable aqua quartz-backend) \
$(use_enable wayland wayland-backend) \
$(use_enable X x11-backend)
}

multilib_src_test() {
virtx emake check
}

multilib_src_install() {
gnome2_src_install
}

multilib_src_install_all() {
einstalldocs

find demos -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null
find demos -type f -name 'Makefile*' -exec rm -f {} \; 2>/dev/null
dodoc -r demos
}

0 comments on commit c7c8dfb

Please sign in to comment.