Skip to content

Commit

Permalink
dev-libs/leatherman: bup
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
prometheanfire committed May 7, 2016
1 parent af64983 commit c7f5310
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/leatherman/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST leatherman-0.4.2.tar.gz 373142 SHA256 5c1d9af54d803ba8a200004320f55e3ec983265a60f9c8942bf53c745f1f1679 SHA512 c82a3458fe813d0ccd9c5b7539b6d98d28c598be24803062b7a990eadf36fe3b4da70c4253af022bfe9eb4cfdf1d322ed3d04f56021ac09ae10f44fd33467981 WHIRLPOOL afec9a9e773f68d2560f272a5eea11fa601667ccb38bba07f3bdb8e8cb528a6b61ecb35625f633faea6095e63eff172c9018420458d1ed2afeedcb07988962a9
DIST leatherman-0.6.2.tar.gz 385105 SHA256 69ef5420ba94f70ffca0dc3255ff0523f4052b2b43bfe3ceea1cb124ce18a786 SHA512 155ac188c570743d54c57c2ea8c5f1b5b2ff6e468a7c10bb194d3332ad3301efb7607083e186015e4e7e0d5c353d194ba25421a171d9da7125e514bf2d185755 WHIRLPOOL 1ac712d86a01ca5b6acaf21c5f3aebb3ba9c6642f4c074d9e998aca9f288092b9764a8f85f3fc5f5fb3525098a4107943ad2daa6c527b89d52a39443d23ee32e
DIST leatherman-0.6.3.tar.gz 387644 SHA256 8951713aff2dd9a4e38016faa6fa6bd5634f1c9ffb59f03ffab24a91a6afcd1b SHA512 bdda57d1816d6a7769f62b7e681453c3e71aff3deac3ed5d0f332440033520aba2cda8f0654b565c4d534eb307ebe02d554660c3502cdd36f842c168b4535535 WHIRLPOOL 62619d7ed688d3e34f90f3d64f77051ccb1df5e3a7d658f9405e74b11b2e128d7505dd21a04d0635d848c5ccc7e3f0d2efcea26437b684ee89403828a9d6d540
51 changes: 51 additions & 0 deletions dev-libs/leatherman/leatherman-0.6.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
USE_RUBY="ruby20 ruby21 ruby22"

inherit cmake-utils multilib ruby-ng

DESCRIPTION="A C++ toolkit"
HOMEPAGE="https://github.com/puppetlabs/leatherman"
SRC_URI="https://downloads.puppetlabs.com/facter/${P}.tar.gz"
SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
S="${S}/all/${P}"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="debug test"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"

CDEPEND="
>=sys-devel/gcc-4.8:*
>=dev-libs/boost-1.54[nls]
net-misc/curl"

RDEPEND+=" ${CDEPEND}"
DEPEND+=" test? ( ${CDEPEND} )"

src_prepare() {
sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
}

src_configure() {
local mycmakeargs=(
-DCMAKE_VERBOSE_MAKEFILE=ON
-DCMAKE_BUILD_TYPE=None
-DCMAKE_INSTALL_PREFIX=/usr
-DCMAKE_INSTALL_SYSCONFDIR=/etc
-DCMAKE_INSTALL_LOCALSTATEDIR=/var
)
if use debug; then
mycmakeargs+=(
-DCMAKE_BUILD_TYPE=Debug
)
fi
cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install
}

0 comments on commit c7f5310

Please sign in to comment.