Skip to content

Commit

Permalink
dev-cpp/gtkmm: bump to 3.22.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
leio committed Jul 9, 2017
1 parent 34c500e commit c804d6e
Show file tree
Hide file tree
Showing 2 changed files with 73 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/gtkmm/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gtkmm-2.24.5.tar.xz 12022024 SHA256 0680a53b7bf90b4e4bf444d1d89e6df41c777e0bacc96e9c09fc4dd2f5fe6b72 SHA512 c50e52830977c37181439f4b82a30ac8bead0cf9022d2bec8225f8dc33e08414f863bf67056e1938fae8f888c09a5a6d757acc011fa9331a78caa6bb626dd51e WHIRLPOOL b1bd5d27f53fece724c3389eb938a9ba746fb168637cacd437f152e6753f0150e5227acaed8d9b93b8e2e497352d03d77bec3fe4a5029c144ef2270c28c31c46
DIST gtkmm-3.22.0.tar.xz 12320816 SHA256 05da4d4b628fb20c8384630ddf478a3b5562952b2d6181fe28d58f6cbc0514f5 SHA512 0bc141ff09bc78697e89c6f071a1411cbc06e015ee664f3a6f9143bdb31793982e09533c8cff6d8c19cc53c4d32a1e5ad016db48141f5cfc21edfb333bf37988 WHIRLPOOL 8ec9f50c3f960dbe907d584c96adc0b4859b0d319c9c299f476cad8065390abb3f0b1c48cdf01303ce6f72a267b72d750d8dd5e4a011ce2d245e9acd649ee4b9
DIST gtkmm-3.22.1.tar.xz 12338092 SHA256 6a0c2cc0894a69b666e688e5e6e93621d7625db5e77fd37551310d75c00896b0 SHA512 f2a924774c6f4a9a1ec66bde65201fc6b8e17bf48d306ad78bdcabe9a2ce4b8d67c0714b52406534708c1c505efc7ff5a651a1df21531568795202e2717d1eaf WHIRLPOOL 515c33d2914779d2e579d6a6e11f7b2740e7716870420a8f2200987ca8830585aeb10e4f4b19712fdc6f614b8e9fe9857e49a116481fd71637a4381b29f640d2
72 changes: 72 additions & 0 deletions dev-cpp/gtkmm/gtkmm-3.22.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit gnome2 multilib-minimal virtualx

DESCRIPTION="C++ interface for GTK+"
HOMEPAGE="https://www.gtkmm.org"

LICENSE="LGPL-2.1+"
SLOT="3.0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"

IUSE="aqua doc test wayland X"
REQUIRED_USE="|| ( aqua wayland X )"

RDEPEND="
>=dev-cpp/glibmm-2.49.1:2[${MULTILIB_USEDEP}]
>=x11-libs/gtk+-3.22.0:3[aqua?,wayland?,X?,${MULTILIB_USEDEP}]
>=x11-libs/gdk-pixbuf-2.35.5:2[${MULTILIB_USEDEP}]
>=dev-cpp/atkmm-2.24.2[${MULTILIB_USEDEP}]
>=dev-cpp/cairomm-1.12.0[${MULTILIB_USEDEP}]
>=dev-cpp/pangomm-2.38.2:1.4[${MULTILIB_USEDEP}]
>=dev-libs/libsigc++-2.3.2:2[${MULTILIB_USEDEP}]
"
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? (
media-gfx/graphviz
dev-libs/libxslt
app-doc/doxygen )
"
# eautoreconf needs mm-common

src_prepare() {
if ! use test; then
# don't waste time building tests
sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
|| die "sed 1 failed"
fi

# don't waste time building examples
sed 's/^\(SUBDIRS =.*\)demos\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
|| die "sed 2 failed"

gnome2_src_prepare
}

multilib_src_configure() {
ECONF_SOURCE="${S}" gnome2_src_configure \
--enable-api-atkmm \
$(multilib_native_use_enable doc documentation) \
$(use_enable aqua quartz-backend) \
$(use_enable wayland wayland-backend) \
$(use_enable X x11-backend)
}

multilib_src_test() {
virtx emake check
}

multilib_src_install() {
gnome2_src_install
}

multilib_src_install_all() {
einstalldocs

find demos -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null
find demos -type f -name 'Makefile*' -exec rm -f {} \; 2>/dev/null
dodoc -r demos
}

0 comments on commit c804d6e

Please sign in to comment.