Skip to content

Commit

Permalink
dev-cpp/yaml-cpp: install cmake and .pc files to lib/
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/807745
Package-Manager: Portage-3.0.20, Repoman-3.0.2
Signed-off-by: Alexey Sokolov <[email protected]>
Closes: gentoo#21953
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
DarthGandalf authored and juippis committed Aug 16, 2021
1 parent 035a8b4 commit c813626
Show file tree
Hide file tree
Showing 2 changed files with 22 additions and 0 deletions.
21 changes: 21 additions & 0 deletions dev-cpp/yaml-cpp/files/yaml-cpp-0.7.0-pkg-config.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
https://bugs.gentoo.org/807745

--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -148,13 +148,13 @@ if (YAML_CPP_INSTALL)
DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
FILES_MATCHING PATTERN "*.h")
install(EXPORT yaml-cpp-targets
- DESTINATION "${CMAKE_INSTALL_DATADIR}/cmake/yaml-cpp")
+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/cmake/yaml-cpp")
install(FILES
"${PROJECT_BINARY_DIR}/yaml-cpp-config.cmake"
"${PROJECT_BINARY_DIR}/yaml-cpp-config-version.cmake"
- DESTINATION "${CMAKE_INSTALL_DATADIR}/cmake/yaml-cpp")
+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/cmake/yaml-cpp")
install(FILES "${PROJECT_BINARY_DIR}/yaml-cpp.pc"
- DESTINATION ${CMAKE_INSTALL_DATADIR}/pkgconfig)
+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
endif()

if(YAML_CPP_BUILD_TESTS)
Original file line number Diff line number Diff line change
Expand Up @@ -21,6 +21,7 @@ DEPEND="test? ( dev-cpp/gtest[${MULTILIB_USEDEP}] )"

PATCHES=(
"${FILESDIR}/${P}-gtest.patch"
"${FILESDIR}/${P}-pkg-config.patch"
)

src_prepare() {
Expand Down

0 comments on commit c813626

Please sign in to comment.