Skip to content

Commit

Permalink
dev-java/resin-servlet-api: Bump to EAPI 7
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/697530
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Nov 10, 2019
1 parent 21a0572 commit c95f6be
Showing 1 changed file with 12 additions and 23 deletions.
35 changes: 12 additions & 23 deletions dev-java/resin-servlet-api/resin-servlet-api-3.0.25.ebuild
Original file line number Diff line number Diff line change
@@ -1,50 +1,39 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=0
EAPI=7

JAVA_PKG_IUSE="source"

inherit eutils java-pkg-2 java-ant-2
inherit java-pkg-2 java-ant-2

DESCRIPTION="Resin Servlet API 2.4/JSP API 2.0 implementation"
HOMEPAGE="http://www.caucho.com/"
SRC_URI="http://www.caucho.com/download/resin-${PV}-src.zip
mirror://gentoo/resin-gentoo-patches-${PV}.tar.bz2"

LICENSE="GPL-2"
LICENSE="GPL-2+"
SLOT="2.4"
KEYWORDS="amd64 ppc64 x86"

IUSE=""

COMMON_DEP=""

RDEPEND=">=virtual/jre-1.4
${COMMON_DEP}"
RDEPEND=">=virtual/jre-1.4:*"
DEPEND=">=virtual/jdk-1.4
app-arch/unzip
${COMMON_DEP}"
app-arch/unzip"

S="${WORKDIR}/resin-${PV}"

src_unpack() {

unpack ${A}

mkdir "${S}/lib"
EANT_BUILD_TARGET="jsdk"
EANT_DOC_TARGET=""

cd "${S}"
epatch "${WORKDIR}/${PV}/resin-${PV}-build.xml.patch"
src_prepare() {
default

mkdir lib || die
eapply "${WORKDIR}/${PV}/resin-${PV}-build.xml.patch"
}

EANT_BUILD_TARGET="jsdk"
EANT_DOC_TARGET=""

src_install() {

java-pkg_newjar "lib/jsdk-24.jar"
use source && java-pkg_dosrc "${S}"/modules/jsdk/src/*

}

0 comments on commit c95f6be

Please sign in to comment.