Skip to content

Commit

Permalink
dev-ros/random_numbers: Initial import. Ebuild by me.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.21
  • Loading branch information
aballier committed Sep 22, 2015
1 parent b0ab444 commit caf2642
Show file tree
Hide file tree
Showing 4 changed files with 54 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ros/random_numbers/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST random_numbers-0.3.0.tar.gz 6824 SHA256 d7af5b2dc47242be5622e059da6aa2d22c8eefd9ddcabba2e0d619608a0f532b SHA512 3a70dd9c8407a23a51279b3e5f97b8e3c7f569a2b95b78d7c4c17d904a796c51e02a652e8f1a34d0e2814ce62492d20313f031f80a23bac527f8b48780da9f07 WHIRLPOOL c88ff5126eeff5c3e20ab9a69aa7e10c3cdfe9023f3db5d64a4edd9d0e974625c9856621088bab55dd94e058a3e456fa7421b565aec10f37c7ffe0ec62cae3dd
5 changes: 5 additions & 0 deletions dev-ros/random_numbers/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>ros</herd>
</pkgmetadata>
24 changes: 24 additions & 0 deletions dev-ros/random_numbers/random_numbers-0.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

ROS_REPO_URI="https://github.com/ros-planning/random_numbers"
KEYWORDS="~amd64 ~arm"

inherit ros-catkin

DESCRIPTION="Wrappers for generating floating point values, integers, quaternions using boost libraries"
LICENSE="BSD"
SLOT="0"
IUSE=""

RDEPEND="dev-libs/boost:=[threads]"
DEPEND="${RDEPEND}"

src_prepare() {
sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
-i CMakeLists.txt \
|| die
}
24 changes: 24 additions & 0 deletions dev-ros/random_numbers/random_numbers-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

ROS_REPO_URI="https://github.com/ros-planning/random_numbers"
KEYWORDS="~amd64 ~arm"

inherit ros-catkin

DESCRIPTION="Wrappers for generating floating point values, integers, quaternions using boost libraries"
LICENSE="BSD"
SLOT="0"
IUSE=""

RDEPEND="dev-libs/boost:=[threads]"
DEPEND="${RDEPEND}"

src_prepare() {
sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
-i CMakeLists.txt \
|| die
}

0 comments on commit caf2642

Please sign in to comment.