Skip to content

Commit

Permalink
app-emulation/buildah: Bump to version 1.11.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Zac Medico <[email protected]>
  • Loading branch information
zmedico committed Sep 12, 2019
1 parent 24e85e0 commit cb0342a
Show file tree
Hide file tree
Showing 2 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/buildah/Manifest
Original file line number Diff line number Diff line change
@@ -1,5 +1,6 @@
DIST buildah-1.10.0.tar.gz 9362108 BLAKE2B 691b5273056f9eb3e1f1dabf22c299ae281af8db13e680351bc0f4e0b6560b0ac20def5a1b3a039d14b97bb35a935a34ae83eeadc6272ad4d68a494439cc5f57 SHA512 33d33bb622e69512a2e11592455d654f6478994e78894bd0f73e03cc01e12c7e30b1fc25bbd6b44a3ce83b9e261ffb47c3d08a99bf523f4fe0e3ff00d93861a8
DIST buildah-1.10.1.tar.gz 9378648 BLAKE2B ea563d1a52634aa4e0172f05caf04b511bd9962cec012ed35830ceb5848dae1c14020167d61d44e11d0dcdcd6d5440c216505a11987f6806bac1336dd12152c9 SHA512 0651ed1ec6015b437ed0a786bef20c6a88fedfa4d318edc081d257720b1cc2c8d380a8cde5125ab5894bf0b4a6df90034b689097f7cc05630401e8e7700fca6a
DIST buildah-1.11.0.tar.gz 10065996 BLAKE2B fcf709f7474bcb45f2da6f90b614b4c95036d19c05fad715f80720efbb9ad6c4be6725001de4b5198c7d81e365ff12a742b73bc5d7268819de56c4b2fbe0b8e4 SHA512 a5e852a427de4e3f3ce8d78fb8ea82e8b6e0a1bcc6a0bc786c2bcb0d4689fec5f5a6413f77898bd953dc7eeea31d1d58fe22fac40cd5209fa5016a376a9958b7
DIST buildah-1.11.1.tar.gz 10126770 BLAKE2B 88ee8aa43490b12e0e63cbdae24d62d8fd10f8a502689dc30b748213aaf32851bc83c4fce38316f79523e3fb3a7110fc763d8bcbd24181ae45abeb5b3eecdda5 SHA512 322fe1b249ff6db160bc1dc111d19ddde8f36ae931f222aeab21e0b39f60bcbe9ad8b11cb6ee088b028478d6774a2fb231b6d457ed4c30cd5477b4a67ebcf06a
DIST buildah-1.8.4.tar.gz 5122400 BLAKE2B b02a1cac77f5f16ab6cec3a74f11ee94675c717ead21fd791feb4cfbd08dcfb4313a1ee3134d3b9f9d20218935db35e28dab406a9f706ff2f46a2beb1abaa56b SHA512 a316e5e2bea7cded1db089bbc7831c9af69242caa6108c78d63864c012053bda3dc3da5bf70248b2742b2be1ad66aeb59c844558022c20f79236f5b1292d6366
DIST buildah-1.9.2.tar.gz 9505091 BLAKE2B 886e1ae5804f005f5782d011ed8440a8ac5eb09b2cf7917ac04ed1ab3e08f8cce6ef9b8efaf3392d60ed46b5bdb2efcec8b44c0448f970210cd613837a5d8f1f SHA512 1add432491fcae3b22dac2768ba71be2a47f42f3d9fae14cc5ff54220b3b7b96a48a95cb10b249de98f9c3067d463bbeca75c7c52783c111a9b5ed0ba03eb30f
57 changes: 57 additions & 0 deletions app-emulation/buildah/buildah-1.11.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit bash-completion-r1 golang-vcs-snapshot

KEYWORDS="~amd64"
DESCRIPTION="A tool that facilitates building OCI images"
HOMEPAGE="https://github.com/containers/buildah"
LICENSE="Apache-2.0"
SLOT="0"
IUSE="ostree selinux"
EGO_PN="${HOMEPAGE#*//}"
EGIT_COMMIT="v${PV}"
GIT_COMMIT="413bd1f"
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
RDEPEND="app-crypt/gpgme:=
app-emulation/skopeo
dev-libs/libgpg-error:=
dev-libs/libassuan:=
sys-fs/lvm2:=
sys-libs/libseccomp:=
selinux? ( sys-libs/libselinux:= )"
DEPEND="${RDEPEND}"
RESTRICT="test"
REQUIRED_USE="!selinux? ( !ostree )"
S="${WORKDIR}/${P}/src/${EGO_PN}"

src_prepare() {
default
sed -e 's|^\(GIT_COMMIT ?= \).*|\1'${GIT_COMMIT}'|' -i Makefile || die

[[ -f ostree_tag.sh ]] || die
use ostree || { echo -e "#!/bin/sh\necho containers_image_ostree_stub" > \
ostree_tag.sh || die; }

[[ -f selinux_tag.sh ]] || die
use selinux || { echo -e "#!/bin/sh\ntrue" > \
selinux_tag.sh || die; }
}

src_compile() {
export -n GOCACHE XDG_CACHE_HOME
GOPATH="${WORKDIR}/${P}" emake all
}

src_install() {
dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
doman docs/*.1
dodoc -r docs/tutorials
dobin ${PN} imgtype
dobashcomp contrib/completions/bash/buildah
}

src_test() {
GOPATH="${WORKDIR}/${P}" emake test-unit
}

0 comments on commit cb0342a

Please sign in to comment.