Skip to content

Commit

Permalink
dev-java/jnr-ffi: bump to 2.2.8
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/786468
Bug: https://bugs.gentoo.org/721944
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Volkmar W. Pogatzki <[email protected]>
Closes: gentoo#20697
Signed-off-by: Miroslav Šulc <[email protected]>
  • Loading branch information
vaukai authored and fordfrog committed Nov 21, 2021
1 parent bd821ea commit cb07f60
Show file tree
Hide file tree
Showing 2 changed files with 64 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-java/jnr-ffi/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST jnr-ffi-2.0.2.tar.gz 170707 BLAKE2B fc4f1dcea51939b6098b980b4962380e58ba590ea9d4cdba7823c1372bd645d985ae25d8ebf1f0b575a0e4b5c192e5595094076d3cd44e4bb3c077dd838c170f SHA512 80a932408f5ceaf19fd7a399b786aa0d7b9251ea144bc2755bcf3cdc3aea85615a1faa001bbcd3072bc0eead2aaa30d0bbead5f96c82c4b9e455c1ed1379b4c0
DIST jnr-ffi-2.2.8-sources.tar.gz 261959 BLAKE2B 16f7b89c88a61fa07da65d4e5287258f96550b93898bb7313ddd62d1f002276da86aca2c79874eccb466eaebcad5181ff33539996a6558b6d79ce9280cf9c0a9 SHA512 15187d90f15ad82cb6cac0617806ab7d0322bfcb4f44523f2272f93f19ec115625806c9d450bffaa57db32c70906328c8edc905046465b0ec3eb6ff52e500b42
63 changes: 63 additions & 0 deletions dev-java/jnr-ffi/jnr-ffi-2.2.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# Skeleton command:
# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/jnr/jnr-ffi/archive/refs/tags/jnr-ffi-2.2.8.tar.gz --slot 2 --keywords "~amd64 ~arm64 ~ppc64 ~x86" --ebuild jnr-ffi-2.2.8.ebuild

EAPI=7

JAVA_PKG_IUSE="doc source"
MAVEN_ID="com.github.jnr:jnr-ffi:2.2.8"
# no junit-jupiter in ::gentoo
# JAVA_TESTING_FRAMEWORKS="junit-jupiter"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="A library for invoking native functions from java"
HOMEPAGE="https://github.com/jnr/jnr-ffi"
SRC_URI="https://github.com/jnr/${PN}/archive/refs/tags/${P}.tar.gz -> ${P}-sources.tar.gz"
LICENSE="Apache-2.0"
SLOT="2"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"

# Common dependencies
# POM: pom.xml
# com.github.jnr:jffi:1.3.6 -> >=dev-java/jffi-1.3.6:1.2
# com.github.jnr:jnr-a64asm:1.0.0 -> >=dev-java/jnr-a64asm-1.0.0:2
# com.github.jnr:jnr-x86asm:1.0.2 -> >=dev-java/jnr-x86asm-1.0.2:1.0
# org.ow2.asm:asm:9.2 -> >=dev-java/asm-9.2:9
# org.ow2.asm:asm-analysis:9.2 -> >=dev-java/asm-analysis-9.2:`ver_cut 1`
# org.ow2.asm:asm-commons:9.2 -> >=dev-java/asm-commons-9.2:`ver_cut 1`
# org.ow2.asm:asm-tree:9.2 -> >=dev-java/asm-tree-9.2:`ver_cut 1`
# org.ow2.asm:asm-util:9.2 -> >=dev-java/asm-util-9.2:`ver_cut 1`

CDEPEND="
dev-java/asm:9
dev-java/asm-analysis:9
dev-java/asm-commons:9
dev-java/asm-tree:9
dev-java/asm-util:9
>=dev-java/jffi-1.3.6:1.2
dev-java/jnr-a64asm:2
dev-java/jnr-x86asm:1.0
"

DEPEND="${CDEPEND}
>=virtual/jdk-1.8:*"

# Runtime dependencies
# POM: pom.xml
# com.github.jnr:jffi:1.3.6 -> >=dev-java/jffi-1.3.6:1.2

RDEPEND="
${CDEPEND}>=virtual/jre-1.8:*
>=dev-java/jffi-1.3.6:1.2"

S="${WORKDIR}/${PN}-${P}"

JAVA_GENTOO_CLASSPATH="jffi-1.2,jnr-a64asm-2,jnr-x86asm-1.0,asm-9,asm-analysis-9,asm-commons-9,asm-tree-9,asm-util-9,jffi-1.2"
# no junit-jupiter in ::gentoo
JAVA_SRC_DIR="src/main/java"

# JAVA_TEST_GENTOO_CLASSPATH="!!!groupId-not-found!!!"
# JAVA_TEST_SRC_DIR="src/test/java"

0 comments on commit cb07f60

Please sign in to comment.