Skip to content

Commit

Permalink
media-sound/picard: 1.4.1 version bump
Browse files Browse the repository at this point in the history
Changes made:
* convert DOCS to array and add README.md
* use correct python_ phase functions instead of src_
* make explicit the passing the phase variables to setup.py
* remove doicon and domenu commands which are no longer required
* remove BROWSER setting documentation
  Picard is able to determine default browser on Gnome and Plasma systems
  Reference: https://picard.musicbrainz.org/docs/faq/#which-browser
* make chromaprint and python-discid runtime optional
  Optional runtime dependencies are:
  - chromaprint[tools]
  - python-discid

Refer to https://devmanual.gentoo.org/general-concepts/use-flags/ for
information on why these dependencies should not be listed in DEPEND
and/or RDEPEND. Picard is capable of executing correctly with and
without these dependencies installed on the system. A user can install
these dependencies at a later stage and Picard will recognise them
without a need to rebuild the media-sound/picard package.

Gentoo-bug: 609376
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Closes: gentoo#4196
  • Loading branch information
davidhicks authored and a17r committed Apr 17, 2017
1 parent 8654aff commit cb1f060
Show file tree
Hide file tree
Showing 2 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-sound/picard/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST picard-1.3.1.tar.gz 2047677 SHA256 f83ec4ab703134a3dbd8203a2b30c15ea87bec79c02446506e4dce1ec87f7d02 SHA512 72641e1f604cc3db339400511e1b37ce513f315e200af3ed25dd842cfa32b8b0a3b93cf60cd01b565be49f95931e7da36742efeb45a4619351acbe70edb511c5 WHIRLPOOL ace3cb441038e09888a2985e2f23149bcaa665d311a2bbd583648e17aeee4453168fc5e9df68b8fcd6acf772e1e4b4e33329643cb840f3355b2a1f420763bcb1
DIST picard-1.3.2.tar.gz 2047760 SHA256 e728234560b82eb33d3143a53d3bbb92833455fd130f8d2083193cffceea4120 SHA512 d5613dd0b29f67a754a9449c6ebb29e4f7a519137dbcd29b03e64678ba49c75542573487c1f95047c0ab43630794fd92365a46dc9820347ffd2eae5a04e531be WHIRLPOOL 5c3cbd5860162ede0150f7e680d7732f38c875e5475fb16dfac2f6f7d51979678567fe677a2887197db963fdf1a75f1ba4f45d132e9fc0923a2d726ffe30a019
DIST picard-1.4.1.tar.gz 2101829 SHA256 994c7f835e1adbd7905e88af841ee6e7c249dc75b8be9963b1b3dc6cb8de6a4a SHA512 3b9508101a52bfde060d9503f11a3c3fd6955c114c46c07ba6f299471f3682cf22b97c955c2b6990bd245fac30626fdbd17d1cb7b23b17839a51ec91091cc42d WHIRLPOOL 4a771205f621b0c9ffab43f0af830382d6af6b57085ac9ef00538758e7e1d6499f3283c6ecd46d23c01aa205a2c3e704e04d345c5cd8ac00b8dc6440a6e149ed
68 changes: 68 additions & 0 deletions media-sound/picard/picard-1.4.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python2_7 )
DISTUTILS_SINGLE_IMPL=1
DISABLE_AUTOFORMATTING=true
inherit distutils-r1 readme.gentoo-r1

DESCRIPTION="A cross-platform music tagger"
HOMEPAGE="https://picard.musicbrainz.org"
SRC_URI="http://ftp.musicbrainz.org/pub/musicbrainz/picard/${P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="nls"

DEPEND="
dev-python/PyQt4[X,${PYTHON_USEDEP}]
dev-qt/qtgui:4[accessibility]
media-libs/mutagen"
RDEPEND="${DEPEND}"

RESTRICT="test" # doesn't work with ebuilds
S="${WORKDIR}/${PN}-release-${PV}"

DOCS=( AUTHORS.txt NEWS.txt README.md )

DOC_CONTENTS="Install optional package media-libs/chromaprint[tools] to enable
calculation and lookup of AcoustID fingerprints.
Install optional package dev-python/python-discid to enable
calculation and lookup of compact disc identifiers (disc IDs).
If you are upgrading Picard and it does not start, try removing
Picard's settings:
rm ~/.config/MusicBrainz/Picard.conf"

python_compile() {
local build_args=(
--disable-autoupdate
)
if ! use nls; then
build_args+=( --disable-locales )
fi
distutils-r1_python_compile ${build_args[@]}
}

python_install() {
local install_args=(
--disable-autoupdate
--skip-build
)
if ! use nls; then
install_args+=( --disable-locales )
fi
distutils-r1_python_install ${install_args[@]}
}

python_install_all() {
distutils-r1_python_install_all
readme.gentoo_create_doc
}

pkg_postinst() {
readme.gentoo_print_elog
}

0 comments on commit cb1f060

Please sign in to comment.