Skip to content

Commit

Permalink
games-board/cockatrice: Add version bump 20200823
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/759505
Package-Manager: Portage-3.0.9, Repoman-3.0.2
Signed-off-by: Guillaume Seren <[email protected]>
Signed-off-by: James Le Cuirot <[email protected]>
  • Loading branch information
GuillaumeSeren authored and chewi committed Jan 24, 2021
1 parent be9394f commit cb81a05
Show file tree
Hide file tree
Showing 2 changed files with 65 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-board/cockatrice/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cockatrice-20190304.tar.gz 8464830 BLAKE2B 6e6b41593d7eddc8599fa894eed63f993fb69888c57fdfc4a45d71e6e7990d7d716663b69902139f5fd7ead455acdba76ac1d649977e26dceb2948293c34b74e SHA512 6a76e5de2aa7a4d2c9943bee9225ebf01aca7679bcd2542450b7e8b919e401992019f5bfb69597e8845bb2d8db568d7a6549600b85b576f9fb29be712bbfc9e5
DIST cockatrice-20200823.tar.gz 8503044 BLAKE2B a987418b25db53e5fc42627e3efa93ee7348ff341d7cf844647c6655b00bb76f2929cff91c6a1d199525fba2785f4d5da533c934ad483636af1979d52f8eea94 SHA512 0fa919009536238cd540db6ef01271a41f96aa40a3d40b468fbc400905dbdfe914cfb785f62f8135355c64cc8fef19a83604aee1ad4420bb73c8f31b9d48e48b
64 changes: 64 additions & 0 deletions games-board/cockatrice/cockatrice-20200823.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit xdg cmake

MY_PV="2020-08-23-Release-2.7.5"
DESCRIPTION="An open-source multiplatform software for playing card games over a network"
HOMEPAGE="https://github.com/Cockatrice/Cockatrice"
SRC_URI="https://github.com/Cockatrice/Cockatrice/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+client +oracle test server"
RESTRICT="!test? ( test )"

RDEPEND="
dev-qt/qtconcurrent:5
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5[ssl]
dev-qt/qtprintsupport:5
dev-qt/qtwebsockets:5
dev-qt/qtwidgets:5
client? (
dev-libs/protobuf:=
dev-qt/qtmultimedia:5
dev-qt/qtsvg:5
)
oracle? ( sys-libs/zlib )
server? (
dev-libs/protobuf:=
dev-qt/qtsql:5
)
"
BDEPEND="
dev-qt/linguist-tools:5
client? ( dev-libs/protobuf )
server? ( dev-libs/protobuf )
test? ( dev-cpp/gtest )
"
DEPEND="${RDEPEND}"

S="${WORKDIR}/Cockatrice-${MY_PV}"

src_configure() {
local mycmakeargs=(
-DBUILD_SHARED_LIBS=OFF
-DUSE_CCACHE=OFF
-DWITH_CLIENT=$(usex client)
-DWITH_ORACLE=$(usex oracle)
-DWITH_SERVER=$(usex server)
-DTEST=$(usex test)
-DICONDIR="${EPREFIX}/usr/share/icons"
-DDESKTOPDIR="${EPREFIX}/usr/share/applications" )

# Add date in the help about, come from git originally
sed -e 's/^set(PROJECT_VERSION_FRIENDLY.*/set(PROJECT_VERSION_FRIENDLY \"'${MY_PV}'\")/' \
-i cmake/getversion.cmake || die "sed failed!"

cmake_src_configure
}

0 comments on commit cb81a05

Please sign in to comment.