Skip to content

Commit

Permalink
app-misc/vcontrold: Daemon for comm with Viessmann Vito heatings
Browse files Browse the repository at this point in the history
  • Loading branch information
Tobias Leupold authored and mgorny committed Feb 9, 2018
1 parent 3a0c07e commit cb927f9
Show file tree
Hide file tree
Showing 4 changed files with 77 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/vcontrold/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST vcontrold-0.98.5.tar.gz 86684 BLAKE2B 07ed2c932b9f1c03410cbd6c23cfbfb7bf1aeaff027f597fb6f05a6b61c647f229a75b5a87d893a66c6b8e917595083d193c5da8585c6b9546d12c5867ca1a1b SHA512 b94dbb09ffe274e0a0a0ac4948365ed3213f221dbc00ed2b2adec2ac5a632e293686d62a07575454b3d11b1b8e4e058625a067461996dd720c2f84066d57e60e
5 changes: 5 additions & 0 deletions app-misc/vcontrold/files/vcontrold
Original file line number Diff line number Diff line change
@@ -0,0 +1,5 @@
#!/sbin/openrc-run
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

command="/usr/sbin/vcontrold"
28 changes: 28 additions & 0 deletions app-misc/vcontrold/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Tobias Leupold</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
<longdescription lang="en">
Vcontrold can be used for communication with Viessmann Vito heatings
through their Optolink interface using an optical communication device
(which can be built quite cheap and easily, cf. the homepage of the
"OpenV" project).
</longdescription>
<use>
<flag name="man">Build the manpages</flag>
<flag name="vclient">
Build the vclient helper program to talk to vcontrold
</flag>
<flag name="vsim">
Build the vsim helper program (simulates the heating's answers, for
development and debugging)
</flag>
</use>
</pkgmetadata>
43 changes: 43 additions & 0 deletions app-misc/vcontrold/vcontrold-0.98.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils

DESCRIPTION="Daemon for communication with Viessmann Vito heatings"
HOMEPAGE="https://github.com/openv/vcontrold/"
SRC_URI="https://github.com/openv/vcontrold/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="+man +vclient vsim"

RDEPEND="dev-libs/libxml2"
DEPEND="${RDEPEND}
man? ( dev-python/docutils )"

src_prepare() {
sed "s/@VERSION@/${PV}/" "src/version.h.in" \
> "src/version.h" || die "Setting version failed"

cmake-utils_src_prepare
}

src_configure() {
local mycmakeargs=(
-DMANPAGES="$(usex man)"
-DVCLIENT="$(usex vclient)"
-DVSIM="$(usex vsim)"
)

cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install
doinitd "${FILESDIR}/vcontrold"
insinto /etc/vcontrold/
doins -r xml
}

0 comments on commit cb927f9

Please sign in to comment.