Skip to content

Commit

Permalink
kde-frameworks/knotifications: Fix USE=dbus build switch
Browse files Browse the repository at this point in the history
Reported-by: [email protected]
Gentoo-bug: 616072

Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
a17r committed Apr 20, 2017
1 parent 670769d commit cb9a470
Showing 1 changed file with 45 additions and 0 deletions.
45 changes: 45 additions & 0 deletions kde-frameworks/knotifications/knotifications-5.33.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

KDE_TEST="false"
inherit kde5

DESCRIPTION="Framework for notifying the user of an event"
LICENSE="LGPL-2.1+"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="dbus nls speech X"

# drop qtgui subslot operator when QT_MINIMAL >= 5.7.0
RDEPEND="
$(add_frameworks_dep kcodecs)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kwindowsystem)
$(add_qt_dep qtdbus)
$(add_qt_dep qtgui '' '' '5=')
$(add_qt_dep qtwidgets)
media-libs/phonon[qt5]
dbus? ( dev-libs/libdbusmenu-qt[qt5] )
speech? ( $(add_qt_dep qtspeech) )
X? (
$(add_qt_dep qtx11extras)
x11-libs/libX11
x11-libs/libXtst
)
"
DEPEND="${RDEPEND}
nls? ( $(add_qt_dep linguist-tools) )
X? ( x11-proto/xproto )
"

src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package dbus dbusmenu-qt5)
$(cmake-utils_use_find_package speech Qt5TextToSpeech)
$(cmake-utils_use_find_package X X11)
)

kde5_src_configure
}

0 comments on commit cb9a470

Please sign in to comment.